aboutsummaryrefslogtreecommitdiffstats
path: root/misc/reed
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:37:04 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:37:04 +0800
commit85c12c34c576d6d32aff6e6ec06b17543c38c87d (patch)
tree6794eb3e25eb77e16d8bdb99daeaecdcf3ab7f7c /misc/reed
parent38e9fcc1ad49abf15de3a0486aae1d40fd6b5b40 (diff)
downloadfreebsd-ports-gnome-85c12c34c576d6d32aff6e6ec06b17543c38c87d.tar.gz
freebsd-ports-gnome-85c12c34c576d6d32aff6e6ec06b17543c38c87d.tar.zst
freebsd-ports-gnome-85c12c34c576d6d32aff6e6ec06b17543c38c87d.zip
get rid of libgnugetopt dependency.
This port does not use getopt_long(); use getopt() in libc instead.
Diffstat (limited to 'misc/reed')
-rw-r--r--misc/reed/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/misc/reed/Makefile b/misc/reed/Makefile
index f0adad1f7264..1f5335d58dd3 100644
--- a/misc/reed/Makefile
+++ b/misc/reed/Makefile
@@ -7,26 +7,24 @@
PORTNAME= reed
PORTVERSION= 5.4
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.sacredchao.net/software/reed/
MAINTAINER= petef@FreeBSD.org
COMMENT= A text pager with autoscrolling and more
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configures
-CONFIGURE_ENV= INCDIR="${LOCALBASE}/include"
-
-CFLAGS+= -I${LOCALBASE}/include
MAN1= breed.1 reed.1 wrap.1
post-patch:
- @${PERL} -pi -e 's!/usr/local/!${PREFIX}!g' ${WRKSRC}/configures
- @${PERL} -pi -e 's!sys/dir.h!dirent.h!g' ${WRKSRC}/reed.c
+ @${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/configures
+ @${PERL} -pi -e 's!sys/dir.h!dirent.h!g;s!.*getopt.h.*\n!!' \
+ ${WRKSRC}/reed.c
+ @${PERL} -pi -e 's!getopt.h !!' ${WRKSRC}/cfg.data
@${PERL} -pi -e 's!-O2!${CFLAGS}!' ${WRKSRC}/Makefile.in
@${PERL} -pi -e 's!^#!/usr/bin/perl!#!${PERL}!' \
${WRKSRC}/fix_bookmarks.pl