aboutsummaryrefslogtreecommitdiffstats
path: root/misc/rump/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-10-06 14:27:43 +0800
committervanilla <vanilla@FreeBSD.org>2017-10-06 14:27:43 +0800
commitce7a148bde9bafba19bfffce58fc3f1ef2ecc8fe (patch)
tree10b66bfe504d45958c3a86d4b488bd9e19094031 /misc/rump/Makefile
parent59a33566c863b980585f5b2d80fa33df68531016 (diff)
downloadfreebsd-ports-gnome-ce7a148bde9bafba19bfffce58fc3f1ef2ecc8fe.tar.gz
freebsd-ports-gnome-ce7a148bde9bafba19bfffce58fc3f1ef2ecc8fe.tar.zst
freebsd-ports-gnome-ce7a148bde9bafba19bfffce58fc3f1ef2ecc8fe.zip
Fix building with clang.
Diffstat (limited to 'misc/rump/Makefile')
-rw-r--r--misc/rump/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/misc/rump/Makefile b/misc/rump/Makefile
index 5cfd4f282fe8..c15f19dbbfbc 100644
--- a/misc/rump/Makefile
+++ b/misc/rump/Makefile
@@ -18,11 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= rumpkernel
GH_PROJECT= buildrump.sh
GH_TAGNAME= b914579
-GH_TUPLE= rumpkernel:src-netbsd:82f3a69:netbsd/src
+GH_TUPLE= rumpkernel:src-netbsd:82f3a69:netbsd/src
USE_LDCONFIG= yes
-USE_GCC= any
-
-.include <bsd.port.pre.mk>
do-build:
cd ${WRKSRC}; ${SETENV} CC=${CC} AR=${AR} NM=${NM} OBJCOPY=${OBJCOPY} ./buildrump.sh -r fullbuild
@@ -30,4 +27,4 @@ do-build:
do-install:
cd ${WRKSRC}/rump; ${PAX} -wr lib include ${STAGEDIR}${PREFIX}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>