aboutsummaryrefslogtreecommitdiffstats
path: root/misc/since/files
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2010-05-20 23:14:14 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2010-05-20 23:14:14 +0800
commitae702786894b37c4e57062f592a1720c37486bd1 (patch)
tree1f98351d9fb76ad6bf9f4765fb7cc5477ba1974c /misc/since/files
parentc977f98c2162f9fd2047cbd79a9f088857bb70aa (diff)
downloadfreebsd-ports-gnome-ae702786894b37c4e57062f592a1720c37486bd1.tar.gz
freebsd-ports-gnome-ae702786894b37c4e57062f592a1720c37486bd1.tar.zst
freebsd-ports-gnome-ae702786894b37c4e57062f592a1720c37486bd1.zip
- Update to 1.0
Submitted by: portscout via miwibot
Diffstat (limited to 'misc/since/files')
-rw-r--r--misc/since/files/patch-Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/misc/since/files/patch-Makefile b/misc/since/files/patch-Makefile
index 845acf7acd30..51abe84e0e21 100644
--- a/misc/since/files/patch-Makefile
+++ b/misc/since/files/patch-Makefile
@@ -1,27 +1,29 @@
---- ./Makefile.orig 2009-01-05 15:52:55.000000000 -0500
-+++ ./Makefile 2009-06-17 14:05:36.000000000 -0400
-@@ -1,4 +1,4 @@
--prefix=/usr/local
-+#prefix=/usr/local
+--- ./Makefile.orig 2009-07-11 16:45:30.000000000 -0400
++++ ./Makefile 2010-05-20 10:53:02.000000000 -0400
+@@ -1,25 +1,22 @@
+ # IMHO auto{make,conf} is overkill. Simple, readable makefiles improve security
+-prefix=/usr/local
NAME = since
- VERSION = 0.9
-@@ -9,16 +9,16 @@
+ VERSION = 1.0
+
+-CFLAGS = -Wall -O2 -DVERSION=\"$(VERSION)\"
++CFLAGS += -Wall -DVERSION=\"$(VERSION)\"
+ # disable/enable as desired
+ CFLAGS += $(shell test -f /usr/include/sys/inotify.h && echo -DUSE_INOTIFY)
CFLAGS += -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
#CFLAGS += -DDEBUG
-CC = gcc
-+#CC = gcc
RM = rm -f
-INSTALL = install -D
-+#INSTALL = install -D
$(NAME): $(NAME).c
$(CC) $(CFLAGS) -o $@ $^
install: $(NAME)
- $(INSTALL) $(NAME) $(prefix)/bin/$(NAME)
-- $(INSTALL) $(NAME).1 $(prefix)/share/man1/$(NAME).1
+- $(INSTALL) $(NAME).1 $(prefix)/share/man/man1/$(NAME).1
+ $(BSD_INSTALL_PROGRAM) $(NAME) $(PREFIX)/bin/$(NAME)
+ $(BSD_INSTALL_MAN) $(NAME).1 $(PREFIX)/man/man1/$(NAME).1