aboutsummaryrefslogtreecommitdiffstats
path: root/misc/sword-modules
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
commit5b243306947e74184be0fc39cd0f0d1eb8063940 (patch)
treecea3c8a6099c3422b99712692a2c3e0e2964a6d2 /misc/sword-modules
parentf6e00c6523a54ccae8d9221d4c43c1bebbe1592d (diff)
downloadfreebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.gz
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.zst
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'misc/sword-modules')
-rw-r--r--misc/sword-modules/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/misc/sword-modules/Makefile b/misc/sword-modules/Makefile
index b6f4297eadbb..e090de95cdfd 100644
--- a/misc/sword-modules/Makefile
+++ b/misc/sword-modules/Makefile
@@ -70,12 +70,12 @@ post-install:
for i in ${MODULE_FILES}; do \
tfiles=`${EXTRACT_CMD} -Z -1 ${DISTDIR}/${DIST_SUBDIR}/$${i}`; \
for j in $${tfiles}; do \
- ${ECHO} "share/sword/$${j}" >>${TMPPLIST}; \
- if [ "`${ECHO} $${j} | ${GREP} -v mods.d`" ]; then \
+ ${ECHO_CMD} "share/sword/$${j}" >>${TMPPLIST}; \
+ if [ "`${ECHO_CMD} $${j} | ${GREP} -v mods.d`" ]; then \
dirn=`${DIRNAME} $${j}`; \
while [ "$${dirn}" -a "$${dirn}" != "." -a \
"$${dirn}" != "/" ]; do \
- if [ ! "`${ECHO} \"$${tdirs}\" | ${GREP} \"$${dirn} \"`" ]; then \
+ if [ ! "`${ECHO_CMD} \"$${tdirs}\" | ${GREP} \"$${dirn} \"`" ]; then \
tdirs="$${tdirs}$${dirn} "; \
fi; \
dirn=`${DIRNAME} $${dirn}`; \
@@ -85,8 +85,8 @@ post-install:
done; \
ksorted=`for k in $${tdirs}; do printf "%s\n" $${k}; done | ${SORT} -r -t" "`;\
for j in $${ksorted}; do \
- ${ECHO} "@dirrm share/sword/$${j}" >>${TMPPLIST}; \
+ ${ECHO_CMD} "@dirrm share/sword/$${j}" >>${TMPPLIST}; \
done; \
- ${ECHO} "@dirrm share/sword/mods.d" >>${TMPPLIST};
+ ${ECHO_CMD} "@dirrm share/sword/mods.d" >>${TMPPLIST};
.include <bsd.port.mk>