aboutsummaryrefslogtreecommitdiffstats
path: root/misc/wmweather+
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-17 12:17:42 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-17 12:17:42 +0800
commit26b53a52df5c3d5d48107160051cf3657610d594 (patch)
treeefed6ae9600534ba689767bd1ff4b90002e2d721 /misc/wmweather+
parent6d20133127f2b6bf37bc5dd653a34931be467d60 (diff)
downloadfreebsd-ports-gnome-26b53a52df5c3d5d48107160051cf3657610d594.tar.gz
freebsd-ports-gnome-26b53a52df5c3d5d48107160051cf3657610d594.tar.zst
freebsd-ports-gnome-26b53a52df5c3d5d48107160051cf3657610d594.zip
- Update to 2.15
- Change master sites, add icon - Use the new format for LIB_DEPENDS - Add Desktop entry file - Support STAGEDIR - Change REINPLACE_CMD, ajdust NOAA site - Change pkg-message
Diffstat (limited to 'misc/wmweather+')
-rw-r--r--misc/wmweather+/Makefile80
-rw-r--r--misc/wmweather+/distinfo6
-rw-r--r--misc/wmweather+/files/pkg-message.in7
3 files changed, 51 insertions, 42 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index 650b2c935159..3036e5ab62cf 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -1,51 +1,54 @@
# Created by: Harald Wille <harald.wille@students.jku.at>
# $FreeBSD$
-PORTNAME= wmweather+
-PORTVERSION= 2.13
-PORTREVISION= 1
-CATEGORIES= misc windowmaker geography
-MASTER_SITES= SF/wmweatherplus/wmweather%2B/
-DISTNAME= wmweather%2B-${PORTVERSION}
+PORTNAME= wmweather+
+PORTVERSION= 2.15
+CATEGORIES= misc windowmaker geography
+MASTER_SITES= SF/wmweatherplus/wmweather%2B/ \
+ SF/nemysisfreebsdp/misc/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Displays current conditions and forecasts with icons and text
LICENSE= GPLv2
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- pcre:${PORTSDIR}/devel/pcre \
- tiff:${PORTSDIR}/graphics/tiff \
- Hermes:${PORTSDIR}/graphics/Hermes \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- gif:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libHermes.so:${PORTSDIR}/graphics/Hermes \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libgif.so:${PORTSDIR}/graphics/giflib
WRKSRC= ${WRKDIR}/wmweather+-${PORTVERSION}
-GNU_CONFIGURE= yes
USES= iconv
USE_XORG= xpm
-
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-libwraster=${LOCALBASE} \
--with-libpcre=${LOCALBASE} \
--with-libcurl=${LOCALBASE} \
--with-xpm-includes=${LOCALBASE} \
--with-xpm-libraries=${LOCALBASE}
-PORTEXAMPLES= HINTS example.conf
-PORTDOCS= ChangeLog README
-
SUB_FILES= pkg-message
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDOCS= ChangeLog README
+PORTEXAMPLES= HINTS example.conf
+
OPTIONS_DEFINE= DOCS EXAMPLES WM
WM_DESC= Depend on Window Maker port (otherwise only libwraster)
-MAN1= wmweather+.1
-
-PLIST_FILES= bin/wmweather+
+DESKTOP_ENTRIES="${PORTNAME}" "" "${PORTNAME}" \
+ "${PORTNAME}" "System;Monitor;" ""
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MWM}
@@ -55,27 +58,24 @@ LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/libwraster
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|void usage(int i) __THROW __attribute__ ((__noreturn__));|void usage(int i);|' \
- ${WRKSRC}/wmweather+.c
+ @${REINPLACE_CMD} -e 's| __THROW __attribute__ ((__noreturn__))|| ; \
+ s|http://www.nws.noaa.gov/tg/siteloc.shtml|http://www.nws.noaa.gov/tg/siteloc.php|' \
+ ${WRKSRC}/${PORTNAME}.c
+ @${REINPLACE_CMD} -e \
+ 's|http://www.nws.noaa.gov/tg/siteloc.shtml|http://www.nws.noaa.gov/tg/siteloc.php|' \
+ ${WRKSRC}/${PORTNAME}.1.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/HINTS ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/misc/wmweather+/distinfo b/misc/wmweather+/distinfo
index 7f4d65e600f9..661843d005d6 100644
--- a/misc/wmweather+/distinfo
+++ b/misc/wmweather+/distinfo
@@ -1,2 +1,4 @@
-SHA256 (wmweather%2B-2.13.tar.gz) = d15d8f491022e2f092d91a3a463b3200a4ac620ac93b0ecff796751d28e997d2
-SIZE (wmweather%2B-2.13.tar.gz) = 195094
+SHA256 (wmweather+-2.15.tar.gz) = 3e7931527a1b5e8def17abc2987ec43508a2cc3394c2f340b6e0062e5bfadbd1
+SIZE (wmweather+-2.15.tar.gz) = 209258
+SHA256 (wmweather+.png) = 4330af568e7b460882c6afeee9aadd2b71ec01cbbdc649819b96d049be48288b
+SIZE (wmweather+.png) = 5730
diff --git a/misc/wmweather+/files/pkg-message.in b/misc/wmweather+/files/pkg-message.in
index 82c1894b074d..0d6b7f1420c4 100644
--- a/misc/wmweather+/files/pkg-message.in
+++ b/misc/wmweather+/files/pkg-message.in
@@ -6,7 +6,14 @@ All options are given in the config file and in command line (CLI)
Please copy example.conf to yours home directory and adjust it to your needs!
+ su user
+
mkdir ~/.wmweather+
+
cp -a %%EXAMPLESDIR%%/example.conf ~/.wmweather+/conf
+ exit
+
+Have fun!
+
===============================================================================