aboutsummaryrefslogtreecommitdiffstats
path: root/misc/wmweather+
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-03-16 02:05:28 +0800
committerpawel <pawel@FreeBSD.org>2013-03-16 02:05:28 +0800
commit3f1113d4e3dc5e68d5f780cc579d8f1bcf31dc47 (patch)
treee5a23d25052950a4eea3fcbfa6a8c904f26cfa20 /misc/wmweather+
parentea4c08506b21154619767b2cec2972e978e02497 (diff)
downloadfreebsd-ports-gnome-3f1113d4e3dc5e68d5f780cc579d8f1bcf31dc47.tar.gz
freebsd-ports-gnome-3f1113d4e3dc5e68d5f780cc579d8f1bcf31dc47.tar.zst
freebsd-ports-gnome-3f1113d4e3dc5e68d5f780cc579d8f1bcf31dc47.zip
- Update to version 2.13
- Add license info - Use pkg-message file to display configure tips - Support DOCS option - Give maintainership to submitter PR: ports/174099 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'misc/wmweather+')
-rw-r--r--misc/wmweather+/Makefile58
-rw-r--r--misc/wmweather+/distinfo4
-rw-r--r--misc/wmweather+/files/pkg-message.in12
-rw-r--r--misc/wmweather+/pkg-descr8
4 files changed, 45 insertions, 37 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index da8b691024fc..2a6f28dbc7af 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -2,22 +2,25 @@
# $FreeBSD$
PORTNAME= wmweather+
-PORTVERSION= 2.11
-PORTREVISION= 7
+PORTVERSION= 2.13
CATEGORIES= misc windowmaker geography
MASTER_SITES= SF/wmweatherplus/wmweather%2B/
DISTNAME= wmweather%2B-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Displays current conditions and forecasts with icons and text
+LICENSE= GPLv2
+
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
pcre:${PORTSDIR}/devel/pcre \
tiff:${PORTSDIR}/graphics/tiff \
Hermes:${PORTSDIR}/graphics/Hermes \
png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
- gif.5:${PORTSDIR}/graphics/giflib
+ gif:${PORTSDIR}/graphics/giflib
+
+WRKSRC= ${WRKDIR}/wmweather+-${PORTVERSION}
GNU_CONFIGURE= yes
USE_ICONV= yes
@@ -29,8 +32,12 @@ CONFIGURE_ARGS+= --with-libwraster=${LOCALBASE} \
--with-xpm-includes=${LOCALBASE} \
--with-xpm-libraries=${LOCALBASE}
-OPTIONS_DEFINE= WM EXAMPLES
-OPTIONS_DEFAULT= WM
+PORTEXAMPLES= HINTS example.conf
+PORTDOCS= ChangeLog README
+
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS EXAMPLES WM
WM_DESC= Depend on Window Maker port (otherwise only libwraster)
MAN1= wmweather+.1
@@ -39,45 +46,34 @@ PLIST_FILES= bin/wmweather+
.include <bsd.port.options.mk>
-CFLAGS:= ${CFLAGS:C/-O[0-9]/-O0/}
-
.if ${PORT_OPTIONS:MWM}
LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/windowmaker
.else
LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/libwraster
.endif
-WRKSRC= ${WRKDIR}/wmweather+-${PORTVERSION}
-
post-patch:
- @${CP} ${WRKSRC}/wmweather+.c ${WRKSRC}/wmweather+.c.dist
- @${SED} -e "s#^void usage(int i) __THROW.*#void usage(int i);#" \
- ${WRKSRC}/wmweather+.c.dist > ${WRKSRC}/wmweather+.c
+ @${REINPLACE_CMD} -e 's|void usage(int i) __THROW __attribute__ ((__noreturn__));|void usage(int i);|' \
+ ${WRKSRC}/wmweather+.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wmweather+ ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/wmweather+.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/HINTS ${EXAMPLESDIR}/HINTS
- ${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}/example.conf
-PLIST_FILES+= ${EXAMPLESDIR_REL}/HINTS
-PLIST_FILES+= ${EXAMPLESDIR_REL}/example.conf
-PLIST_DIRS+= ${EXAMPLESDIR_REL}
-PM= ${WRKDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
+ ${INSTALL_DATA} ${WRKSRC}/HINTS ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}
.endif
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${ECHO} "===================================================" > ${PM}
- @${ECHO} "A sample configuration file has been copied to" >> ${PM}
- @${ECHO} "${EXAMPLESDIR}/example.conf" >> ${PM}
- @${ECHO} "" >> ${PM}
- @${ECHO} "Please copy it to ~/.wmweather+/conf and adjust it" >> ${PM}
- @${ECHO} "to your needs!" >> ${PM}
- @${ECHO} "===================================================" >> ${PM}
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
-.endif
+ @${ECHO_CMD}
.include <bsd.port.mk>
diff --git a/misc/wmweather+/distinfo b/misc/wmweather+/distinfo
index 36a93565755f..7f4d65e600f9 100644
--- a/misc/wmweather+/distinfo
+++ b/misc/wmweather+/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wmweather%2B-2.11.tar.gz) = bab0d2d2cac65db51bb25f70b028ee7c55642119d2b38441aff65553a35566f9
-SIZE (wmweather%2B-2.11.tar.gz) = 193596
+SHA256 (wmweather%2B-2.13.tar.gz) = d15d8f491022e2f092d91a3a463b3200a4ac620ac93b0ecff796751d28e997d2
+SIZE (wmweather%2B-2.13.tar.gz) = 195094
diff --git a/misc/wmweather+/files/pkg-message.in b/misc/wmweather+/files/pkg-message.in
new file mode 100644
index 000000000000..82c1894b074d
--- /dev/null
+++ b/misc/wmweather+/files/pkg-message.in
@@ -0,0 +1,12 @@
+===============================================================================
+
+wmweather+ has been installed.
+
+All options are given in the config file and in command line (CLI)
+
+Please copy example.conf to yours home directory and adjust it to your needs!
+
+ mkdir ~/.wmweather+
+ cp -a %%EXAMPLESDIR%%/example.conf ~/.wmweather+/conf
+
+===============================================================================
diff --git a/misc/wmweather+/pkg-descr b/misc/wmweather+/pkg-descr
index f4c22fe5e469..ff85cc698b4a 100644
--- a/misc/wmweather+/pkg-descr
+++ b/misc/wmweather+/pkg-descr
@@ -1,7 +1,7 @@
-wmweather+ will download the National Weather Serivce METAR bulletins,
-ANV and MRF forecasts, and any weather map for display in a WindowMaker
-dockapp. Think wmweather with a smaller font, forecasts, a weather map,
-and a sky condition display.
+wmweather+ will download the National Weather Serivce METAR bulletins;
+AVN, ETA, and MRF forecasts; and any weather map for display in a
+WindowMaker dockapp. Think wmweather with a smaller font, forecasts,
+a weather map, and a sky condition display.
You will need to look up the METAR code for your city (a standard code
used in aviation).