aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 11:00:46 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 11:00:46 +0800
commit037277c495c4a69f56029e71eecf6838910561c8 (patch)
tree728a3619568ce38b9188fc0b8717a16a880d52d3 /misc
parent944f55c3adc149ff34c18999a68dd201bd55600a (diff)
downloadfreebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.tar.gz
freebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.tar.zst
freebsd-ports-gnome-037277c495c4a69f56029e71eecf6838910561c8.zip
Add DOCS option for ports with PORTDOCS in plist.
Diffstat (limited to 'misc')
-rw-r--r--misc/getopt/Makefile2
-rw-r--r--misc/linm/Makefile2
-rw-r--r--misc/ruby-progressbar/Makefile2
-rw-r--r--misc/tcb/Makefile2
-rw-r--r--misc/terraform/Makefile2
-rw-r--r--misc/wmScoreBoard/Makefile2
-rw-r--r--misc/xiphos/Makefile2
-rw-r--r--misc/ytree/Makefile2
8 files changed, 14 insertions, 2 deletions
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index 0e1f739eb0c9..0ad98b2faf7d 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -17,6 +17,8 @@ MAKE_ENV+= LIBCGETOPT=0
DOCS= Changelog README
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|' ${WRKSRC}/Makefile
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index c11a88a6077b..efd180a1de76 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -26,7 +26,7 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= SMB
+OPTIONS_DEFINE= SMB DOCS
.include <bsd.port.options.mk>
diff --git a/misc/ruby-progressbar/Makefile b/misc/ruby-progressbar/Makefile
index c0e85efe4ad5..a66b7f58cc4a 100644
--- a/misc/ruby-progressbar/Makefile
+++ b/misc/ruby-progressbar/Makefile
@@ -18,6 +18,8 @@ NO_BUILD= yes
RUBY_RD_FILES= progressbar.en.rd progressbar.ja.rd
DOCS= ChangeLog ${RUBY_RD_FILES}
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTNAME}.rb ${STAGEDIR}${RUBY_SITELIBDIR}
diff --git a/misc/tcb/Makefile b/misc/tcb/Makefile
index fa589631e0ff..f8f65cf29937 100644
--- a/misc/tcb/Makefile
+++ b/misc/tcb/Makefile
@@ -13,6 +13,8 @@ COMMENT= File viewer for terminal
USES= gmake
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/tcb ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/share/tcb
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
index bb9f4fbeeec1..53c1a82e4fe9 100644
--- a/misc/terraform/Makefile
+++ b/misc/terraform/Makefile
@@ -28,7 +28,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DOCS= DOCS
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s| desktop-links docs | |' \
diff --git a/misc/wmScoreBoard/Makefile b/misc/wmScoreBoard/Makefile
index c25b247f7143..d28365dafd44 100644
--- a/misc/wmScoreBoard/Makefile
+++ b/misc/wmScoreBoard/Makefile
@@ -20,6 +20,8 @@ USE_XORG= xpm
USES= gmake shebangfix
SHEBANG_FILES= GrabScores.excite
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmScoreBoard ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/GrabScores.excite ${STAGEDIR}${PREFIX}/bin
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 0493362e8f4c..cf4ff2faf6c6 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -24,6 +24,8 @@ INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomehack gnomeprefix gtkhtml3 intlhack libgsf
+OPTIONS_DEFINE= DOCS
+
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./waf configure \
--prefix=${STAGEDIR}${PREFIX} --destdir=${STAGEDIR}${PREFIX} \
diff --git a/misc/ytree/Makefile b/misc/ytree/Makefile
index b0b79eefe98c..d76b6f84e000 100644
--- a/misc/ytree/Makefile
+++ b/misc/ytree/Makefile
@@ -11,6 +11,8 @@ COMMENT= DOS-XTREE(tm) look-a-like file manager
ALL_TARGET= ytree
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ytree ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/ytree.conf ${STAGEDIR}${PREFIX}/etc/ytree.conf.sample