aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-11-24 04:27:28 +0800
committeryuri <yuri@FreeBSD.org>2019-11-24 04:27:28 +0800
commit09b1f1f07c4bf4ec25e95e7966123c942d5e15ca (patch)
tree2af923f101f1c952de89f5d351200dba5dc0a3a1 /misc
parent4abb7320be17f4390a991922b1e3cb72e32c0cd3 (diff)
downloadfreebsd-ports-gnome-09b1f1f07c4bf4ec25e95e7966123c942d5e15ca.tar.gz
freebsd-ports-gnome-09b1f1f07c4bf4ec25e95e7966123c942d5e15ca.tar.zst
freebsd-ports-gnome-09b1f1f07c4bf4ec25e95e7966123c942d5e15ca.zip
New port: misc/py-tflearn: Modular and transparent deep learning library on top of TensorFlow
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-tflearn/Makefile26
-rw-r--r--misc/py-tflearn/distinfo3
-rw-r--r--misc/py-tflearn/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 119054f04549..49f092f81a24 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -410,6 +410,7 @@
SUBDIR += py-spdx
SUBDIR += py-spdx-lookup
SUBDIR += py-spdx-tools
+ SUBDIR += py-tflearn
SUBDIR += py-toil
SUBDIR += py-tqdm
SUBDIR += py-yolk
diff --git a/misc/py-tflearn/Makefile b/misc/py-tflearn/Makefile
new file mode 100644
index 000000000000..d0fff514d9f2
--- /dev/null
+++ b/misc/py-tflearn/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= tflearn
+DISTVERSION= 0.3.2-53
+DISTVERSIONSUFFIX= -g5c23566
+CATEGORIES= misc python # machine-learning
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Modular and transparent deep learning library on top of TensorFlow
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tensorflow>0:science/py-tensorflow@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_GITHUB= yes
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-tflearn/distinfo b/misc/py-tflearn/distinfo
new file mode 100644
index 000000000000..756a8a83f607
--- /dev/null
+++ b/misc/py-tflearn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574540151
+SHA256 (tflearn-tflearn-0.3.2-53-g5c23566_GH0.tar.gz) = 0c48f347da46cf6321e2e7b48843c9b5c7282e8ffc8e5fe172e23ced3757257b
+SIZE (tflearn-tflearn-0.3.2-53-g5c23566_GH0.tar.gz) = 858607
diff --git a/misc/py-tflearn/pkg-descr b/misc/py-tflearn/pkg-descr
new file mode 100644
index 000000000000..009c4532b879
--- /dev/null
+++ b/misc/py-tflearn/pkg-descr
@@ -0,0 +1,6 @@
+TFlearn is a modular and transparent deep learning library built on top of
+Tensorflow. It was designed to provide a higher-level API to TensorFlow in
+order to facilitate and speed-up experimentations, while remaining fully
+transparent and compatible with it.
+
+WWW: http://tflearn.org/