aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-01-30 18:49:03 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-01-30 18:49:03 +0800
commit09c5ba1a9b62d7da4cca631b11f7f5fe9cc87076 (patch)
treeb000f06daa5e31d0384fb5634777b5fe0bd12da1 /misc
parentf316cf1d276752fe6ab785f16615388872ccc90a (diff)
downloadfreebsd-ports-gnome-09c5ba1a9b62d7da4cca631b11f7f5fe9cc87076.tar.gz
freebsd-ports-gnome-09c5ba1a9b62d7da4cca631b11f7f5fe9cc87076.tar.zst
freebsd-ports-gnome-09c5ba1a9b62d7da4cca631b11f7f5fe9cc87076.zip
Update to 3.3.12
Diffstat (limited to 'misc')
-rw-r--r--misc/gnu-watch/Makefile24
-rw-r--r--misc/gnu-watch/distinfo5
-rw-r--r--misc/gnu-watch/files/extrapatch-watch.c16
-rw-r--r--misc/gnu-watch/files/patch-Makefile.am97
-rw-r--r--misc/gnu-watch/files/patch-gnu-watch.175
-rw-r--r--misc/gnu-watch/files/patch-proc_sig.c26
-rw-r--r--misc/gnu-watch/files/patch-ps_display.c13
-rw-r--r--misc/gnu-watch/files/patch-ps_global.c12
-rw-r--r--misc/gnu-watch/files/patch-watch.c25
-rw-r--r--misc/gnu-watch/pkg-descr2
10 files changed, 191 insertions, 104 deletions
diff --git a/misc/gnu-watch/Makefile b/misc/gnu-watch/Makefile
index b427c884f429..cb343d50f9cc 100644
--- a/misc/gnu-watch/Makefile
+++ b/misc/gnu-watch/Makefile
@@ -2,29 +2,33 @@
# $FreeBSD$
PORTNAME= watch
-DISTVERSION= 3.2.8
+DISTVERSION= 3.3.12
CATEGORIES= misc
-MASTER_SITES= http://procps.sourceforge.net/ \
+MASTER_SITES= SF/procps-ng/Production \
LOCAL/ehaupt
PKGNAMEPREFIX= gnu-
-DISTNAME= procps-${DISTVERSION}
+DISTNAME= procps-ng-${DISTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= GNU watch command
LICENSE= GPLv2
-USES= ncurses
-LDFLAGS+= -lncurses
+GNU_CONFIGURE= yes
+USES= autoreconf gettext gmake libtool localbase:ldflags ncurses \
+ pkgconfig tar:xz
+USE_CSTD= gnu99
-PLIST_FILES= bin/${PKGBASE} man/man1/gnu-watch.1.gz
+OPTIONS_DEFINE= UNICODE
+OPTIONS_DEFAULT=UNICODE
+
+UNICODE_CONFIGURE_ENABLE= watch8bit
-do-build:
- ${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
- -o ${WRKSRC}/${PKGBASE}
+PLIST_FILES= bin/${PKGBASE} man/man1/gnu-watch.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PKGBASE} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PKGBASE}
${INSTALL_MAN} ${WRKSRC}/watch.1 \
${STAGEDIR}${MANPREFIX}/man/man1/${PKGBASE}.1
diff --git a/misc/gnu-watch/distinfo b/misc/gnu-watch/distinfo
index 334ece98d9b6..d721c29d0a27 100644
--- a/misc/gnu-watch/distinfo
+++ b/misc/gnu-watch/distinfo
@@ -1,2 +1,3 @@
-SHA256 (procps-3.2.8.tar.gz) = 11ed68d8a4433b91cd833deb714a3aa849c02aea738c42e6b4557982419c1535
-SIZE (procps-3.2.8.tar.gz) = 285758
+TIMESTAMP = 1485505846
+SHA256 (procps-ng-3.3.12.tar.xz) = 6ed65ab86318f37904e8f9014415a098bec5bc53653e5d9ab404f95ca5e1a7d4
+SIZE (procps-ng-3.3.12.tar.xz) = 845484
diff --git a/misc/gnu-watch/files/extrapatch-watch.c b/misc/gnu-watch/files/extrapatch-watch.c
deleted file mode 100644
index de8c97abfa4a..000000000000
--- a/misc/gnu-watch/files/extrapatch-watch.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- watch.c.orig Sat Jun 4 02:34:34 2005
-+++ watch.c Sat Jun 4 02:34:38 2005
-@@ -147,6 +147,13 @@
- setlocale(LC_ALL, "");
- progname = argv[0];
-
-+ float
-+ strtof(const char * restrict nptr, char ** restrict endptr)
-+ {
-+
-+ return ((float)strtod(nptr, endptr));
-+ }
-+
- while ((optc = getopt_long(argc, argv, "+d::hn:vt", longopts, (int *) 0))
- != EOF) {
- switch (optc) {
diff --git a/misc/gnu-watch/files/patch-Makefile.am b/misc/gnu-watch/files/patch-Makefile.am
new file mode 100644
index 000000000000..d17896e8ae6f
--- /dev/null
+++ b/misc/gnu-watch/files/patch-Makefile.am
@@ -0,0 +1,97 @@
+--- Makefile.am.orig 2016-07-09 22:40:44 UTC
++++ Makefile.am
+@@ -1,7 +1,4 @@
+-CYGWINFLAGS =
+-if CYGWIN
+- CYGWINFLAGS += -lintl
+-endif
++CYGWINFLAGS = -lintl
+
+ AM_CPPFLAGS = \
+ -include $(top_builddir)/config.h \
+@@ -24,19 +21,9 @@ LDADD = ./proc/libprocps.la $(CYGWINFLAG
+ transform = s/pscommand/ps/; $(program_transform_name)
+
+ bin_PROGRAMS = \
+- ps/pscommand \
+- free \
+- pgrep \
+- pkill \
+- pmap \
+- pwdx \
+- tload \
+- uptime \
+- vmstat \
+- w
++ ps/pscommand
+
+-sbin_PROGRAMS = \
+- sysctl
++sbin_PROGRAMS = #
+
+ lib_LTLIBRARIES = \
+ proc/libprocps.la
+@@ -73,29 +60,10 @@ dist_procpsng_DATA = \
+ Documentation/bugs.md \
+ Documentation/FAQ
+
+-if BUILD_PIDOF
+-bin_PROGRAMS += pidof
+-dist_man_MANS += pidof.1
+-pidof_SOURCES = pidof.c lib/fileutils.c
+-else
+- EXTRA_DIST += pidof.1
+-endif
+-
+-if BUILD_KILL
+-bin_PROGRAMS += kill
+-dist_man_MANS += kill.1
+-kill_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
+-else
+- EXTRA_DIST += kill.1
+-endif
+-
+ if WITH_NCURSES
+ bin_PROGRAMS += \
+- slabtop \
+- watch \
+- top/top
++ watch
+ dist_man_MANS += \
+- slabtop.1 \
+ watch.1 \
+ top/top.1
+ slabtop_SOURCES = slabtop.c lib/strutils.c lib/fileutils.c
+@@ -115,21 +83,6 @@ endif
+ top_top_LDADD = $(LDADD) @NCURSES_LIBS@ $(DL_LIB)
+ endif
+
+-if BUILD_SKILL
+-bin_PROGRAMS += \
+- skill \
+- snice
+-skill_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
+-snice_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
+-dist_man_MANS += \
+- skill.1 \
+- snice.1
+-else
+- EXTRA_DIST += \
+- skill.1 \
+- snice.1
+-endif
+-
+ free_SOURCES = free.c lib/strutils.c lib/fileutils.c
+ pgrep_SOURCES = pgrep.c lib/fileutils.c lib/nsutils.c
+ pkill_SOURCES = pgrep.c lib/fileutils.c lib/nsutils.c
+@@ -182,9 +135,7 @@ proc_libprocps_la_SOURCES = \
+ proc/version.c \
+ proc/version.h \
+ proc/wchan.c \
+- proc/wchan.h \
+- proc/whattime.c \
+- proc/whattime.h
++ proc/wchan.h
+
+ proc_libprocps_la_includedir = $(includedir)/proc/
+ proc_libprocps_la_include_HEADERS = \
diff --git a/misc/gnu-watch/files/patch-gnu-watch.1 b/misc/gnu-watch/files/patch-gnu-watch.1
deleted file mode 100644
index 3e0f58ee788c..000000000000
--- a/misc/gnu-watch/files/patch-gnu-watch.1
+++ /dev/null
@@ -1,75 +0,0 @@
---- watch.1.orig Sun Feb 9 08:05:25 2003
-+++ watch.1 Fri Jun 3 23:44:46 2005
-@@ -1,11 +1,11 @@
- .TH WATCH 1 "1999 Apr 3" " " "Linux User's Manual"
- .SH NAME
--watch \- execute a program periodically, showing output fullscreen
-+gnu-watch \- execute a program periodically, showing output fullscreen
- .SH SYNOPSIS
--.B watch
-+.B gnu-watch
- .I [\-dhvt] [\-n <seconds>] [\-\-differences[=cumulative]] [\-\-help] [\-\-interval=<seconds>] [\-\-no\-title] [\-\-version] <command>
- .SH DESCRIPTION
--.BR watch
-+.BR gnu-watch
- runs
- .I command
- repeatedly, displaying its output (the first screenfull). This allows you to
-@@ -30,7 +30,7 @@
- option turns off the header showing the interval, command, and current
- time at the top of the display, as well as the following blank line.
- .PP
--.BR watch
-+.BR gnu-watch
- will run until interrupted.
- .SH NOTE
- Note that
-@@ -42,33 +42,33 @@
- the first non-option argument). This means that flags after
- .I command
- don't get interpreted by
--.BR watch
-+.BR gnu-watch
- itself.
- .SH EXAMPLES
- .PP
- To watch for mail, you might do
- .IP
--watch \-n 60 from
-+gnu-watch \-n 60 from
- .PP
- To watch the contents of a directory change, you could use
- .IP
--watch \-d ls \-l
-+gnu-watch \-d ls \-l
- .PP
- If you're only interested in files owned by user joe, you might use
- .IP
--watch \-d 'ls \-l | fgrep joe'
-+gnu-watch \-d 'ls \-l | fgrep joe'
- .PP
- To see the effects of quoting, try these out
- .IP
--watch echo $$
-+gnu-watch echo $$
- .IP
--watch echo '$$'
-+gnu-watch echo '$$'
- .IP
--watch echo "'"'$$'"'"
-+gnu-watch echo "'"'$$'"'"
- .PP
- You can watch for your administrator to install the latest kernel with
- .IP
--watch uname -r
-+gnu-watch uname -r
- .PP
- (Just kidding.)
- .SH BUGS
-@@ -84,4 +84,5 @@
- .B watch
- was written by Tony Rems <rembo@unisoft.com> in 1991, with mods and
- corrections by Francois Pinard. It was reworked and new features added by
--Mike Coleman <mkc@acm.org> in 1999.
-+Mike Coleman <mkc@acm.org> in 1999. In 2005 it was modified for FreeBSD by
-+Emanuel Haupt <ehaupt@critical.ch>.
diff --git a/misc/gnu-watch/files/patch-proc_sig.c b/misc/gnu-watch/files/patch-proc_sig.c
new file mode 100644
index 000000000000..11d0b2d9f590
--- /dev/null
+++ b/misc/gnu-watch/files/patch-proc_sig.c
@@ -0,0 +1,26 @@
+--- proc/sig.c.orig 2016-07-09 21:49:25 UTC
++++ proc/sig.c
+@@ -82,7 +82,11 @@ static const mapstruct sigtable[] = {
+ {"INT", SIGINT},
+ {"KILL", SIGKILL},
+ {"PIPE", SIGPIPE},
++#ifdef __FreeBSD__
++ {"POLL", SIGIO},
++#else
+ {"POLL", SIGPOLL}, /* IO */
++#endif
+ {"PROF", SIGPROF},
+ {"PWR", SIGPWR},
+ {"QUIT", SIGQUIT},
+@@ -121,7 +125,11 @@ int signal_name_to_number(const char *re
+ if(!strncasecmp(name,"SIG",3)) name += 3;
+
+ if(!strcasecmp(name,"CLD")) return SIGCHLD;
++#ifdef __FreeBSD__
++ if(!strcasecmp(name,"IO")) return SIGIO;
++#else
+ if(!strcasecmp(name,"IO")) return SIGPOLL;
++#endif
+ if(!strcasecmp(name,"IOT")) return SIGABRT;
+
+ /* search the table */
diff --git a/misc/gnu-watch/files/patch-ps_display.c b/misc/gnu-watch/files/patch-ps_display.c
new file mode 100644
index 000000000000..cfc0e65bf8a9
--- /dev/null
+++ b/misc/gnu-watch/files/patch-ps_display.c
@@ -0,0 +1,13 @@
+--- ps/display.c.orig 2016-07-09 21:49:25 UTC
++++ ps/display.c
+@@ -26,7 +26,10 @@
+ #include <string.h>
+ #include <unistd.h>
+
++
++#ifndef __FreeBSD__
+ #include <sys/sysmacros.h>
++#endif
+ #include <sys/types.h>
+
+ #include "../proc/alloc.h"
diff --git a/misc/gnu-watch/files/patch-ps_global.c b/misc/gnu-watch/files/patch-ps_global.c
new file mode 100644
index 000000000000..14c37fe2b345
--- /dev/null
+++ b/misc/gnu-watch/files/patch-ps_global.c
@@ -0,0 +1,12 @@
+--- ps/global.c.orig 2016-07-09 21:49:25 UTC
++++ ps/global.c
+@@ -28,7 +28,9 @@
+
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#ifndef __FreeBSD__
+ #include <sys/sysmacros.h>
++#endif
+ #include <sys/types.h>
+
+ #include "../proc/wchan.h"
diff --git a/misc/gnu-watch/files/patch-watch.c b/misc/gnu-watch/files/patch-watch.c
new file mode 100644
index 000000000000..9ada30c0f1d1
--- /dev/null
+++ b/misc/gnu-watch/files/patch-watch.c
@@ -0,0 +1,25 @@
+--- watch.c.orig 2016-07-09 21:49:25 UTC
++++ watch.c
+@@ -52,7 +52,11 @@
+ # define _XOPEN_SOURCE_EXTENDED 1
+ # include <wchar.h>
+ # include <wctype.h>
++#ifdef __FreeBSD__
++# include <ncurses.h>
++#else
+ # include <ncursesw/ncurses.h>
++#endif
+ #else
+ # include <ncurses.h>
+ #endif /* WITH_WATCH8BIT */
+@@ -72,6 +76,10 @@ static int flags;
+ #define WATCH_ERREXIT (1 << 6)
+ #define WATCH_CHGEXIT (1 << 7)
+
++#ifdef __FreeBSD__
++#define HOST_NAME_MAX 1024
++#endif
++
+ static int curses_started = 0;
+ static long height = 24, width = 80;
+ static int screen_size_changed = 0;
diff --git a/misc/gnu-watch/pkg-descr b/misc/gnu-watch/pkg-descr
index c6a04eb38efc..ca03fb59347b 100644
--- a/misc/gnu-watch/pkg-descr
+++ b/misc/gnu-watch/pkg-descr
@@ -1,4 +1,4 @@
GNU watch runs a command repeatedly, displaying its output (the first
screenfull). This allows you to watch the program output change over time.
-WWW: http://procps.sourceforge.net/
+WWW: https://gitlab.com/procps-ng/procps/