aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-01-25 02:10:14 +0800
committerrakuco <rakuco@FreeBSD.org>2016-01-25 02:10:14 +0800
commit168c09d7ac04fe1367cf358d9ef4b866358da769 (patch)
tree66663b28c2c298161be86b00114ab18d6fad8670 /misc
parentd6f5862ed14a358ca5995e92368a7a4c2c6cf2a4 (diff)
downloadfreebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.tar.gz
freebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.tar.zst
freebsd-ports-gnome-168c09d7ac04fe1367cf358d9ef4b866358da769.zip
Update Qt5 to 5.5.1.
This is the latest stable release at time of writing. Release announcement: http://blog.qt.io/blog/2015/07/01/qt-5-5-released/ New features in Qt 5.5: https://wiki.qt.io/New_Features_in_Qt_5.5 As usual, huge thanks to Tobias Berner (tcberner@gmail.com) for all his work on these ports in kde@'s experimental area51 repository. He's the one who started the update and did a lot of the initial work on Qt 5.5. Ralf Nolden (nolden@kde.org) has contributed the initial version of most of our new Qt5 ports. Also thanks to Yuri Victorovich (yuri@rawbw.com) for contributing PR 205805 with his own patch for the 5.5.1 update. Some of his changes there prompted additional fixes and changes present in the final patch generated from our experimental repository. New ports: - comms/qt5-connectivity, comms/qt5-sensors, devel/qt5-location, graphics/qt5-3d, net/qt5-enginio, x11-toolkits/qt5-canvas3d, x11-toolkits/qt5-uiplugin. General changes in all Qt5 ports: - All Qt5 ports are now built with -Wl,--as-needed to avoid overlinking, which is a problem with qmake-based because the libraries passed to the linker come from the modules .pri files and many are not necessary. - With this change, several ports had their USE_QT5 lines adjusted to explicitly include some libraries that were pulled in implicitly, and to exclude libraries no longer required with -Wl,--as-needed. Changes in specific ports: - devel/qt5: Drop the SQL_PLUGINS and TOOLS options and depend on all Qt5 ports by default. It makes the Makefile much simpler, and those options were already on by default. - devel/qt5-core: The clang+base libstdc++ workaround has been expanded and more C++11 features have been disabled when that combination is used by a port (basically, FreeBSD 9 with USES=compiler:c++11-lang). The disabled features have explanations for why they were disabled in the patched header itself. - devel/qt5-designer: uiplugins has been split out following a similar change upstream. By depending on qt5-uiplugin, qt5-uitools avoids having to depend on the big qt5-designer port. - multimedia/qt5-multimedia: The port now uses GStreamer 1.0 instead of 0.10. - net/qt5-network: The port now depends on libproxy for proxy settings. Using libproxy allows proxy settings to be read from different sources, and also allows .pac files to work with Qt. - www/qt5-webkit: The port now uses GStreamer 1.0 instead of 0.10. PR: 205805 PR: 206435
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/qt5-l10n/Makefile15
-rw-r--r--misc/qt5-l10n/pkg-plist203
3 files changed, 219 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6afcba075b78..fa5407270402 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -393,6 +393,7 @@
SUBDIR += qt4-l10n
SUBDIR += qt4-qtconfig
SUBDIR += qt4-qtdemo
+ SUBDIR += qt5-l10n
SUBDIR += qt5ct
SUBDIR += quotes
SUBDIR += raspberrypi-userland
diff --git a/misc/qt5-l10n/Makefile b/misc/qt5-l10n/Makefile
new file mode 100644
index 000000000000..6793a2fe3d72
--- /dev/null
+++ b/misc/qt5-l10n/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= l10n
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= misc
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt localized messages
+
+USES= qmake
+USE_QT5= qmake_build linguisttools_build
+QT_DIST= translations
+
+.include <bsd.port.mk>
diff --git a/misc/qt5-l10n/pkg-plist b/misc/qt5-l10n/pkg-plist
new file mode 100644
index 000000000000..66db43041710
--- /dev/null
+++ b/misc/qt5-l10n/pkg-plist
@@ -0,0 +1,203 @@
+%%QT_L10NDIR%%/assistant_cs.qm
+%%QT_L10NDIR%%/assistant_da.qm
+%%QT_L10NDIR%%/assistant_de.qm
+%%QT_L10NDIR%%/assistant_en.qm
+%%QT_L10NDIR%%/assistant_fr.qm
+%%QT_L10NDIR%%/assistant_hu.qm
+%%QT_L10NDIR%%/assistant_ja.qm
+%%QT_L10NDIR%%/assistant_ko.qm
+%%QT_L10NDIR%%/assistant_pl.qm
+%%QT_L10NDIR%%/assistant_ru.qm
+%%QT_L10NDIR%%/assistant_sk.qm
+%%QT_L10NDIR%%/assistant_sl.qm
+%%QT_L10NDIR%%/assistant_uk.qm
+%%QT_L10NDIR%%/assistant_zh_CN.qm
+%%QT_L10NDIR%%/assistant_zh_TW.qm
+%%QT_L10NDIR%%/designer_cs.qm
+%%QT_L10NDIR%%/designer_de.qm
+%%QT_L10NDIR%%/designer_en.qm
+%%QT_L10NDIR%%/designer_fr.qm
+%%QT_L10NDIR%%/designer_hu.qm
+%%QT_L10NDIR%%/designer_ja.qm
+%%QT_L10NDIR%%/designer_ko.qm
+%%QT_L10NDIR%%/designer_pl.qm
+%%QT_L10NDIR%%/designer_ru.qm
+%%QT_L10NDIR%%/designer_sk.qm
+%%QT_L10NDIR%%/designer_sl.qm
+%%QT_L10NDIR%%/designer_uk.qm
+%%QT_L10NDIR%%/designer_zh_CN.qm
+%%QT_L10NDIR%%/designer_zh_TW.qm
+%%QT_L10NDIR%%/linguist_cs.qm
+%%QT_L10NDIR%%/linguist_de.qm
+%%QT_L10NDIR%%/linguist_en.qm
+%%QT_L10NDIR%%/linguist_fr.qm
+%%QT_L10NDIR%%/linguist_hu.qm
+%%QT_L10NDIR%%/linguist_ja.qm
+%%QT_L10NDIR%%/linguist_ko.qm
+%%QT_L10NDIR%%/linguist_pl.qm
+%%QT_L10NDIR%%/linguist_ru.qm
+%%QT_L10NDIR%%/linguist_sk.qm
+%%QT_L10NDIR%%/linguist_sl.qm
+%%QT_L10NDIR%%/linguist_uk.qm
+%%QT_L10NDIR%%/linguist_zh_CN.qm
+%%QT_L10NDIR%%/linguist_zh_TW.qm
+%%QT_L10NDIR%%/qmlviewer_cs.qm
+%%QT_L10NDIR%%/qmlviewer_en.qm
+%%QT_L10NDIR%%/qmlviewer_fi.qm
+%%QT_L10NDIR%%/qmlviewer_fr.qm
+%%QT_L10NDIR%%/qmlviewer_hu.qm
+%%QT_L10NDIR%%/qmlviewer_ja.qm
+%%QT_L10NDIR%%/qmlviewer_ko.qm
+%%QT_L10NDIR%%/qmlviewer_ru.qm
+%%QT_L10NDIR%%/qmlviewer_sk.qm
+%%QT_L10NDIR%%/qmlviewer_uk.qm
+%%QT_L10NDIR%%/qt_ar.qm
+%%QT_L10NDIR%%/qt_ca.qm
+%%QT_L10NDIR%%/qt_cs.qm
+%%QT_L10NDIR%%/qt_da.qm
+%%QT_L10NDIR%%/qt_de.qm
+%%QT_L10NDIR%%/qt_en.qm
+%%QT_L10NDIR%%/qt_es.qm
+%%QT_L10NDIR%%/qt_fa.qm
+%%QT_L10NDIR%%/qt_fi.qm
+%%QT_L10NDIR%%/qt_fr.qm
+%%QT_L10NDIR%%/qt_gl.qm
+%%QT_L10NDIR%%/qt_he.qm
+%%QT_L10NDIR%%/qt_help_cs.qm
+%%QT_L10NDIR%%/qt_help_da.qm
+%%QT_L10NDIR%%/qt_help_de.qm
+%%QT_L10NDIR%%/qt_help_en.qm
+%%QT_L10NDIR%%/qt_help_fr.qm
+%%QT_L10NDIR%%/qt_help_gl.qm
+%%QT_L10NDIR%%/qt_help_hu.qm
+%%QT_L10NDIR%%/qt_help_it.qm
+%%QT_L10NDIR%%/qt_help_ja.qm
+%%QT_L10NDIR%%/qt_help_ko.qm
+%%QT_L10NDIR%%/qt_help_pl.qm
+%%QT_L10NDIR%%/qt_help_ru.qm
+%%QT_L10NDIR%%/qt_help_sk.qm
+%%QT_L10NDIR%%/qt_help_sl.qm
+%%QT_L10NDIR%%/qt_help_uk.qm
+%%QT_L10NDIR%%/qt_help_zh_CN.qm
+%%QT_L10NDIR%%/qt_help_zh_TW.qm
+%%QT_L10NDIR%%/qt_hu.qm
+%%QT_L10NDIR%%/qt_it.qm
+%%QT_L10NDIR%%/qt_ja.qm
+%%QT_L10NDIR%%/qt_ko.qm
+%%QT_L10NDIR%%/qt_lt.qm
+%%QT_L10NDIR%%/qt_pl.qm
+%%QT_L10NDIR%%/qt_pt.qm
+%%QT_L10NDIR%%/qt_ru.qm
+%%QT_L10NDIR%%/qt_sk.qm
+%%QT_L10NDIR%%/qt_sl.qm
+%%QT_L10NDIR%%/qt_sv.qm
+%%QT_L10NDIR%%/qt_uk.qm
+%%QT_L10NDIR%%/qt_zh_CN.qm
+%%QT_L10NDIR%%/qt_zh_TW.qm
+%%QT_L10NDIR%%/qtbase_ca.qm
+%%QT_L10NDIR%%/qtbase_cs.qm
+%%QT_L10NDIR%%/qtbase_de.qm
+%%QT_L10NDIR%%/qtbase_en.qm
+%%QT_L10NDIR%%/qtbase_fi.qm
+%%QT_L10NDIR%%/qtbase_fr.qm
+%%QT_L10NDIR%%/qtbase_he.qm
+%%QT_L10NDIR%%/qtbase_hu.qm
+%%QT_L10NDIR%%/qtbase_it.qm
+%%QT_L10NDIR%%/qtbase_ja.qm
+%%QT_L10NDIR%%/qtbase_ko.qm
+%%QT_L10NDIR%%/qtbase_lv.qm
+%%QT_L10NDIR%%/qtbase_ru.qm
+%%QT_L10NDIR%%/qtbase_sk.qm
+%%QT_L10NDIR%%/qtbase_uk.qm
+%%QT_L10NDIR%%/qtconfig_hu.qm
+%%QT_L10NDIR%%/qtconfig_ja.qm
+%%QT_L10NDIR%%/qtconfig_ko.qm
+%%QT_L10NDIR%%/qtconfig_pl.qm
+%%QT_L10NDIR%%/qtconfig_ru.qm
+%%QT_L10NDIR%%/qtconfig_sk.qm
+%%QT_L10NDIR%%/qtconfig_sl.qm
+%%QT_L10NDIR%%/qtconfig_uk.qm
+%%QT_L10NDIR%%/qtconfig_zh_CN.qm
+%%QT_L10NDIR%%/qtconfig_zh_TW.qm
+%%QT_L10NDIR%%/qtconnectivity_de.qm
+%%QT_L10NDIR%%/qtconnectivity_en.qm
+%%QT_L10NDIR%%/qtconnectivity_ko.qm
+%%QT_L10NDIR%%/qtconnectivity_uk.qm
+%%QT_L10NDIR%%/qtdeclarative_de.qm
+%%QT_L10NDIR%%/qtdeclarative_en.qm
+%%QT_L10NDIR%%/qtdeclarative_fi.qm
+%%QT_L10NDIR%%/qtdeclarative_fr.qm
+%%QT_L10NDIR%%/qtdeclarative_ja.qm
+%%QT_L10NDIR%%/qtdeclarative_ko.qm
+%%QT_L10NDIR%%/qtdeclarative_lv.qm
+%%QT_L10NDIR%%/qtdeclarative_ru.qm
+%%QT_L10NDIR%%/qtdeclarative_sk.qm
+%%QT_L10NDIR%%/qtdeclarative_uk.qm
+%%QT_L10NDIR%%/qtlocation_de.qm
+%%QT_L10NDIR%%/qtlocation_en.qm
+%%QT_L10NDIR%%/qtlocation_fr.qm
+%%QT_L10NDIR%%/qtlocation_ko.qm
+%%QT_L10NDIR%%/qtlocation_uk.qm
+%%QT_L10NDIR%%/qtmultimedia_ca.qm
+%%QT_L10NDIR%%/qtmultimedia_cs.qm
+%%QT_L10NDIR%%/qtmultimedia_de.qm
+%%QT_L10NDIR%%/qtmultimedia_en.qm
+%%QT_L10NDIR%%/qtmultimedia_fi.qm
+%%QT_L10NDIR%%/qtmultimedia_fr.qm
+%%QT_L10NDIR%%/qtmultimedia_hu.qm
+%%QT_L10NDIR%%/qtmultimedia_it.qm
+%%QT_L10NDIR%%/qtmultimedia_ja.qm
+%%QT_L10NDIR%%/qtmultimedia_ko.qm
+%%QT_L10NDIR%%/qtmultimedia_ru.qm
+%%QT_L10NDIR%%/qtmultimedia_sk.qm
+%%QT_L10NDIR%%/qtmultimedia_uk.qm
+%%QT_L10NDIR%%/qtquick1_ca.qm
+%%QT_L10NDIR%%/qtquick1_cs.qm
+%%QT_L10NDIR%%/qtquick1_de.qm
+%%QT_L10NDIR%%/qtquick1_en.qm
+%%QT_L10NDIR%%/qtquick1_fi.qm
+%%QT_L10NDIR%%/qtquick1_fr.qm
+%%QT_L10NDIR%%/qtquick1_he.qm
+%%QT_L10NDIR%%/qtquick1_hu.qm
+%%QT_L10NDIR%%/qtquick1_it.qm
+%%QT_L10NDIR%%/qtquick1_ja.qm
+%%QT_L10NDIR%%/qtquick1_ko.qm
+%%QT_L10NDIR%%/qtquick1_ru.qm
+%%QT_L10NDIR%%/qtquick1_sk.qm
+%%QT_L10NDIR%%/qtquick1_uk.qm
+%%QT_L10NDIR%%/qtquickcontrols_de.qm
+%%QT_L10NDIR%%/qtquickcontrols_en.qm
+%%QT_L10NDIR%%/qtquickcontrols_fi.qm
+%%QT_L10NDIR%%/qtquickcontrols_fr.qm
+%%QT_L10NDIR%%/qtquickcontrols_ja.qm
+%%QT_L10NDIR%%/qtquickcontrols_ru.qm
+%%QT_L10NDIR%%/qtquickcontrols_uk.qm
+%%QT_L10NDIR%%/qtscript_ca.qm
+%%QT_L10NDIR%%/qtscript_cs.qm
+%%QT_L10NDIR%%/qtscript_de.qm
+%%QT_L10NDIR%%/qtscript_en.qm
+%%QT_L10NDIR%%/qtscript_fi.qm
+%%QT_L10NDIR%%/qtscript_fr.qm
+%%QT_L10NDIR%%/qtscript_he.qm
+%%QT_L10NDIR%%/qtscript_hu.qm
+%%QT_L10NDIR%%/qtscript_it.qm
+%%QT_L10NDIR%%/qtscript_ja.qm
+%%QT_L10NDIR%%/qtscript_ko.qm
+%%QT_L10NDIR%%/qtscript_lv.qm
+%%QT_L10NDIR%%/qtscript_ru.qm
+%%QT_L10NDIR%%/qtscript_sk.qm
+%%QT_L10NDIR%%/qtscript_uk.qm
+%%QT_L10NDIR%%/qtwebsockets_en.qm
+%%QT_L10NDIR%%/qtwebsockets_fr.qm
+%%QT_L10NDIR%%/qtxmlpatterns_ca.qm
+%%QT_L10NDIR%%/qtxmlpatterns_cs.qm
+%%QT_L10NDIR%%/qtxmlpatterns_de.qm
+%%QT_L10NDIR%%/qtxmlpatterns_en.qm
+%%QT_L10NDIR%%/qtxmlpatterns_fr.qm
+%%QT_L10NDIR%%/qtxmlpatterns_hu.qm
+%%QT_L10NDIR%%/qtxmlpatterns_it.qm
+%%QT_L10NDIR%%/qtxmlpatterns_ja.qm
+%%QT_L10NDIR%%/qtxmlpatterns_ko.qm
+%%QT_L10NDIR%%/qtxmlpatterns_ru.qm
+%%QT_L10NDIR%%/qtxmlpatterns_sk.qm
+%%QT_L10NDIR%%/qtxmlpatterns_uk.qm