aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2017-12-17 14:58:41 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2017-12-17 14:58:41 +0800
commit17b999b1becff3fc6acb28b99a90a176bc858688 (patch)
tree7d923507ad65b3849c64cbf229198d7e58862f07 /misc
parent9d0d65fd184ce8bf66b77c688d24fbf006d5edb4 (diff)
downloadfreebsd-ports-gnome-17b999b1becff3fc6acb28b99a90a176bc858688.tar.gz
freebsd-ports-gnome-17b999b1becff3fc6acb28b99a90a176bc858688.tar.zst
freebsd-ports-gnome-17b999b1becff3fc6acb28b99a90a176bc858688.zip
misc/mc: Fix SUBSHELL blank terminal upon opening in xterm with Slang
Note: Unfortunately this does not fix this issue on the FreeBSD console. PR: 217758 Submitted by: Alexander Moisseev <moiseev@mezonplus.ru> Reported by: Dron <dron_2@ua.fm> Reported by: danfe MFH: 2017Q4
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile1
-rw-r--r--misc/mc/files/patch-lib_tty_tty-slang.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 09875ad984ba..788159ac5d53 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mc
PORTVERSION= 4.8.20
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
http://ftp.osuosl.org/pub/midnightcommander/
diff --git a/misc/mc/files/patch-lib_tty_tty-slang.c b/misc/mc/files/patch-lib_tty_tty-slang.c
new file mode 100644
index 000000000000..fb0f07ff29ba
--- /dev/null
+++ b/misc/mc/files/patch-lib_tty_tty-slang.c
@@ -0,0 +1,28 @@
+--- lib/tty/tty-slang.c.orig 2017-03-04 17:51:38 UTC
++++ lib/tty/tty-slang.c
+@@ -373,7 +373,11 @@ tty_shutdown (void)
+ void
+ tty_enter_ca_mode (void)
+ {
+- /* S-Lang handles alternate screen switching and cursor position saving */
++ if (mc_global.tty.xterm_flag)
++ {
++ fprintf (stdout, /* ESC_STR ")0" */ ESC_STR "7" ESC_STR "[?47h");
++ fflush (stdout);
++ }
+ }
+
+ /* --------------------------------------------------------------------------------------------- */
+@@ -381,7 +385,11 @@ tty_enter_ca_mode (void)
+ void
+ tty_exit_ca_mode (void)
+ {
+- /* S-Lang handles alternate screen switching and cursor position restoring */
++ if (mc_global.tty.xterm_flag)
++ {
++ fprintf (stdout, ESC_STR "[?47l" ESC_STR "8" ESC_STR "[m");
++ fflush (stdout);
++ }
+ }
+
+ /* --------------------------------------------------------------------------------------------- */