aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-15 02:43:20 +0800
committeryuri <yuri@FreeBSD.org>2018-07-15 02:43:20 +0800
commit1a8e5effd85192fc5411e5b1ff9459bb99b273e0 (patch)
treee1ce7c93e80112647088cea97e1743b08f0a6ba1 /misc
parente85e2d3c6265726b0783fb24934fef0240264acd (diff)
downloadfreebsd-ports-gnome-1a8e5effd85192fc5411e5b1ff9459bb99b273e0.tar.gz
freebsd-ports-gnome-1a8e5effd85192fc5411e5b1ff9459bb99b273e0.tar.zst
freebsd-ports-gnome-1a8e5effd85192fc5411e5b1ff9459bb99b273e0.zip
New port: misc/zygrib: Weather data visualization, GRIB file viewer
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/zygrib/Makefile58
-rw-r--r--misc/zygrib/distinfo3
-rw-r--r--misc/zygrib/files/patch-Makefile39
-rw-r--r--misc/zygrib/files/patch-src_g2clib_makefile11
-rw-r--r--misc/zygrib/files/patch-src_zyGrib.pro20
-rw-r--r--misc/zygrib/pkg-descr14
-rw-r--r--misc/zygrib/pkg-plist134
8 files changed, 280 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dc307068cc8f..43a5c715f2bf 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -567,5 +567,6 @@
SUBDIR += yaunc
SUBDIR += ytree
SUBDIR += zoneinfo
+ SUBDIR += zygrib
.include <bsd.port.subdir.mk>
diff --git a/misc/zygrib/Makefile b/misc/zygrib/Makefile
new file mode 100644
index 000000000000..70bdfa96415b
--- /dev/null
+++ b/misc/zygrib/Makefile
@@ -0,0 +1,58 @@
+# $FreeBSD$
+
+PORTNAME= zygrib
+DISTVERSION= 8.0.1
+CATEGORIES= misc
+MASTER_SITES= http://www.zygrib.org/getfile.php?file=
+DISTNAME= zyGrib-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Weather data visualization, GRIB file viewer
+
+LICENSE= GPLv3
+
+BROKEN_FreeBSD_10= g2clib/libg2c.a: could not read symbols: File format not recognized
+
+FETCH_DEPENDS= curl:ftp/curl
+LIB_DEPENDS= libjasper.so:graphics/jasper \
+ libnova.so:astro/libnova \
+ libpng16.so:graphics/png \
+ libproj.so:graphics/proj \
+ libqwt6.so:x11-toolkits/qwt6@qt5
+
+USES= gmake localbase tar:tgz qt:5
+USE_QT= core gui network printsupport widgets xml buildtools_build qmake_build
+USE_GL= gl
+
+WRKSRC= ${WRKDIR}/zyGrib-${DISTVERSION}
+CXXFLAGS+= -I${LOCALBASE}/include/qt5/qwt6
+BINARY_ALIAS= make=gmake gcc=cc
+
+local-makesum: # Workaround: the generic 'make makesum' is broken when custom do-fetch is defined: it calls ${SCRIPTSDIR}/do-fetch.sh.
+ @${MAKE} distclean fetch makesum
+
+do-fetch: # fetch needs cookies
+ @if [ "${FORCE_FETCH_ALL}" = "true" ] || ! [ -f "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}" ]; then \
+ ${LOCALBASE}/bin/curl -fLC - \
+ --cookie nada -o /dev/null "${MASTER_SITES}${DISTNAME}${EXTRACT_SUFX}" \
+ --next \
+ --cookie nada --retry-delay 3 -o "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}" "${MASTER_SITES}${DISTNAME}${EXTRACT_SUFX}"; \
+ fi
+
+post-extract: # unbundle qwt
+ @${RM} -r ${WRKSRC}/src/qwt-6.1.3
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e 's|/usr/bin/qmake|${QMAKE}|'
+ @${REINPLACE_CMD} -E ' \
+ s,return pathData\(\)\+"data/(colors|fonts|gis|maps/gshhs|stuff|img)/",return QString()+"${DATADIR}/\1/", ; \
+ s,pathData\(\)\+"data/tr/zyGrib_",QString()+"${PREFIX}/share/locale/tr/LC_MESSAGES/zyGrib_",' \
+ ${WRKSRC}/src/util/Util.h
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/zyGrib
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/zyGrib ${STAGEDIR}${PREFIX}/bin
+ @${MV} ${STAGEDIR}${DATADIR}/tr/* ${STAGEDIR}${PREFIX}/share/locale/tr/LC_MESSAGES/
+ @cd ${STAGEDIR}${DATADIR} && ${RMDIR} tr config grib
+
+.include <bsd.port.mk>
diff --git a/misc/zygrib/distinfo b/misc/zygrib/distinfo
new file mode 100644
index 000000000000..44f89c19b076
--- /dev/null
+++ b/misc/zygrib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531588082
+SHA256 (zyGrib-8.0.1.tgz) = 9c0490cbec74cea6d3c8f150bc745cb4c48f04969e10e91579fe01e56b9830f8
+SIZE (zyGrib-8.0.1.tgz) = 19759812
diff --git a/misc/zygrib/files/patch-Makefile b/misc/zygrib/files/patch-Makefile
new file mode 100644
index 000000000000..1c5396b6274f
--- /dev/null
+++ b/misc/zygrib/files/patch-Makefile
@@ -0,0 +1,39 @@
+--- Makefile.orig 2016-11-09 16:27:38 UTC
++++ Makefile
+@@ -1,13 +1,12 @@
+-QMAKE=/usr/bin/qmake
++QMAKE=/usr/local/lib/qt5/bin/qmake
+
+-INSTALLDIR=$(HOME)/zyGrib
++INSTALLDIR=$(DESTDIR)$(PREFIX)
+ MACQTBIN=/usr/local/Qt-5.3.2/bin/
+-QWTDIR=src/qwt-6.1.3
++#QWTDIR=src/qwt-6.1.3
+
+ all: zyGrib
+
+-SRC= src/*.h src/*.cpp src/*/*.h src/*/*.cpp \
+- src/qwt*/src/*.cpp src/qwt*/src/*.h
++SRC= src/*.h src/*.cpp src/*/*.h src/*/*.cpp
+
+ mac: $(SRC)
+ rm -f ./zyGrib
+@@ -42,7 +41,6 @@ veryclean: clean
+ zyGrib: $(SRC)
+ @ echo
+ rm -f ./zyGrib
+- cd $(QWTDIR)/src; $(QMAKE); make -j6
+ cd src/g2clib; make
+ cd src; $(QMAKE); make -j6
+ @ echo "-----------------------------------"
+@@ -54,8 +52,8 @@ zyGrib: $(SRC)
+ install: zyGrib
+ mkdir -p $(INSTALLDIR)
+ mkdir -p $(INSTALLDIR)/bin
+- cp -a data $(INSTALLDIR)
+- cp -a grib $(INSTALLDIR)
++ cp -a data $(INSTALLDIR)/share/zygrib
++ cp -a grib $(INSTALLDIR)/share/zygrib
+ rm -f ./zyGrib
+ rm -f $(INSTALLDIR)/bin/zyGrib
+ cp -a src/zyGrib $(INSTALLDIR)/bin
diff --git a/misc/zygrib/files/patch-src_g2clib_makefile b/misc/zygrib/files/patch-src_g2clib_makefile
new file mode 100644
index 000000000000..73e423afe5c6
--- /dev/null
+++ b/misc/zygrib/files/patch-src_g2clib_makefile
@@ -0,0 +1,11 @@
+--- src/g2clib/makefile.orig 2018-07-14 07:16:22 UTC
++++ src/g2clib/makefile
+@@ -25,7 +25,7 @@ INC=-I/nwprod/lib/include/
+ # appropriate compiler flag to allow the use of "//" comment indicators.
+ #
+
+-CFLAGS= -O3 -g -m64 $(INC) $(DEFS) -D__64BIT__
++CFLAGS+= -m64 $(INC) $(DEFS) -D__64BIT__
+
+ CC=gcc
+
diff --git a/misc/zygrib/files/patch-src_zyGrib.pro b/misc/zygrib/files/patch-src_zyGrib.pro
new file mode 100644
index 000000000000..bf5f32d73302
--- /dev/null
+++ b/misc/zygrib/files/patch-src_zyGrib.pro
@@ -0,0 +1,20 @@
+--- src/zyGrib.pro.orig 2018-07-14 08:35:01 UTC
++++ src/zyGrib.pro
+@@ -8,7 +8,7 @@ TEMPLATE = app
+ TARGET = zyGrib
+
+ DEPENDPATH += . util map GUI
+-INCLUDEPATH += . util map GUI curvedrawer qwt-6.1.3/src g2clib
++INCLUDEPATH += . util map GUI curvedrawer $$(PREFIX)/include/qt5/qwt6 g2clib
+
+ # ----------------------------------------------------
+ # platform specific
+@@ -35,7 +35,7 @@ else {
+ }
+ }
+
+-LIBS += -lbz2 -lz -lproj -lnova -Lqwt-6.1.3/lib/ -lqwt
++LIBS += -lbz2 -lz -lproj -lnova -L$$(PREFIX)/lib/qt5/libqwt -lqwt6
+ LIBS += -Lg2clib -lg2c -lpng -ljasper # respect order!
+
+ # ----------------------------------------------------
diff --git a/misc/zygrib/pkg-descr b/misc/zygrib/pkg-descr
new file mode 100644
index 000000000000..09ff11677c96
--- /dev/null
+++ b/misc/zygrib/pkg-descr
@@ -0,0 +1,14 @@
+zyGrib visualizes weather data in GRIB format. Historical weather data,
+as long as current and forcast information is presented in the standadard
+called GRIB format. These files are available from a variety of sources.
+
+zyGrib displays the following weather information:
+* Atmospheric pressure
+* Wind
+* Temperature
+* Humidity
+* Dew point
+* Isothermal altitude
+* etc.
+
+WWW: http://www.zygrib.org/
diff --git a/misc/zygrib/pkg-plist b/misc/zygrib/pkg-plist
new file mode 100644
index 000000000000..58b01571bb14
--- /dev/null
+++ b/misc/zygrib/pkg-plist
@@ -0,0 +1,134 @@
+bin/zyGrib
+share/locale/tr/LC_MESSAGES/zyGrib_ar.qm
+share/locale/tr/LC_MESSAGES/zyGrib_ar.ts
+share/locale/tr/LC_MESSAGES/zyGrib_cz.qm
+share/locale/tr/LC_MESSAGES/zyGrib_cz.ts
+share/locale/tr/LC_MESSAGES/zyGrib_de.qm
+share/locale/tr/LC_MESSAGES/zyGrib_de.ts
+share/locale/tr/LC_MESSAGES/zyGrib_es.qm
+share/locale/tr/LC_MESSAGES/zyGrib_es.ts
+share/locale/tr/LC_MESSAGES/zyGrib_fi.qm
+share/locale/tr/LC_MESSAGES/zyGrib_fi.ts
+share/locale/tr/LC_MESSAGES/zyGrib_fr.qm
+share/locale/tr/LC_MESSAGES/zyGrib_fr.ts
+share/locale/tr/LC_MESSAGES/zyGrib_gr.qm
+share/locale/tr/LC_MESSAGES/zyGrib_gr.ts
+share/locale/tr/LC_MESSAGES/zyGrib_it.qm
+share/locale/tr/LC_MESSAGES/zyGrib_it.ts
+share/locale/tr/LC_MESSAGES/zyGrib_nl.qm
+share/locale/tr/LC_MESSAGES/zyGrib_nl.ts
+share/locale/tr/LC_MESSAGES/zyGrib_pt.qm
+share/locale/tr/LC_MESSAGES/zyGrib_pt.ts
+share/locale/tr/LC_MESSAGES/zyGrib_ru.qm
+share/locale/tr/LC_MESSAGES/zyGrib_ru.ts
+%%DATADIR%%/colors/colors_binary.txt
+%%DATADIR%%/colors/colors_cape_jkg.txt
+%%DATADIR%%/colors/colors_cin_jkg.txt
+%%DATADIR%%/colors/colors_clouds_black_pc.txt
+%%DATADIR%%/colors/colors_clouds_white_pc.txt
+%%DATADIR%%/colors/colors_current_kts.txt
+%%DATADIR%%/colors/colors_deltatemp_celcius.txt
+%%DATADIR%%/colors/colors_humidrel_pc.txt
+%%DATADIR%%/colors/colors_rain_mmh.txt
+%%DATADIR%%/colors/colors_snowdepth_m.txt
+%%DATADIR%%/colors/colors_temp_celcius.txt
+%%DATADIR%%/colors/colors_thetae_celcius.txt
+%%DATADIR%%/colors/colors_thetae_celcius_1.txt
+%%DATADIR%%/colors/colors_waveheight_m.txt
+%%DATADIR%%/colors/colors_whitecap_prb.txt
+%%DATADIR%%/colors/colors_whitecap_prb.txt.colors
+%%DATADIR%%/colors/colors_wind_jet_kts.txt
+%%DATADIR%%/colors/colors_wind_kts.txt
+%%DATADIR%%/fonts/liberation-fonts/AUTHORS
+%%DATADIR%%/fonts/liberation-fonts/COPYING
+%%DATADIR%%/fonts/liberation-fonts/ChangeLog
+%%DATADIR%%/fonts/liberation-fonts/LiberationMono-Bold.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationMono-BoldItalic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationMono-Italic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationMono-Regular.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSans-Bold.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSans-BoldItalic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSans-Italic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSans-Regular.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSerif-Bold.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSerif-BoldItalic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSerif-Italic.ttf
+%%DATADIR%%/fonts/liberation-fonts/LiberationSerif-Regular.ttf
+%%DATADIR%%/fonts/liberation-fonts/License.txt
+%%DATADIR%%/fonts/liberation-fonts/README
+%%DATADIR%%/gis/cities_10k-more.txt.gz
+%%DATADIR%%/gis/cities_3k-10k.txt.gz
+%%DATADIR%%/gis/countries_en.txt.gz
+%%DATADIR%%/gis/countries_fr.txt.gz
+%%DATADIR%%/gis/states_en.txt.gz
+%%DATADIR%%/gis/stations_metar.txt.gz
+%%DATADIR%%/img/1leftarrow.png
+%%DATADIR%%/img/1rightarrow.png
+%%DATADIR%%/img/2leftarrow.png
+%%DATADIR%%/img/2rightarrow.png
+%%DATADIR%%/img/airport.png
+%%DATADIR%%/img/anim.png
+%%DATADIR%%/img/back.png
+%%DATADIR%%/img/connect_no.png
+%%DATADIR%%/img/down.png
+%%DATADIR%%/img/drapeau_ar.png
+%%DATADIR%%/img/drapeau_cz.png
+%%DATADIR%%/img/drapeau_de.png
+%%DATADIR%%/img/drapeau_en.png
+%%DATADIR%%/img/drapeau_es.png
+%%DATADIR%%/img/drapeau_fi.png
+%%DATADIR%%/img/drapeau_fr.png
+%%DATADIR%%/img/drapeau_gr.png
+%%DATADIR%%/img/drapeau_it.png
+%%DATADIR%%/img/drapeau_nl.png
+%%DATADIR%%/img/drapeau_pt.png
+%%DATADIR%%/img/drapeau_ru.png
+%%DATADIR%%/img/exit.png
+%%DATADIR%%/img/fileclose.png
+%%DATADIR%%/img/fileopen.png
+%%DATADIR%%/img/forward.png
+%%DATADIR%%/img/help.png
+%%DATADIR%%/img/info.png
+%%DATADIR%%/img/media-floppy.png
+%%DATADIR%%/img/meteoblue.png
+%%DATADIR%%/img/network.png
+%%DATADIR%%/img/player_eject.png
+%%DATADIR%%/img/player_end.png
+%%DATADIR%%/img/player_fwd.png
+%%DATADIR%%/img/player_pause.png
+%%DATADIR%%/img/player_play.png
+%%DATADIR%%/img/player_playlist.png
+%%DATADIR%%/img/player_rew.png
+%%DATADIR%%/img/player_start.png
+%%DATADIR%%/img/player_stop.png
+%%DATADIR%%/img/printer.png
+%%DATADIR%%/img/reload.png
+%%DATADIR%%/img/resource.rc
+%%DATADIR%%/img/spreadsheet.png
+%%DATADIR%%/img/time_icon.png
+%%DATADIR%%/img/up.png
+%%DATADIR%%/img/viewmag+.png
+%%DATADIR%%/img/viewmag-.png
+%%DATADIR%%/img/viewmag1.png
+%%DATADIR%%/img/viewmagfit.png
+%%DATADIR%%/img/zyGrib.icns
+%%DATADIR%%/img/zyGrib_32.ico
+%%DATADIR%%/img/zyGrib_32.xpm
+%%DATADIR%%/maps/gshhs/README.gshhs
+%%DATADIR%%/maps/gshhs/README.gshhs.rangs
+%%DATADIR%%/maps/gshhs/gshhs_2.rim
+%%DATADIR%%/maps/gshhs/gshhs_3.rim
+%%DATADIR%%/maps/gshhs/gshhs_4.rim
+%%DATADIR%%/maps/gshhs/rangs_2.cat
+%%DATADIR%%/maps/gshhs/rangs_2.cel
+%%DATADIR%%/maps/gshhs/rangs_3.cat
+%%DATADIR%%/maps/gshhs/rangs_3.cel
+%%DATADIR%%/maps/gshhs/rangs_4.cat
+%%DATADIR%%/maps/gshhs/rangs_4.cel
+%%DATADIR%%/maps/gshhs/wdb_borders_c.b
+%%DATADIR%%/maps/gshhs/wdb_borders_i.b
+%%DATADIR%%/maps/gshhs/wdb_borders_l.b
+%%DATADIR%%/maps/gshhs/wdb_rivers_c.b
+%%DATADIR%%/maps/gshhs/wdb_rivers_i.b
+%%DATADIR%%/maps/gshhs/wdb_rivers_l.b
+%%DATADIR%%/stuff/boat_parameters.csv