aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-26 08:38:21 +0800
committerlioux <lioux@FreeBSD.org>2002-08-26 08:38:21 +0800
commit1b243b109aeff0aeccd0020847c1733a4570efcd (patch)
treec7653842f7adba85974d4974c4086f6d6d27f896 /misc
parent273de49718c8bf294192b24ae40eaee649ca2a7a (diff)
downloadfreebsd-ports-gnome-1b243b109aeff0aeccd0020847c1733a4570efcd.tar.gz
freebsd-ports-gnome-1b243b109aeff0aeccd0020847c1733a4570efcd.tar.zst
freebsd-ports-gnome-1b243b109aeff0aeccd0020847c1733a4570efcd.zip
New port xmms-pipe version 0.4.5: Controls XMMS with a named pipe
Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/xmms-pipe/Makefile41
-rw-r--r--misc/xmms-pipe/distinfo1
-rw-r--r--misc/xmms-pipe/pkg-comment1
-rw-r--r--misc/xmms-pipe/pkg-descr8
-rw-r--r--misc/xmms-pipe/pkg-plist5
6 files changed, 57 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 637599fbe812..1e5a506828c3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -320,6 +320,7 @@
SUBDIR += xenmenu
SUBDIR += xgas
SUBDIR += xless
+ SUBDIR += xmms-pipe
SUBDIR += xosd
SUBDIR += xpns
SUBDIR += xquote
diff --git a/misc/xmms-pipe/Makefile b/misc/xmms-pipe/Makefile
new file mode 100644
index 000000000000..b3f26998325a
--- /dev/null
+++ b/misc/xmms-pipe/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xmms-pipe
+# Date created: 23 Aug 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-pipe
+PORTVERSION= 0.4.5
+CATEGORIES= misc
+MASTER_SITES= http://rooster.stanford.edu/~ben/xmmspipe/
+DISTNAME= xmmspipe-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dyeske@yahoo.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+DOC_FILES= HISTORY README LICENSE
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|gcc|${CC}|; \
+ s|^(COPT=).+$$|\1${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/xmmspipe.so \
+ ${PREFIX}/lib/xmms/Effect/
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/xmms-pipe/distinfo b/misc/xmms-pipe/distinfo
new file mode 100644
index 000000000000..a890f9f96c36
--- /dev/null
+++ b/misc/xmms-pipe/distinfo
@@ -0,0 +1 @@
+MD5 (xmmspipe-0.4.5.tgz) = c22d8b4ed62a1bf000312c80e2a4ea34
diff --git a/misc/xmms-pipe/pkg-comment b/misc/xmms-pipe/pkg-comment
new file mode 100644
index 000000000000..85a6ff1a19d4
--- /dev/null
+++ b/misc/xmms-pipe/pkg-comment
@@ -0,0 +1 @@
+Controls XMMS with a named pipe
diff --git a/misc/xmms-pipe/pkg-descr b/misc/xmms-pipe/pkg-descr
new file mode 100644
index 000000000000..c00d94cc39a6
--- /dev/null
+++ b/misc/xmms-pipe/pkg-descr
@@ -0,0 +1,8 @@
+xmmspipe is a plugin for XMMS that enables it to be controlled by
+sending strings to a named pipe (FIFO). When enabled, XMMS can be
+commanded by sending strings to $HOME/.xmms/inpipe.
+
+WWW: http://rooster.stanford.edu/~ben/xmmspipe/
+
+- David
+dyeske@yahoo.com
diff --git a/misc/xmms-pipe/pkg-plist b/misc/xmms-pipe/pkg-plist
new file mode 100644
index 000000000000..f88a50ae5563
--- /dev/null
+++ b/misc/xmms-pipe/pkg-plist
@@ -0,0 +1,5 @@
+%%PORTDOCS%%share/doc/xmms-pipe/HISTORY
+%%PORTDOCS%%share/doc/xmms-pipe/LICENSE
+%%PORTDOCS%%share/doc/xmms-pipe/README
+lib/xmms/Effect/xmmspipe.so
+%%PORTDOCS%%@dirrm share/doc/xmms-pipe