aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-04-04 16:11:32 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-04-04 16:11:32 +0800
commit270f30bfb04459b68a3cc6e3580496f52585f7bc (patch)
treeb46742e4d81942006ce32c72c2571d379523d19b /misc
parent14441beda770ce26fee0fb049492a89991ed5d81 (diff)
downloadfreebsd-ports-gnome-270f30bfb04459b68a3cc6e3580496f52585f7bc.tar.gz
freebsd-ports-gnome-270f30bfb04459b68a3cc6e3580496f52585f7bc.tar.zst
freebsd-ports-gnome-270f30bfb04459b68a3cc6e3580496f52585f7bc.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'misc')
-rw-r--r--misc/translate/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/misc/translate/Makefile b/misc/translate/Makefile
index 4f91741fd5d7..85bd83ea493c 100644
--- a/misc/translate/Makefile
+++ b/misc/translate/Makefile
@@ -11,16 +11,16 @@ COMMENT= Translates string using Babelfish
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+PLIST_FILES= bin/translate man/man1/translate.1.gz
+SHEBANG_FILES= translate
-MAN1= translate.1
-PLIST_FILES= bin/translate
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>