aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2021-01-05 20:47:13 +0800
committerKoichiro Iwao <meta@FreeBSD.org>2021-01-05 20:47:13 +0800
commit2f2f23c72747027ecf8ac7191b05c07aa4408bbf (patch)
tree2ff1f6e106614902fef0db3c28a9996af08cdc53 /misc
parent1a9ec2af19242ceb24005684ce7a3456acc46bbd (diff)
downloadfreebsd-ports-gnome-2f2f23c72747027ecf8ac7191b05c07aa4408bbf.tar.gz
freebsd-ports-gnome-2f2f23c72747027ecf8ac7191b05c07aa4408bbf.tar.zst
freebsd-ports-gnome-2f2f23c72747027ecf8ac7191b05c07aa4408bbf.zip
New port: misc/cxxmatrix: C++ Matrix: The Matrix Reloaded in Terminals
C++ Matrix: The Matrix Reloaded in Terminals (Number falls, Banners, Matrix rains, Conway's Game of Life and Mandelbrot set) I wrote a simple terminal program of Matrix digital rain. A part of the purpose of this program is to test the performance of terminal emulators. Another purpose is just for fun. Enjoy it with fast terminals (e.g., urxvt, alacritty, terminology, etc.)! Features - Hankaku kana characters as in the original film - Ten levels of "green"s using terminal 256 color support - Twinkling effects by adding random brightness fluctuations - Diffused reflection effects by cell background colors WWW: https://github.com/akinomyoga/cxxmatrix PR: 252433 Submitted by: Nuno Teixeira <ed.arrakis@gmail.com>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/cxxmatrix/Makefile41
-rw-r--r--misc/cxxmatrix/distinfo3
-rw-r--r--misc/cxxmatrix/pkg-descr16
4 files changed, 61 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 3d728b288797..e4d88b3d2450 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -65,6 +65,7 @@
SUBDIR += cs
SUBDIR += cstream
SUBDIR += ctm
+ SUBDIR += cxxmatrix
SUBDIR += dahdi
SUBDIR += dahdi-kmod
SUBDIR += dahdi-kmod26
diff --git a/misc/cxxmatrix/Makefile b/misc/cxxmatrix/Makefile
new file mode 100644
index 000000000000..73cff3b9073a
--- /dev/null
+++ b/misc/cxxmatrix/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= cxxmatrix
+DISTVERSION= g20201128
+CATEGORIES= misc
+
+MAINTAINER= ed.arrakis@gmail.com
+COMMENT= C++ Matrix: The Matrix Reloaded in Terminals
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= gawk:lang/gawk
+
+USES= compiler:c++17-lang gmake
+MAKEFILE= GNUmakefile
+USE_GITHUB= yes
+GH_ACCOUNT= akinomyoga
+GH_TAGNAME= 93e505c
+
+PORTDOCS= README.md
+PLIST_FILES= bin/cxxmatrix \
+ share/man/man1/cxxmatrix.1.gz
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|CXXFLAGS :=|CXXFLAGS +=|g' \
+ -e 's|-Ofast||g' \
+ ${WRKSRC}/GNUmakefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cxxmatrix ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cxxmatrix.1 ${STAGEDIR}${PREFIX}/share/man/man1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/cxxmatrix/distinfo b/misc/cxxmatrix/distinfo
new file mode 100644
index 000000000000..6af53d49cc8b
--- /dev/null
+++ b/misc/cxxmatrix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609760666
+SHA256 (akinomyoga-cxxmatrix-g20201128-93e505c_GH0.tar.gz) = c6c118be8b268c5297615fb40bb9596a3a59869174879d6987e036fdb2a6e903
+SIZE (akinomyoga-cxxmatrix-g20201128-93e505c_GH0.tar.gz) = 23446
diff --git a/misc/cxxmatrix/pkg-descr b/misc/cxxmatrix/pkg-descr
new file mode 100644
index 000000000000..ca764be51a83
--- /dev/null
+++ b/misc/cxxmatrix/pkg-descr
@@ -0,0 +1,16 @@
+C++ Matrix: The Matrix Reloaded in Terminals (Number falls, Banners,
+Matrix rains, Conway's Game of Life and Mandelbrot set)
+
+I wrote a simple terminal program of Matrix digital rain.
+A part of the purpose of this program is to test the performance
+of terminal emulators. Another purpose is just for fun.
+Enjoy it with fast terminals (e.g., urxvt, alacritty, terminology, etc.)!
+
+Features
+
+- Hankaku kana characters as in the original film
+- Ten levels of "green"s using terminal 256 color support
+- Twinkling effects by adding random brightness fluctuations
+- Diffused reflection effects by cell background colors
+
+WWW: https://github.com/akinomyoga/cxxmatrix