aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2012-02-23 16:08:51 +0800
committerfjoe <fjoe@FreeBSD.org>2012-02-23 16:08:51 +0800
commit30e0a11671e42281e662d9d1b623aa9b5852270a (patch)
treef3051b5bd77531c283f595039f71c9c576e91fd4 /misc
parent3a3fd08a80dd9592a3ecb41ddb6acc69e28aec5b (diff)
downloadfreebsd-ports-gnome-30e0a11671e42281e662d9d1b623aa9b5852270a.tar.gz
freebsd-ports-gnome-30e0a11671e42281e662d9d1b623aa9b5852270a.tar.zst
freebsd-ports-gnome-30e0a11671e42281e662d9d1b623aa9b5852270a.zip
- Fix build on FreeBSD 9 and later where "bool" is defined in <sys/types.h>
- Bump PORTREVISION
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod/files/patch-freebsd-include-stdbool.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index fe346a8df6aa..ffd4b1f93aea 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi-kmod
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi-kmod/files/patch-freebsd-include-stdbool.h b/misc/dahdi-kmod/files/patch-freebsd-include-stdbool.h
new file mode 100644
index 000000000000..01de10205263
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-freebsd-include-stdbool.h
@@ -0,0 +1,20 @@
+Index: freebsd/include/stdbool.h
+===================================================================
+--- freebsd/include/stdbool.h.orig (revision 10467)
++++ freebsd/include/stdbool.h (revision 10468)
+@@ -1,11 +1,15 @@
+ #ifndef _STDBOOL_H_
+ #define _STDBOOL_H_
+
++#include <sys/types.h>
++
++#ifndef __bool_true_false_are_defined
+ typedef int bool;
+
+ enum {
+ false,
+ true
+ };
++#endif
+
+ #endif /* _STDBOOL_H_ */