aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
committermat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
commit359f486d9eb2765e2538b660686a47ca7f489039 (patch)
tree33a19b5745c1e5e7cbfa4a5ab2c30f6971177e74 /misc
parent16d9767b56dfb66fc3cda0c10604d546bd95003f (diff)
downloadfreebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.tar.gz
freebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.tar.zst
freebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.zip
Don't quote {} in find -exec calls.
Braces are not shell metacharacters, and they do not need to be quoted. By the time find parses its arguments and dicovers them, the quoting will have been removed by the shell anyway. Sponsored by: Absolight
Diffstat (limited to 'misc')
-rw-r--r--misc/tvbrowser/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/misc/tvbrowser/Makefile b/misc/tvbrowser/Makefile
index f89b82f41742..16a58fe77cb3 100644
--- a/misc/tvbrowser/Makefile
+++ b/misc/tvbrowser/Makefile
@@ -28,7 +28,7 @@ do-install:
@cd ${WRKSRC} && ${FIND} . -type d -exec \
${MKDIR} "${STAGEDIR}${DATADIR}/{}" \;
@cd ${WRKSRC} && ${FIND} . -type f -exec \
- ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/{}" \;
+ ${INSTALL_DATA} {} "${STAGEDIR}${DATADIR}/{}" \;
${INSTALL_SCRIPT} ${WRKDIR}/tvbrowser ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>