aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-04-28 19:10:20 +0800
committernaddy <naddy@FreeBSD.org>2003-04-28 19:10:20 +0800
commit3cd398d259e860c969e3c67a976ee8f54359354e (patch)
tree24ebf146f8c070e863d2749ee5ce23094ca8914d /misc
parent348f928b74ffda343eb3c5c83e07104d9eba3fdc (diff)
downloadfreebsd-ports-gnome-3cd398d259e860c969e3c67a976ee8f54359354e.tar.gz
freebsd-ports-gnome-3cd398d259e860c969e3c67a976ee8f54359354e.tar.zst
freebsd-ports-gnome-3cd398d259e860c969e3c67a976ee8f54359354e.zip
Add phraze 0.1.
Phraze produces a list of combinations of "valid" words that correspond to the letters on a standard U.S. telephone keypad. PR: 51038 Submitted by: Michael L.Hostbaek <mich@freebsdcluster.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/phraze/Makefile34
-rw-r--r--misc/phraze/distinfo1
-rw-r--r--misc/phraze/pkg-descr10
-rw-r--r--misc/phraze/pkg-plist4
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index c800f2c7ae74..879f4cedaeb5 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -247,6 +247,7 @@
SUBDIR += pdmenu
SUBDIR += peq
SUBDIR += pg
+ SUBDIR += phraze
SUBDIR += pinfo
SUBDIR += pl-sms
SUBDIR += porteasy
diff --git a/misc/phraze/Makefile b/misc/phraze/Makefile
new file mode 100644
index 000000000000..08d990a8717d
--- /dev/null
+++ b/misc/phraze/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: phraze
+# Date created: Wed Apr 16, 2003
+# Whom: Michael L. Hostbaek <mich@freebsdcluster.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phraze
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= Converts telephone number to combinations of valid words
+
+USE_RUBY= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^#!/usr/bin/ruby|#!${RUBY}|; \
+ s|/usr/local/phraze|${DATADIR}|' ${WRKSRC}/phraze ${WRKSRC}/phraze.1
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/phraze.dict ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/phraze ${PREFIX}/bin/phraze
+ ${INSTALL_MAN} ${WRKSRC}/phraze.1 ${PREFIX}/man/man1/
+
+MAN1= phraze.1
+
+.include <bsd.port.mk>
diff --git a/misc/phraze/distinfo b/misc/phraze/distinfo
new file mode 100644
index 000000000000..43e301fd1932
--- /dev/null
+++ b/misc/phraze/distinfo
@@ -0,0 +1 @@
+MD5 (phraze-0.1.tar.gz) = 01f1d29be64d7ecd11c8ff5a0c0ce633
diff --git a/misc/phraze/pkg-descr b/misc/phraze/pkg-descr
new file mode 100644
index 000000000000..16db82eeedeb
--- /dev/null
+++ b/misc/phraze/pkg-descr
@@ -0,0 +1,10 @@
+Phraze takes a telephone number and produces a list of combinations of
+valid words that can be derived from it, using the keypad of a US phone.
+
+Requires ruby.
+
+WWW: http://phraze.sourceforge.net/
+AUTHOR: Jeff Pace <jpace@incava.org>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/misc/phraze/pkg-plist b/misc/phraze/pkg-plist
new file mode 100644
index 000000000000..52026528d5d1
--- /dev/null
+++ b/misc/phraze/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/phraze
+%%DATADIR%%/phraze.dict
+@dirrm %%DATADIR%%