aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorroyger <royger@FreeBSD.org>2016-04-01 20:01:38 +0800
committerroyger <royger@FreeBSD.org>2016-04-01 20:01:38 +0800
commit3dbb698f422c42871c5d5afcb9d9be6d20c165dc (patch)
tree84cc10ffadd212e4887d7b2e715be0b1e577670d /misc
parentbc471e793f1738e9812704cec35b02177ec426a3 (diff)
downloadfreebsd-ports-gnome-3dbb698f422c42871c5d5afcb9d9be6d20c165dc.tar.gz
freebsd-ports-gnome-3dbb698f422c42871c5d5afcb9d9be6d20c165dc.tar.zst
freebsd-ports-gnome-3dbb698f422c42871c5d5afcb9d9be6d20c165dc.zip
seabios: fix failure to find python
The failure has been reported by the automatic builders: http://package19.nyi.freebsd.org/data/103i386-default-build-as-user/412304/logs/errors/seabios-1.9.1.log This is because SeaBIOS doesn't have a configure phase and the paths of the required build tools need to be passed to the make command when building. Approved by: bapt Sponsored by: Citrix Systems R&D Differential revision: https://reviews.freebsd.org/D5804
Diffstat (limited to 'misc')
-rw-r--r--misc/seabios/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/misc/seabios/Makefile b/misc/seabios/Makefile
index 5bd8e0939a3d..a117b41d538b 100644
--- a/misc/seabios/Makefile
+++ b/misc/seabios/Makefile
@@ -12,7 +12,8 @@ LICENSE= LGPL3
USES= gmake python:build
-MAKE_ARGS= HOSTCC="${CC}" LD32BIT_FLAG="-melf_i386_fbsd"
+MAKE_ARGS= HOSTCC="${CC}" LD32BIT_FLAG="-melf_i386_fbsd" \
+ PYTHON="${PYTHON_CMD}"
USE_GCC= yes
EXTRA_PATCHES= ${FILESDIR}/0001-build-fix-.text-section-address-alignment.patch:-p1