aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2011-02-23 19:20:30 +0800
committerchinsan <chinsan@FreeBSD.org>2011-02-23 19:20:30 +0800
commit65ff23ff0eed299510cd8bf204bbd3341a4a304c (patch)
treeaf09871176977d892d9055e65794b82e3f076810 /misc
parenta7402a185f7b6c790fbe6c344cd2253bd4791011 (diff)
downloadfreebsd-ports-gnome-65ff23ff0eed299510cd8bf204bbd3341a4a304c.tar.gz
freebsd-ports-gnome-65ff23ff0eed299510cd8bf204bbd3341a4a304c.tar.zst
freebsd-ports-gnome-65ff23ff0eed299510cd8bf204bbd3341a4a304c.zip
Add Array::FileReader - Lazily tie files to arrays for reading
WWW: http://search.cpan.org/dist/Array-FileReader/
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Array-FileReader/Makefile30
-rw-r--r--misc/p5-Array-FileReader/distinfo2
-rw-r--r--misc/p5-Array-FileReader/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 75738a261955..ea83f038fca3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -387,6 +387,7 @@
SUBDIR += p5-Acme-ButFirst
SUBDIR += p5-Array-Compare
SUBDIR += p5-Array-Diff
+ SUBDIR += p5-Array-FileReader
SUBDIR += p5-Array-IntSpan
SUBDIR += p5-Array-LineReader
SUBDIR += p5-Array-PrintCols
diff --git a/misc/p5-Array-FileReader/Makefile b/misc/p5-Array-FileReader/Makefile
new file mode 100644
index 000000000000..e5d338a6f46f
--- /dev/null
+++ b/misc/p5-Array-FileReader/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Array-FileReader
+# Date created: 2011/02/20
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Array-FileReader
+PORTVERSION= 0.03
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Lazily tie files to arrays for reading
+
+BUILD_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Array::FileReader.3
+
+PLIST_FILES= %%SITE_PERL%%/Array/FileReader.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/FileReader/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/FileReader \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array \
+ %%SITE_PERL%%/Array
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Array-FileReader/distinfo b/misc/p5-Array-FileReader/distinfo
new file mode 100644
index 000000000000..44fdbaf1f9ca
--- /dev/null
+++ b/misc/p5-Array-FileReader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Array-FileReader-0.03.tar.gz) = 692065a1dbb3ed512bfb3269d5a234f4e9fdb6efedcf17c00f7c49c64f972b68
+SIZE (Array-FileReader-0.03.tar.gz) = 3113
diff --git a/misc/p5-Array-FileReader/pkg-descr b/misc/p5-Array-FileReader/pkg-descr
new file mode 100644
index 000000000000..404cb71012f1
--- /dev/null
+++ b/misc/p5-Array-FileReader/pkg-descr
@@ -0,0 +1,3 @@
+Array::FileReader - Lazily tie files to arrays for reading
+
+WWW: http://search.cpan.org/dist/Array-FileReader/