aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-03-24 02:32:16 +0800
committerarved <arved@FreeBSD.org>2003-03-24 02:32:16 +0800
commit6806ee8eacaa60285ec8cc194ec4b1c166671f6f (patch)
tree930b7a04917bf0a2f047ea3270af89c33ff856a6 /misc
parent40306e308bebef4d11c6b33e017646e7aa008fcd (diff)
downloadfreebsd-ports-gnome-6806ee8eacaa60285ec8cc194ec4b1c166671f6f.tar.gz
freebsd-ports-gnome-6806ee8eacaa60285ec8cc194ec4b1c166671f6f.tar.zst
freebsd-ports-gnome-6806ee8eacaa60285ec8cc194ec4b1c166671f6f.zip
- Install portell.py as portell
- Respect NOPORTDOCS in pkg-plist - Use ECHO_MSG instead of ECHO_CMD - Bump PORTREVISION PR: 50124 Submitted by: Sergei Kolobov <sergei@kolobov.com> Approved by: Michael Hostbaek <mich@freebsdcluster.org> (maintainer)
Diffstat (limited to 'misc')
-rw-r--r--misc/portell/Makefile21
-rw-r--r--misc/portell/pkg-plist6
2 files changed, 15 insertions, 12 deletions
diff --git a/misc/portell/Makefile b/misc/portell/Makefile
index 445df555d3da..4a3c866db0a4 100644
--- a/misc/portell/Makefile
+++ b/misc/portell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portell
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.seekrut.com/rk/
DISTNAME= ${PORTNAME}
@@ -16,11 +17,13 @@ MAINTAINER= mich@freebsdcluster.org
COMMENT= Quick display of FreeBSD port descriptions
USE_PYTHON= YES
-NO_BUILD= YES
+USE_REINPLACE= YES
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin
+do-build:
+ ${REINPLACE_CMD} -e 's/portell.py/portell/' ${WRKDIR}/README
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/portell.py ${PREFIX}/bin/portell
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README ${DOCSDIR}
@@ -28,12 +31,12 @@ do-install:
post-install:
.if !defined(BATCH)
- @${ECHO_CMD} ""
- @${ECHO_CMD} "###############################################################################"
- @${ECHO_CMD} "# You must run 'portell.py -u' to initialize the DB. #"
- @${ECHO_CMD} "# ${DOCSDIR}/README for more information. #"
- @${ECHO_CMD} "###############################################################################"
- @${ECHO_CMD}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG} "# You must run 'portell -u' to initialize the DB"
+ @${ECHO_MSG} "# ${DOCSDIR}/README for more information."
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG} ""
.endif
.include <bsd.port.mk>
diff --git a/misc/portell/pkg-plist b/misc/portell/pkg-plist
index 46ade5e3f4b5..c03b2356b55e 100644
--- a/misc/portell/pkg-plist
+++ b/misc/portell/pkg-plist
@@ -1,3 +1,3 @@
-bin/portell.py
-share/doc/portell/README
-@dirrm share/doc/portell
+bin/portell
+%%PORTDOCS%%share/doc/portell/README
+%%PORTDOCS%%@dirrm share/doc/portell