aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-09-26 20:25:52 +0800
committerantoine <antoine@FreeBSD.org>2015-09-26 20:25:52 +0800
commit6b5858fec4db786d24622ab72387b862ca03f777 (patch)
tree46975994b299e5d6925938daf5f74ee4cb7bfe25 /misc
parent49f4f2d1cac7d44848044fdec5410a57cee99ade (diff)
downloadfreebsd-ports-gnome-6b5858fec4db786d24622ab72387b862ca03f777.tar.gz
freebsd-ports-gnome-6b5858fec4db786d24622ab72387b862ca03f777.tar.zst
freebsd-ports-gnome-6b5858fec4db786d24622ab72387b862ca03f777.zip
Remove @exec lines redundant with USE_LDCONFIG32
Diffstat (limited to 'misc')
-rw-r--r--misc/compat10x/Makefile1
-rw-r--r--misc/compat10x/pkg-plist.amd641
-rw-r--r--misc/compat4x/Makefile2
-rw-r--r--misc/compat4x/pkg-plist.freebsd51
-rw-r--r--misc/compat5x/Makefile1
-rw-r--r--misc/compat5x/pkg-plist1
-rw-r--r--misc/compat6x/Makefile1
-rw-r--r--misc/compat6x/pkg-plist.amd641
-rw-r--r--misc/compat7x/Makefile1
-rw-r--r--misc/compat7x/pkg-plist.amd641
-rw-r--r--misc/compat8x/Makefile1
-rw-r--r--misc/compat8x/pkg-plist.amd641
-rw-r--r--misc/compat9x/Makefile1
-rw-r--r--misc/compat9x/pkg-plist.amd641
14 files changed, 0 insertions, 15 deletions
diff --git a/misc/compat10x/Makefile b/misc/compat10x/Makefile
index 75e48f9f2232..a19bc042f05f 100644
--- a/misc/compat10x/Makefile
+++ b/misc/compat10x/Makefile
@@ -27,7 +27,6 @@ IGNORE= is for FreeBSD 10.x and newer
.endif
.if ${ARCH} == amd64
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.endif
diff --git a/misc/compat10x/pkg-plist.amd64 b/misc/compat10x/pkg-plist.amd64
index d510c9e27288..44c02abb199f 100644
--- a/misc/compat10x/pkg-plist.amd64
+++ b/misc/compat10x/pkg-plist.amd64
@@ -14,4 +14,3 @@ lib32/compat/libipx.so.5
lib32/compat/libopie.so.7
lib32/compat/libreadline.so.8
lib32/compat/libsbuf.so.6
-@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index f578844ae999..1b2b09ef727a 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -20,7 +20,6 @@ WRKSRC= ${WRKDIR}/usr/lib/compat
NO_BUILD= yes
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
-LDCONFIG_LIB32= ${LDCONFIG} -32
.include <bsd.port.pre.mk>
@@ -50,7 +49,6 @@ PLIST_SUB+= I386_ONLY="@comment "
.if ${ARCH} == amd64
PLIST_SUB+= AMD64_ONLY="" AMD64NA="@comment "
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.else
USE_LDCONFIG= ${TARGET_DIR}
diff --git a/misc/compat4x/pkg-plist.freebsd5 b/misc/compat4x/pkg-plist.freebsd5
index 55f5ac37edc3..791340e01fae 100644
--- a/misc/compat4x/pkg-plist.freebsd5
+++ b/misc/compat4x/pkg-plist.freebsd5
@@ -37,5 +37,4 @@
%%LIBDIR%%/compat/pam_ssh.so
%%LIBDIR%%/compat/pam_tacplus.so
%%LIBDIR%%/compat/pam_unix.so
-%%AMD64_ONLY%%@exec %%LDCONFIG_LIB32%% -m %D/%%LIBDIR%%/compat
@comment Hardcode lib32 since we should not remove lib.
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index 5bea85666112..8a18a279d953 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -35,7 +35,6 @@ BROKEN= Does not install on sparc64: fails to link lib/compat/libpthread.so.1
.if ${ARCH} == amd64
PLIST_SUB+= AMD64=""
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.else
PLIST_SUB+= AMD64="@comment "
diff --git a/misc/compat5x/pkg-plist b/misc/compat5x/pkg-plist
index 16c8902bc795..f7bfc2d0219d 100644
--- a/misc/compat5x/pkg-plist
+++ b/misc/compat5x/pkg-plist
@@ -208,4 +208,3 @@ lib/compat/snmp_netgraph.so.2
%%AMD64%%lib32/compat/snmp_atm.so.2
%%AMD64%%lib32/compat/snmp_mibII.so.2
%%AMD64%%lib32/compat/snmp_netgraph.so.2
-%%AMD64%%@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat
diff --git a/misc/compat6x/Makefile b/misc/compat6x/Makefile
index 909574cced62..ab28da2f4e78 100644
--- a/misc/compat6x/Makefile
+++ b/misc/compat6x/Makefile
@@ -28,7 +28,6 @@ BROKEN= Does not install on sparc64: fails to link lib/compat/libpthread.so.2
.endif
.if ${ARCH} == amd64
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.endif
diff --git a/misc/compat6x/pkg-plist.amd64 b/misc/compat6x/pkg-plist.amd64
index 9afff0862f06..2c482114f7e2 100644
--- a/misc/compat6x/pkg-plist.amd64
+++ b/misc/compat6x/pkg-plist.amd64
@@ -207,4 +207,3 @@ lib32/compat/pam_self.so.3
lib32/compat/pam_ssh.so.3
lib32/compat/pam_tacplus.so.3
lib32/compat/pam_unix.so.3
-@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat
diff --git a/misc/compat7x/Makefile b/misc/compat7x/Makefile
index b32bb7ed618d..a03055ae7e36 100644
--- a/misc/compat7x/Makefile
+++ b/misc/compat7x/Makefile
@@ -23,7 +23,6 @@ USE_LDCONFIG= ${TARGET_DIR}
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.endif
diff --git a/misc/compat7x/pkg-plist.amd64 b/misc/compat7x/pkg-plist.amd64
index 3a0db4c3a055..d5d8bf892dac 100644
--- a/misc/compat7x/pkg-plist.amd64
+++ b/misc/compat7x/pkg-plist.amd64
@@ -222,4 +222,3 @@ lib32/compat/pam_self.so.4
lib32/compat/pam_ssh.so.4
lib32/compat/pam_tacplus.so.4
lib32/compat/pam_unix.so.4
-@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat
diff --git a/misc/compat8x/Makefile b/misc/compat8x/Makefile
index 34b038f784aa..29a214113a8d 100644
--- a/misc/compat8x/Makefile
+++ b/misc/compat8x/Makefile
@@ -29,7 +29,6 @@ RUN_DEPENDS= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
.endif
.if ${ARCH} == amd64
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.endif
diff --git a/misc/compat8x/pkg-plist.amd64 b/misc/compat8x/pkg-plist.amd64
index a68f7db30d8e..230b9bf75377 100644
--- a/misc/compat8x/pkg-plist.amd64
+++ b/misc/compat8x/pkg-plist.amd64
@@ -22,4 +22,3 @@ lib32/compat/libtacplus.so.4
lib32/compat/libufs.so.5
lib32/compat/libutil.so.8
lib32/compat/libz.so.5
-@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat
diff --git a/misc/compat9x/Makefile b/misc/compat9x/Makefile
index 97f84f7476d1..6c59459cc7eb 100644
--- a/misc/compat9x/Makefile
+++ b/misc/compat9x/Makefile
@@ -27,7 +27,6 @@ IGNORE= is for FreeBSD 9.x and newer
.endif
.if ${ARCH} == amd64
-PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
.endif
diff --git a/misc/compat9x/pkg-plist.amd64 b/misc/compat9x/pkg-plist.amd64
index 7865b833ea48..1757db416735 100644
--- a/misc/compat9x/pkg-plist.amd64
+++ b/misc/compat9x/pkg-plist.amd64
@@ -41,4 +41,3 @@ lib32/compat/libssl.so.6
lib32/compat/libstdc++.so.6
lib32/compat/libsupc++.so.1
lib32/compat/libusb.so.2
-@exec %%LDCONFIG_LIB32%% -m %D/lib32/compat