aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-05 21:53:19 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-05 21:53:19 +0800
commit767787da473d3f67c7ee38697b3adb643d1aa7b3 (patch)
tree37331141a3f439b1cfe96247954b1ca66cfd7357 /misc
parent7331c11a2f326baf4340fd8d2bbf11f597bc805e (diff)
downloadfreebsd-ports-gnome-767787da473d3f67c7ee38697b3adb643d1aa7b3.tar.gz
freebsd-ports-gnome-767787da473d3f67c7ee38697b3adb643d1aa7b3.tar.zst
freebsd-ports-gnome-767787da473d3f67c7ee38697b3adb643d1aa7b3.zip
misc/libsweep-lidar: fix build with GCC architectures
This needs c++11 compiler. GCC from ports doesn't support -Weverything. PR: 239332 Approved by: hyun@caffeinated.codes (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D21145
Diffstat (limited to 'misc')
-rw-r--r--misc/libsweep-lidar/Makefile4
-rw-r--r--misc/libsweep-lidar/files/patch-libsweep_CMakeLists.txt11
2 files changed, 12 insertions, 3 deletions
diff --git a/misc/libsweep-lidar/Makefile b/misc/libsweep-lidar/Makefile
index a417e7ea96d8..87b2e8026feb 100644
--- a/misc/libsweep-lidar/Makefile
+++ b/misc/libsweep-lidar/Makefile
@@ -11,9 +11,7 @@ COMMENT= Low-level Scanse Sweep LiDAR library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Weverything"
-
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= scanse
GH_PROJECT= sweep-sdk
diff --git a/misc/libsweep-lidar/files/patch-libsweep_CMakeLists.txt b/misc/libsweep-lidar/files/patch-libsweep_CMakeLists.txt
new file mode 100644
index 000000000000..24d65187c867
--- /dev/null
+++ b/misc/libsweep-lidar/files/patch-libsweep_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libsweep/CMakeLists.txt.orig 2019-07-20 09:46:23 UTC
++++ libsweep/CMakeLists.txt
+@@ -19,7 +19,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ set(libsweep_OS unix)
+
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Weverything -fvisibility=hidden -fPIC -fno-rtti")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fvisibility=hidden -fPIC -fno-rtti")
+ set(libsweep_OS unix)
+
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")