aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2004-03-20 21:19:31 +0800
committerphantom <phantom@FreeBSD.org>2004-03-20 21:19:31 +0800
commit7ebca294f75886b0180302c032989e717e9f03e8 (patch)
tree082a280583527e0b00893758c82c9233fe756479 /misc
parent20972bd61aed7c7d1ea886161b0c7455955b2398 (diff)
downloadfreebsd-ports-gnome-7ebca294f75886b0180302c032989e717e9f03e8.tar.gz
freebsd-ports-gnome-7ebca294f75886b0180302c032989e717e9f03e8.tar.zst
freebsd-ports-gnome-7ebca294f75886b0180302c032989e717e9f03e8.zip
Make libpthread default threading library. Since this port is supposed
to be compiled/run against any threading library in system, so we can't use default PTHREAD_LIBS stuff here.
Diffstat (limited to 'misc')
-rw-r--r--misc/posixtestsuite/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
index e5334ff87420..32b6772d757a 100644
--- a/misc/posixtestsuite/Makefile
+++ b/misc/posixtestsuite/Makefile
@@ -43,7 +43,7 @@ THEPIPE= | tee 2>&1
.if defined(WITH_THRLIB)
THRLIB=${WITH_THRLIB}
.else
-THRLIB= -lc_r
+THRLIB= -lpthread
.endif
pre-everything::
@@ -58,15 +58,16 @@ pre-everything::
@${ECHO} ""
@${ECHO} " * QUIET - don't print progress messages while running"
@${ECHO} " * WITH_THRLIB - choose thread library to run test against"
- @${ECHO} " (NB: by default 'libc_r' is used)"
+ @${ECHO} " (NB: by default 'libpthread' is used)"
@${ECHO} ""
@${ECHO} "Examples:"
@${ECHO} ""
- @${ECHO} " make WITH_THRLIB=libkse run"
- @${ECHO} " - run tests against libkse"
+ @${ECHO} " make WITH_THRLIB=libthr run"
+ @${ECHO} " - run tests against libthr"
@${ECHO} ""
@${ECHO} " make QUIET=YES WITH_THRLIB= regression"
- @${ECHO} " - be quiet, run tests against libc, compare tests results"
+ @${ECHO} " - be quiet, run tests against libpthread (default"
+ @${ECHO} " threading library), compare tests results"
@${ECHO} ""
help: pre-everything