aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-01-22 19:06:02 +0800
committertrevor <trevor@FreeBSD.org>2004-01-22 19:06:02 +0800
commit95b0fb093b0c0fe3ac4b112fd462a41fa1933a35 (patch)
tree607a7a5c9179d269688eebfcbd7a60c01c983c03 /misc
parentdbde1e218a8b9a82a1edefb7c0aed001b0d24fd5 (diff)
downloadfreebsd-ports-gnome-95b0fb093b0c0fe3ac4b112fd462a41fa1933a35.tar.gz
freebsd-ports-gnome-95b0fb093b0c0fe3ac4b112fd462a41fa1933a35.tar.zst
freebsd-ports-gnome-95b0fb093b0c0fe3ac4b112fd462a41fa1933a35.zip
Use the SORT macro from bsd.port.mk.
Diffstat (limited to 'misc')
-rw-r--r--misc/gnomehier/Makefile4
-rw-r--r--misc/lingoteach/Makefile2
-rw-r--r--misc/sword-modules/Makefile1
3 files changed, 2 insertions, 5 deletions
diff --git a/misc/gnomehier/Makefile b/misc/gnomehier/Makefile
index 0e00fad19d33..066c639e3a7c 100644
--- a/misc/gnomehier/Makefile
+++ b/misc/gnomehier/Makefile
@@ -27,13 +27,13 @@ do-fetch:
pre-install:
@${RM} -f ${PLIST}
@${TOUCH} -f ${PLIST}
- @${CAT} ${FILESDIR}/dirlist | sort | ${SED} -e \
+ @${CAT} ${FILESDIR}/dirlist | ${SORT} | ${SED} -e \
's|$$|/.keep_me|' >> ${PLIST}
@${ECHO_CMD} "etc/gconf/gconf.xml.defaults/schemas/apps/%gconf.xml" \
>> ${PLIST}
@${ECHO_CMD} "etc/gconf/gconf.xml.defaults/apps/%gconf.xml" \
>> ${PLIST}
- @${CAT} ${FILESDIR}/dirlist | sort -r | ${SED} -e \
+ @${CAT} ${FILESDIR}/dirlist | ${SORT} -r | ${SED} -e \
's|^|@dirrm |' >> ${PLIST}
do-install:
diff --git a/misc/lingoteach/Makefile b/misc/lingoteach/Makefile
index 1f94981f26a3..ba85a09edb68 100644
--- a/misc/lingoteach/Makefile
+++ b/misc/lingoteach/Makefile
@@ -42,8 +42,6 @@ CONFIGURE_ARGS+= --enable-debug
PLIST= ${WRKDIR}/plist
.endif
-SORT?= /usr/bin/sort
-
.include <bsd.port.pre.mk>
pre-everything::
diff --git a/misc/sword-modules/Makefile b/misc/sword-modules/Makefile
index e5238123231c..fab68facdaac 100644
--- a/misc/sword-modules/Makefile
+++ b/misc/sword-modules/Makefile
@@ -45,7 +45,6 @@ SCRIPTS_ENV= SETDIR="${SETDIR}" \
BATCH="${BATCH}"
DIRNAME?= ${BASENAME:S/basename/dirname/}
-SORT?= sort
.if !exists(${MODFILE})
pre-fetch: select