aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-10-22 01:49:53 +0800
committeryuri <yuri@FreeBSD.org>2018-10-22 01:49:53 +0800
commita50587c13400deef602267e2e3f96e283b85c7cc (patch)
tree550285fd32df0eb43aa1306e9661836b099b6b0e /misc
parent9eb06009beec3c76c340efb7860804b53114cd69 (diff)
downloadfreebsd-ports-gnome-a50587c13400deef602267e2e3f96e283b85c7cc.tar.gz
freebsd-ports-gnome-a50587c13400deef602267e2e3f96e283b85c7cc.tar.zst
freebsd-ports-gnome-a50587c13400deef602267e2e3f96e283b85c7cc.zip
New port: misc/py-molequeue: Python binding for MolEqueue, task management framework
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-molequeue/Makefile22
-rw-r--r--misc/py-molequeue/distinfo3
-rw-r--r--misc/py-molequeue/files/patch-molequeue_client.py11
-rw-r--r--misc/py-molequeue/pkg-descr5
-rw-r--r--misc/py-molequeue/pkg-plist3
6 files changed, 45 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index cf920020a5e5..9c3bc6d0e1c9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -418,6 +418,7 @@
SUBDIR += py-fuzzy
SUBDIR += py-glance
SUBDIR += py-kartograph
+ SUBDIR += py-molequeue
SUBDIR += py-orange3-associate
SUBDIR += py-orange3-datafusion
SUBDIR += py-orange3-educational
diff --git a/misc/py-molequeue/Makefile b/misc/py-molequeue/Makefile
new file mode 100644
index 000000000000..0a2e683aedea
--- /dev/null
+++ b/misc/py-molequeue/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= molequeue
+DISTVERSION= 0.9.0
+CATEGORIES= misc
+MASTER_SITES= https://github.com/openchemistry/molequeue/releases/download/${DISTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python binding for MolEqueue, task management framework
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>0:net/py-pyzmq@${PY_FLAVOR}
+
+USES= cmake:outsource compiler:c++11-lang python
+USE_PYTHON= flavors
+
+WRKSRC_SUBDIR= python
+
+.include <bsd.port.mk>
diff --git a/misc/py-molequeue/distinfo b/misc/py-molequeue/distinfo
new file mode 100644
index 000000000000..d384fa42ce15
--- /dev/null
+++ b/misc/py-molequeue/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539726091
+SHA256 (molequeue-0.9.0.tar.gz) = df036dbca090db4348443cf3d09be35fdf877a37075b4cb427b1130f005ef6e5
+SIZE (molequeue-0.9.0.tar.gz) = 620286
diff --git a/misc/py-molequeue/files/patch-molequeue_client.py b/misc/py-molequeue/files/patch-molequeue_client.py
new file mode 100644
index 000000000000..1b1d752bcc23
--- /dev/null
+++ b/misc/py-molequeue/files/patch-molequeue_client.py
@@ -0,0 +1,11 @@
+--- molequeue/client.py.orig 2018-10-21 03:22:34 UTC
++++ molequeue/client.py
+@@ -122,7 +122,7 @@ class Client:
+ self.socket = self.context.socket(zmq.DEALER)
+
+ tmpdir = tempfile.gettempdir()
+- connection_string = 'ipc://%s/%s_%s' % (tmpdir, 'zmq', server)
++ connection_string = 'ipc://%s/%s' % (tmpdir, server)
+ self.socket.connect(connection_string)
+
+ io_loop = ioloop.IOLoop.instance()
diff --git a/misc/py-molequeue/pkg-descr b/misc/py-molequeue/pkg-descr
new file mode 100644
index 000000000000..d6d631735d41
--- /dev/null
+++ b/misc/py-molequeue/pkg-descr
@@ -0,0 +1,5 @@
+Pythin bindings for MoleQueue, an open-source, cross-platform, system-tray
+resident desktop application for abstracting, managing, and coordinating the
+execution of tasks both locally and on remote computational resources.
+
+WWW: https://www.openchemistry.org/projects/molequeue
diff --git a/misc/py-molequeue/pkg-plist b/misc/py-molequeue/pkg-plist
new file mode 100644
index 000000000000..3fcaff435865
--- /dev/null
+++ b/misc/py-molequeue/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/molequeue/__init__.py
+%%PYTHON_SITELIBDIR%%/molequeue/client.py
+%%PYTHON_SITELIBDIR%%/molequeue/utils.py