aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2016-04-30 09:08:02 +0800
committerzi <zi@FreeBSD.org>2016-04-30 09:08:02 +0800
commita71f051f30e464a4c892a6dff7d3c6c3fe0a1179 (patch)
tree611e35aa793180f678be0f91f7ad6f13170cedc7 /misc
parent836f07b46d653fb2e2fcc962f4f6a6d422024b9e (diff)
downloadfreebsd-ports-gnome-a71f051f30e464a4c892a6dff7d3c6c3fe0a1179.tar.gz
freebsd-ports-gnome-a71f051f30e464a4c892a6dff7d3c6c3fe0a1179.tar.zst
freebsd-ports-gnome-a71f051f30e464a4c892a6dff7d3c6c3fe0a1179.zip
New port: misc/nms:
"No More Secrets" is the name I've lovingly given to the infamous "decrypting text" effect seen on screen in the 1992 hacker movie Sneakers. This project provides tools to recreate this effect in your projects. WWW: https://github.com/bartobri/no-more-secrets
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/nms/Makefile23
-rw-r--r--misc/nms/distinfo2
-rw-r--r--misc/nms/files/patch-Makefile11
-rw-r--r--misc/nms/pkg-descr7
5 files changed, 44 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 709492533991..207ec33de209 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -275,6 +275,7 @@
SUBDIR += mtx
SUBDIR += najitool
SUBDIR += newer
+ SUBDIR += nms
SUBDIR += nsf
SUBDIR += numchar
SUBDIR += nut
diff --git a/misc/nms/Makefile b/misc/nms/Makefile
new file mode 100644
index 000000000000..160a9dcec87c
--- /dev/null
+++ b/misc/nms/Makefile
@@ -0,0 +1,23 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nms
+PORTVERSION= 20160429
+CATEGORIES= misc
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Recreate decrypting text effect from the Sneakers movie
+
+LICENSE= GPLv3
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= bartobri
+GH_PROJECT= no-more-secrets
+GH_TAGNAME= 9a7a77c
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/nms/distinfo b/misc/nms/distinfo
new file mode 100644
index 000000000000..95cee0e5bfe3
--- /dev/null
+++ b/misc/nms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bartobri-no-more-secrets-20160429-9a7a77c_GH0.tar.gz) = a25e0577a17212e00f0e4d1b5818212567d72cc4e7c392e3c0f81aa55487c4f6
+SIZE (bartobri-no-more-secrets-20160429-9a7a77c_GH0.tar.gz) = 18503
diff --git a/misc/nms/files/patch-Makefile b/misc/nms/files/patch-Makefile
new file mode 100644
index 000000000000..4be0c2bc8f56
--- /dev/null
+++ b/misc/nms/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-04-30 01:05:20 UTC
++++ Makefile
+@@ -2,7 +2,7 @@ BIN=bin
+ OBJ=obj
+ SRC=src
+
+-CC = gcc
++CC ?= gcc
+ CFLAGS = -Wextra -Wall
+ LDLIBS = -lncurses
+ NCURSES_H = /usr/include/ncurses.h
diff --git a/misc/nms/pkg-descr b/misc/nms/pkg-descr
new file mode 100644
index 000000000000..e730322f31b3
--- /dev/null
+++ b/misc/nms/pkg-descr
@@ -0,0 +1,7 @@
+"No More Secrets" is the name I've lovingly given to the infamous
+"decrypting text" effect seen on screen in the 1992 hacker movie
+Sneakers.
+
+This project provides tools to recreate this effect in your projects.
+
+WWW: https://github.com/bartobri/no-more-secrets