aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-08-16 05:28:11 +0800
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-08-16 05:28:11 +0800
commitb1479c55cc6ae7f247e9e1cb2f08efdf1c7f99d2 (patch)
tree0f6a0e6590803463da9e363cb458250b0324617c /misc
parentb153af3794ba7db81bb750ddb42f435bd66cfd58 (diff)
downloadfreebsd-ports-gnome-b1479c55cc6ae7f247e9e1cb2f08efdf1c7f99d2.tar.gz
freebsd-ports-gnome-b1479c55cc6ae7f247e9e1cb2f08efdf1c7f99d2.tar.zst
freebsd-ports-gnome-b1479c55cc6ae7f247e9e1cb2f08efdf1c7f99d2.zip
- Update to 0.8.1
- Use USE_PKGCONFIG macro Approved by: rene, miwi (mentors)
Diffstat (limited to 'misc')
-rw-r--r--misc/xfce4-weather-plugin/Makefile16
-rw-r--r--misc/xfce4-weather-plugin/distinfo4
-rw-r--r--misc/xfce4-weather-plugin/files/patch-configure45
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather-http.c10
-rw-r--r--misc/xfce4-weather-plugin/pkg-plist97
5 files changed, 105 insertions, 67 deletions
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
index 590a0aa5acbf..450c09bec14d 100644
--- a/misc/xfce4-weather-plugin/Makefile
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= xfce4-weather-plugin
-PORTVERSION= 0.7.4
-PORTREVISION= 3
+PORTVERSION= 0.8.1
CATEGORIES= misc xfce geography
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@@ -21,13 +20,8 @@ INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 intltool intlhack libxml2 pkgconfig
-USE_XFCE= configenv libgui libutil panel
-
-post-patch:
-# Patch taken from https://bugzilla.xfce.org/show_bug.cgi?id=8105#c9
- @${REINPLACE_CMD} -e 's|1121946239|1003666583| ; \
- s|3c4cd39ee5dec84f|4128909340a9b2fc|' \
- ${WRKSRC}/panel-plugin/weather.h
+USE_GNOME= gnomehack glib20 gtk20 intltool intlhack libxml2
+USE_XFCE= configenv libmenu libutil panel
+USE_PKGCONFIG= build
.include <bsd.port.mk>
diff --git a/misc/xfce4-weather-plugin/distinfo b/misc/xfce4-weather-plugin/distinfo
index 012e03d222e1..7974a950a9b9 100644
--- a/misc/xfce4-weather-plugin/distinfo
+++ b/misc/xfce4-weather-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-weather-plugin-0.7.4.tar.bz2) = 3f76207b8a845d15bfec6825bd5300aedd086c455259c4dd8670a89a3c8ab382
-SIZE (xfce4/xfce4-weather-plugin-0.7.4.tar.bz2) = 686773
+SHA256 (xfce4/xfce4-weather-plugin-0.8.1.tar.bz2) = a03a001065afdd8a167a44b96885d70013290b88d82e7deec45a2d294411077d
+SIZE (xfce4/xfce4-weather-plugin-0.8.1.tar.bz2) = 662546
diff --git a/misc/xfce4-weather-plugin/files/patch-configure b/misc/xfce4-weather-plugin/files/patch-configure
new file mode 100644
index 000000000000..3d7c1eab61a0
--- /dev/null
+++ b/misc/xfce4-weather-plugin/files/patch-configure
@@ -0,0 +1,45 @@
+--- configure.orig 2012-08-06 11:16:36.000000000 +0000
++++ configure 2012-08-12 14:57:44.000000000 +0000
+@@ -14468,13 +14468,13 @@
+ fi
+
+
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for res_query in -lresolv" >&5
+-$as_echo_n "checking for res_query in -lresolv... " >&6; }
+-if ${ac_cv_lib_resolv_res_query+:} false; then :
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for res_query in -lc" >&5
++$as_echo_n "checking for res_query in -lc... " >&6; }
++if ${ac_cv_lib_c_res_query+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lresolv $LIBS"
++LIBS="-lc $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14494,18 +14494,18 @@
+ }
+ _ACEOF
+ if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_lib_resolv_res_query=yes
++ ac_cv_lib_c_res_query=yes
+ else
+- ac_cv_lib_resolv_res_query=no
++ ac_cv_lib_c_res_query=no
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_resolv_res_query" >&5
+-$as_echo "$ac_cv_lib_resolv_res_query" >&6; }
+-if test "x$ac_cv_lib_resolv_res_query" = xyes; then :
+- LIBRESOLV=-lresolv
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_c_res_query" >&5
++$as_echo "$ac_cv_lib_c_res_query" >&6; }
++if test "x$ac_cv_lib_c_res_query" = xyes; then :
++ LIBRESOLV=-lc
+ fi
+
+
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather-http.c b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather-http.c
new file mode 100644
index 000000000000..e1094e13783d
--- /dev/null
+++ b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather-http.c
@@ -0,0 +1,10 @@
+--- panel-plugin/weather-http.c.orig 2012-08-02 21:16:17.000000000 +0000
++++ panel-plugin/weather-http.c 2012-08-12 19:28:36.000000000 +0000
+@@ -32,6 +32,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <netinet/in.h>
++#include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <signal.h>
+ #include <setjmp.h>
diff --git a/misc/xfce4-weather-plugin/pkg-plist b/misc/xfce4-weather-plugin/pkg-plist
index 9014f101c066..8ae8a044fe95 100644
--- a/misc/xfce4-weather-plugin/pkg-plist
+++ b/misc/xfce4-weather-plugin/pkg-plist
@@ -1,7 +1,9 @@
-libexec/xfce4/panel-plugins/xfce4-weather-plugin
+lib/xfce4/panel/plugins/libweather.la
+lib/xfce4/panel/plugins/libweather.so
share/icons/hicolor/48x48/apps/xfce4-weather.png
share/locale/ar/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/ast/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/be/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/ca/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/cs/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/da/LC_MESSAGES/xfce4-weather-plugin.mo
@@ -13,14 +15,18 @@ share/locale/eu/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/fi/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/fr/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/gl/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/he/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/hr/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/hu/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/id/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/it/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/ja/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/ko/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/lt/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/lv/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/nb/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/nl/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/nn/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/pa/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/pl/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/pt/LC_MESSAGES/xfce4-weather-plugin.mo
@@ -29,6 +35,7 @@ share/locale/ru/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/sk/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/sq/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/sv/LC_MESSAGES/xfce4-weather-plugin.mo
+share/locale/te/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/tr/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/ug/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/uk/LC_MESSAGES/xfce4-weather-plugin.mo
@@ -36,60 +43,39 @@ share/locale/ur/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/ur_PK/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/zh_CN/LC_MESSAGES/xfce4-weather-plugin.mo
share/locale/zh_TW/LC_MESSAGES/xfce4-weather-plugin.mo
-share/xfce4/panel-plugins/weather.desktop
-share/xfce4/weather/icons/liquid/0.png
-share/xfce4/weather/icons/liquid/1.png
-share/xfce4/weather/icons/liquid/10.png
-share/xfce4/weather/icons/liquid/11.png
-share/xfce4/weather/icons/liquid/12.png
-share/xfce4/weather/icons/liquid/13.png
-share/xfce4/weather/icons/liquid/14.png
-share/xfce4/weather/icons/liquid/15.png
-share/xfce4/weather/icons/liquid/16.png
-share/xfce4/weather/icons/liquid/17.png
-share/xfce4/weather/icons/liquid/18.png
-share/xfce4/weather/icons/liquid/19.png
-share/xfce4/weather/icons/liquid/2.png
-share/xfce4/weather/icons/liquid/20.png
-share/xfce4/weather/icons/liquid/21.png
-share/xfce4/weather/icons/liquid/22.png
-share/xfce4/weather/icons/liquid/23.png
-share/xfce4/weather/icons/liquid/24.png
-share/xfce4/weather/icons/liquid/25.png
-share/xfce4/weather/icons/liquid/26.png
-share/xfce4/weather/icons/liquid/27.png
-share/xfce4/weather/icons/liquid/28.png
-share/xfce4/weather/icons/liquid/29.png
-share/xfce4/weather/icons/liquid/3.png
-share/xfce4/weather/icons/liquid/30.png
-share/xfce4/weather/icons/liquid/31.png
-share/xfce4/weather/icons/liquid/32.png
-share/xfce4/weather/icons/liquid/33.png
-share/xfce4/weather/icons/liquid/34.png
-share/xfce4/weather/icons/liquid/35.png
-share/xfce4/weather/icons/liquid/36.png
-share/xfce4/weather/icons/liquid/37.png
-share/xfce4/weather/icons/liquid/38.png
-share/xfce4/weather/icons/liquid/39.png
-share/xfce4/weather/icons/liquid/4.png
-share/xfce4/weather/icons/liquid/40.png
-share/xfce4/weather/icons/liquid/41.png
-share/xfce4/weather/icons/liquid/42.png
-share/xfce4/weather/icons/liquid/43.png
-share/xfce4/weather/icons/liquid/44.png
-share/xfce4/weather/icons/liquid/45.png
-share/xfce4/weather/icons/liquid/46.png
-share/xfce4/weather/icons/liquid/47.png
-share/xfce4/weather/icons/liquid/5.png
-share/xfce4/weather/icons/liquid/6.png
-share/xfce4/weather/icons/liquid/7.png
-share/xfce4/weather/icons/liquid/8.png
-share/xfce4/weather/icons/liquid/9.png
-share/xfce4/weather/icons/liquid/99.png
+share/xfce4/panel/plugins/weather.desktop
+share/xfce4/weather/icons/liquid/CLOUD-night.png
+share/xfce4/weather/icons/liquid/CLOUD.png
+share/xfce4/weather/icons/liquid/FOG.png
+share/xfce4/weather/icons/liquid/LIGHTCLOUD-night.png
+share/xfce4/weather/icons/liquid/LIGHTCLOUD.png
+share/xfce4/weather/icons/liquid/LIGHTRAIN.png
+share/xfce4/weather/icons/liquid/LIGHTRAINSUN-night.png
+share/xfce4/weather/icons/liquid/LIGHTRAINSUN.png
+share/xfce4/weather/icons/liquid/LIGHTRAINTHUNDER.png
+share/xfce4/weather/icons/liquid/LIGHTRAINTHUNDERSUN-night.png
+share/xfce4/weather/icons/liquid/LIGHTRAINTHUNDERSUN.png
+share/xfce4/weather/icons/liquid/NODATA.png
+share/xfce4/weather/icons/liquid/PARTLYCLOUD-night.png
+share/xfce4/weather/icons/liquid/PARTLYCLOUD.png
+share/xfce4/weather/icons/liquid/RAIN.png
+share/xfce4/weather/icons/liquid/RAINTHUNDER.png
+share/xfce4/weather/icons/liquid/SLEET.png
+share/xfce4/weather/icons/liquid/SLEETSUN.png
+share/xfce4/weather/icons/liquid/SLEETSUNTHUNDER.png
+share/xfce4/weather/icons/liquid/SLEETTHUNDER.png
+share/xfce4/weather/icons/liquid/SNOW.png
+share/xfce4/weather/icons/liquid/SNOWSUN-night.png
+share/xfce4/weather/icons/liquid/SNOWSUN.png
+share/xfce4/weather/icons/liquid/SNOWSUNTHUNDER.png
+share/xfce4/weather/icons/liquid/SNOWTHUNDER.png
+share/xfce4/weather/icons/liquid/SUN-night.png
+share/xfce4/weather/icons/liquid/SUN.png
@dirrm share/xfce4/weather/icons/liquid
@dirrm share/xfce4/weather/icons
@dirrm share/xfce4/weather
-@dirrmtry share/xfce4/panel-plugins
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
@dirrmtry share/xfce4
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
@@ -99,5 +85,8 @@ share/xfce4/weather/icons/liquid/99.png
@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@dirrmtry share/locale/ur
-@dirrmtry libexec/xfce4/panel-plugins
-@dirrmtry libexec/xfce4
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@dirrmtry lib/xfce4