aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-22 19:44:56 +0800
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-22 19:44:56 +0800
commitb53a3b21b78975e24fe33a76f3e27b73c58bd9f4 (patch)
treeb301bbf1b94a15aea42d0f39f69ac1c7ecdd7e0e /misc
parentcf7f7c61a5d6426a94d6bd2b86cf3d461caecf2f (diff)
downloadfreebsd-ports-gnome-b53a3b21b78975e24fe33a76f3e27b73c58bd9f4.tar.gz
freebsd-ports-gnome-b53a3b21b78975e24fe33a76f3e27b73c58bd9f4.tar.zst
freebsd-ports-gnome-b53a3b21b78975e24fe33a76f3e27b73c58bd9f4.zip
misc/lxde-common: NLS and config fixes
- Trim Makefile header - Add LICENSE (GPLv2) - Install docs - Preserve original *.conf files - Pass maintainership to submitter PR: ports/179700 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'misc')
-rw-r--r--misc/lxde-common/Makefile43
-rw-r--r--misc/lxde-common/files/patch-Makefile-am4
-rw-r--r--misc/lxde-common/files/patch-Makefile-in33
-rw-r--r--misc/lxde-common/files/patch-configure4
-rw-r--r--misc/lxde-common/files/patch-configure-ac4
-rw-r--r--misc/lxde-common/pkg-descr2
-rw-r--r--misc/lxde-common/pkg-plist21
7 files changed, 72 insertions, 39 deletions
diff --git a/misc/lxde-common/Makefile b/misc/lxde-common/Makefile
index 45483f6932a9..d33ef95d52b5 100644
--- a/misc/lxde-common/Makefile
+++ b/misc/lxde-common/Makefile
@@ -1,22 +1,19 @@
-# New ports collection makefile for: lxde-common
-# Date created: 2009/02/03
-# Whom: sahne
-#
+# Created by: sahne
# $FreeBSD$
-#
PORTNAME= lxde-common
PORTVERSION= 0.5.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc
-MASTER_SITES= SF/lxde/${PORTNAME}%20%28default%20config%29/LXDE%20Common%20${PORTVERSION}
+MASTER_SITES= SF/lxde/${PORTNAME}%20%28default%20config%29/LXDE%20Common%20${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= LXDE Common files
-USE_GNOME= gtk20
-USE_GMAKE= yes
+LICENSE= GPLv2
+
USES= iconv
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
CPPFLAGS="-I${LOCALBASE}/include" \
@@ -24,12 +21,32 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
GMSGFMT="${LOCALBASE}/bin/msgfmt" \
--with-xsession-path=${PREFIX}/share/xsessions \
--with-xdg-path=${PREFIX}/share/applications
+USE_GMAKE= yes
DATADIR= ${PREFIX}/share/lxde
INSTALLS_ICONS= YES
-MAN1= startlxde.1\
- lxde-logout.1 \
- openbox-lxde.1
+MAN1= startlxde.1 lxde-logout.1 openbox-lxde.1
+
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/desktop.conf ${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf ${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
+.if ! exists(${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf)
+ ${INSTALL_DATA} ${WRKSRC}/desktop.conf ${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf
+.endif
+.if ! exists(${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf)
+ ${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf ${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/misc/lxde-common/files/patch-Makefile-am b/misc/lxde-common/files/patch-Makefile-am
index 5ef5529b4b15..9a7de4482ced 100644
--- a/misc/lxde-common/files/patch-Makefile-am
+++ b/misc/lxde-common/files/patch-Makefile-am
@@ -1,5 +1,5 @@
---- Makefile.am.o 2012-03-09 15:28:13.000000000 -0500
-+++ Makefile.am 2012-03-09 15:29:20.000000000 -0500
+--- Makefile.am.orig 2011-07-29 16:04:03.000000000 +0200
++++ Makefile.am 2013-06-21 19:58:35.000000000 +0200
@@ -6,6 +6,9 @@
xsessiondir=$(xsesspath)
xsession_DATA = LXDE.desktop
diff --git a/misc/lxde-common/files/patch-Makefile-in b/misc/lxde-common/files/patch-Makefile-in
index 99eda80ccbd1..25cc84cd63c8 100644
--- a/misc/lxde-common/files/patch-Makefile-in
+++ b/misc/lxde-common/files/patch-Makefile-in
@@ -1,5 +1,5 @@
---- Makefile.in.o 2012-03-09 15:48:58.000000000 -0500
-+++ Makefile.in 2012-03-09 15:51:53.000000000 -0500
+--- Makefile.in.orig 2011-07-29 16:12:19.000000000 +0200
++++ Makefile.in 2013-06-21 21:33:42.000000000 +0200
@@ -79,7 +79,7 @@
"$(DESTDIR)$(imagesdir)" "$(DESTDIR)$(lxpaneldir)" \
"$(DESTDIR)$(lxpanel_paneldir)" "$(DESTDIR)$(openboxdir)" \
@@ -18,7 +18,7 @@
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
distclean-recursive maintainer-clean-recursive
AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
-@@ -214,12 +214,15 @@
+@@ -214,14 +214,17 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
xsesspath = @xsesspath@
@@ -32,9 +32,22 @@
+xdgdir = $(xdgpath)
+xdg_DATA = lxde-logout.desktop
defaultsdir = $(sysconfdir)/xdg/lxsession/LXDE
- defaults_DATA = autostart desktop.conf
+-defaults_DATA = autostart desktop.conf
++defaults_DATA = autostart
wallpapersdir = $(datadir)/lxde/wallpapers
-@@ -508,6 +511,26 @@
+ wallpapers_DATA = \
+ wallpapers/lxde_blue.jpg \
+@@ -243,8 +246,7 @@
+ openbox/menu.xml
+
+ pcmanfmdir = $(sysconfdir)/xdg/pcmanfm/LXDE
+-pcmanfm_DATA = \
+- pcmanfm/pcmanfm.conf
++pcmanfm_DATA =
+
+ EXTRA_DIST = \
+ autostart \
+@@ -508,6 +510,26 @@
test -n "$$files" || exit 0; \
echo " ( cd '$(DESTDIR)$(xsessiondir)' && rm -f" $$files ")"; \
cd "$(DESTDIR)$(xsessiondir)" && rm -f $$files
@@ -61,7 +74,7 @@
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
-@@ -824,7 +847,7 @@
+@@ -824,7 +846,7 @@
all-am: Makefile $(SCRIPTS) $(DATA)
installdirs: installdirs-recursive
installdirs-am:
@@ -70,7 +83,7 @@
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-recursive
-@@ -877,7 +900,7 @@
+@@ -877,7 +899,7 @@
install-data-am: install-defaultsDATA install-imagesDATA \
install-lxpanelDATA install-lxpanel_panelDATA \
install-openboxDATA install-pcmanfmDATA install-wallpapersDATA \
@@ -79,7 +92,7 @@
install-dvi: install-dvi-recursive
-@@ -927,7 +950,7 @@
+@@ -927,7 +949,7 @@
uninstall-imagesDATA uninstall-lxpanelDATA \
uninstall-lxpanel_panelDATA uninstall-openboxDATA \
uninstall-pcmanfmDATA uninstall-wallpapersDATA \
@@ -88,7 +101,7 @@
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) ctags-recursive \
install-am install-strip tags-recursive
-@@ -945,7 +968,7 @@
+@@ -945,7 +967,7 @@
install-info-am install-lxpanelDATA install-lxpanel_panelDATA \
install-man install-openboxDATA install-pcmanfmDATA \
install-pdf install-pdf-am install-ps install-ps-am \
@@ -97,7 +110,7 @@
installcheck installcheck-am installdirs installdirs-am \
maintainer-clean maintainer-clean-generic mostlyclean \
mostlyclean-generic pdf pdf-am ps ps-am tags tags-recursive \
-@@ -953,7 +976,7 @@
+@@ -953,7 +975,7 @@
uninstall-defaultsDATA uninstall-imagesDATA \
uninstall-lxpanelDATA uninstall-lxpanel_panelDATA \
uninstall-openboxDATA uninstall-pcmanfmDATA \
diff --git a/misc/lxde-common/files/patch-configure b/misc/lxde-common/files/patch-configure
index 3c939aed7bb1..08cbf5424a4c 100644
--- a/misc/lxde-common/files/patch-configure
+++ b/misc/lxde-common/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2011-07-29 10:12:19.000000000 -0400
-+++ configure 2012-03-09 16:08:37.000000000 -0500
+--- configure.orig 2011-07-29 16:12:19.000000000 +0200
++++ configure 2013-06-21 20:48:19.000000000 +0200
@@ -568,6 +568,7 @@
XMLCATALOG
XML_CATALOG_FILE
diff --git a/misc/lxde-common/files/patch-configure-ac b/misc/lxde-common/files/patch-configure-ac
index f5a5248553a5..1b10383bb959 100644
--- a/misc/lxde-common/files/patch-configure-ac
+++ b/misc/lxde-common/files/patch-configure-ac
@@ -1,5 +1,5 @@
---- configure.ac.orig 2011-07-29 10:04:03.000000000 -0400
-+++ configure.ac 2012-03-09 16:09:36.000000000 -0500
+--- configure.ac.orig 2011-07-29 16:04:03.000000000 +0200
++++ configure.ac 2013-06-21 21:11:18.000000000 +0200
@@ -23,6 +23,15 @@
[xsesspath="\${datarootdir}/xsessions"])
AC_SUBST(xsesspath)
diff --git a/misc/lxde-common/pkg-descr b/misc/lxde-common/pkg-descr
index f5596d5ed937..e3dea963b9ec 100644
--- a/misc/lxde-common/pkg-descr
+++ b/misc/lxde-common/pkg-descr
@@ -1,3 +1,3 @@
LXDE Common files including startup and logout scripts.
-WWW: http://lxde.org/
+WWW: http://lxde.org/
diff --git a/misc/lxde-common/pkg-plist b/misc/lxde-common/pkg-plist
index 710333828dc7..723ad11f50eb 100644
--- a/misc/lxde-common/pkg-plist
+++ b/misc/lxde-common/pkg-plist
@@ -1,9 +1,13 @@
bin/lxde-logout
bin/openbox-lxde
bin/startlxde
-etc/xdg/pcmanfm/LXDE/pcmanfm.conf
etc/xdg/lxsession/LXDE/autostart
-etc/xdg/lxsession/LXDE/desktop.conf
+@unexec if cmp -s %D/etc/xdg/lxsession/LXDE/desktop.conf %D/etc/xdg/lxsession/LXDE/desktop.conf.sample; then rm -f %D/etc/xdg/lxsession/LXDE/desktop.conf; fi
+etc/xdg/lxsession/LXDE/desktop.conf.sample
+@exec if [ ! -f %D/etc/xdg/lxsession/LXDE/desktop.conf ] ; then cp -p %D/%F %B/desktop.conf; fi
+@unexec if cmp -s %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample; then rm -f %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf; fi
+etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
+@exec if [ ! -f %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf ] ; then cp -p %D/%F %B/pcmanfm.conf; fi
share/applications/lxde-logout.desktop
share/lxde/images/logout-banner.png
share/lxde/images/lxde-icon.png
@@ -15,11 +19,7 @@ share/lxde/wallpapers/lxde_red.jpg
share/lxpanel/profile/LXDE/config
share/lxpanel/profile/LXDE/panels/panel
share/xsessions/LXDE.desktop
-@dirrm etc/xdg/lxsession/LXDE
-@dirrm etc/xdg/lxsession
-@dirrmtry etc/xdg/pcmanfm/LXDE
-@dirrmtry etc/xdg/pcmanfm
-@dirrmtry share/applications
+@dirrmtry share/xsessions
@dirrmtry share/lxpanel/profile/LXDE/panels
@dirrmtry share/lxpanel/profile/LXDE
@dirrmtry share/lxpanel/profile
@@ -28,5 +28,8 @@ share/xsessions/LXDE.desktop
@dirrm share/lxde/openbox
@dirrm share/lxde/images
@dirrm share/lxde
-@dirrmtry share/xsessions
-@dirrmtry etc/xdg
+@dirrmtry share/applications
+@dirrmtry etc/xdg/pcmanfm/LXDE
+@dirrmtry etc/xdg/pcmanfm
+@dirrmtry etc/xdg/lxsession/LXDE
+@dirrmtry etc/xdg/lxsession