aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-08-27 23:48:59 +0800
committergarga <garga@FreeBSD.org>2009-08-27 23:48:59 +0800
commitc2b501e944c339d9ca42fbf9c072ffa6dd0ba5bf (patch)
treef36f575deba584cbfc93541972fc2ca6fabb8592 /misc
parenta93ab1343f0aaaa2b052de6c9ff4423355dd594a (diff)
downloadfreebsd-ports-gnome-c2b501e944c339d9ca42fbf9c072ffa6dd0ba5bf.tar.gz
freebsd-ports-gnome-c2b501e944c339d9ca42fbf9c072ffa6dd0ba5bf.tar.zst
freebsd-ports-gnome-c2b501e944c339d9ca42fbf9c072ffa6dd0ba5bf.zip
When installing on 8.x (>= 800105), don't install libpthread.so.2 but create a
symlink to /usr/lib/libpthr.so Discussed with: jhb Approved by: mnag (maintainer)
Diffstat (limited to 'misc')
-rw-r--r--misc/compat6x/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/misc/compat6x/Makefile b/misc/compat6x/Makefile
index e24051342eb7..0fa87e50c0d7 100644
--- a/misc/compat6x/Makefile
+++ b/misc/compat6x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= compat6x
PORTVERSION= 6.4.604000.200810
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~${MASTER_SITE_SUBDIR}/
@@ -38,9 +39,17 @@ USE_LDCONFIG32= ${TARGET32_DIR}
do-install:
@${MKDIR} ${TARGET_DIR}
+.if ${OSVERSION} >= 800105
+ ${RM} -f ${WRKSRC}/libpthread.so.2
+ (cd ${TARGET_DIR} && ${LN} -s /usr/lib/libpthr.so ./libpthread.so.2)
+.endif
(cd ${WRKSRC}/lib && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
.if ${ARCH} == amd64
@${MKDIR} ${TARGET32_DIR}
+. if ${OSVERSION} >= 800105
+ ${RM} -f ${WRKSRC}/lib32/libpthread.so.2
+ (cd ${TARGET32_DIR} && ${LN} -s /usr/lib32/libpthr.so ./libpthread.so.2)
+. endif
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif