aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-12-08 11:21:53 +0800
committerdanilo <danilo@FreeBSD.org>2013-12-08 11:21:53 +0800
commitc5a924a5ced0598f684c623fdb35f49947277083 (patch)
treea057e3b2d18da4351e6b6b947ad82422b872df6e /misc
parent1de69a40cfd3d94676f116491032b36c62297ef7 (diff)
downloadfreebsd-ports-gnome-c5a924a5ced0598f684c623fdb35f49947277083.tar.gz
freebsd-ports-gnome-c5a924a5ced0598f684c623fdb35f49947277083.tar.zst
freebsd-ports-gnome-c5a924a5ced0598f684c623fdb35f49947277083.zip
- Add stage support
Diffstat (limited to 'misc')
-rw-r--r--misc/whichman/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/misc/whichman/Makefile b/misc/whichman/Makefile
index 98a889141bb4..263c1b45cde0 100644
--- a/misc/whichman/Makefile
+++ b/misc/whichman/Makefile
@@ -12,17 +12,17 @@ COMMENT= Approximate matching utilities to search for manpages and files
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-MAN1= ftff.1 ftwhich.1 whichman.1
-PLIST_FILES= bin/ftff bin/ftwhich bin/whichman
+PLIST_FILES= bin/ftff bin/ftwhich bin/whichman \
+ man/man1/ftff.1.gz man/man1/ftwhich.1.gz \
+ man/man1/whichman.1.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/man:||g' ${WRKSRC}/whichman.c
do-install:
.for name in ftff ftwhich whichman
- ${INSTALL_PROGRAM} ${WRKSRC}/${name} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man1/${name}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${name} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man1/${name}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>