aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2016-02-16 07:49:11 +0800
committerdanilo <danilo@FreeBSD.org>2016-02-16 07:49:11 +0800
commitc8b4857d2f4849062b2a8cba71e0248897ec2b75 (patch)
treea9b51c545ceed41773f2584d60914772ff752a1f /misc
parentc7228425fd19d0774b929053da15694a68f64544 (diff)
downloadfreebsd-ports-gnome-c8b4857d2f4849062b2a8cba71e0248897ec2b75.tar.gz
freebsd-ports-gnome-c8b4857d2f4849062b2a8cba71e0248897ec2b75.tar.zst
freebsd-ports-gnome-c8b4857d2f4849062b2a8cba71e0248897ec2b75.zip
- Update to 3.0.11
- Address CVE-2014-9765 PR: 207174 Submitted by: junovitch MFH: 2016Q1
Diffstat (limited to 'misc')
-rw-r--r--misc/xdelta3/Makefile13
-rw-r--r--misc/xdelta3/distinfo4
-rw-r--r--misc/xdelta3/files/patch-testing_regtest.cc (renamed from misc/xdelta3/files/patch-testing-regtest.cc.patch)8
3 files changed, 16 insertions, 9 deletions
diff --git a/misc/xdelta3/Makefile b/misc/xdelta3/Makefile
index 3b6c2ee1250a..446f4b819f64 100644
--- a/misc/xdelta3/Makefile
+++ b/misc/xdelta3/Makefile
@@ -2,18 +2,25 @@
# $FreeBSD$
PORTNAME= xdelta
-PORTVERSION= 3.0.7
+PORTVERSION= 3.0.11
PORTEPOCH= 1
CATEGORIES?= misc devel
-MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= 3
-DISTNAME= ${PORTNAME}3-${PORTVERSION}
MAINTAINER= danilo@FreeBSD.org
COMMENT= Open-source binary diff, VCDIFF/RFC 3284 delta compression
LICENSE= GPLv2+
+USES= autoreconf gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= jmacd
+GH_PROJECT= xdelta-devel
+GH_TAGNAME= v3.0.11
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-devel-${PORTVERSION}/xdelta3
+
GNU_CONFIGURE= yes
PLIST_FILES= bin/xdelta3 man/man1/xdelta3.1.gz
diff --git a/misc/xdelta3/distinfo b/misc/xdelta3/distinfo
index 8ee67bc6a158..0d89d26bf218 100644
--- a/misc/xdelta3/distinfo
+++ b/misc/xdelta3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xdelta3-3.0.7.tar.gz) = 97e56a019be7f6c8d7e974dfe501fcf55d7ac97fe42165a172ed8c6b0e96f219
-SIZE (xdelta3-3.0.7.tar.gz) = 481371
+SHA256 (jmacd-xdelta-devel-3.0.11-v3.0.11_GH0.tar.gz) = 0cd1ab3e53be8e57bc6335789ead8a6177b0a3524c931e6af2aa801b2c1736cc
+SIZE (jmacd-xdelta-devel-3.0.11-v3.0.11_GH0.tar.gz) = 993860
diff --git a/misc/xdelta3/files/patch-testing-regtest.cc.patch b/misc/xdelta3/files/patch-testing_regtest.cc
index dcf04977352f..972bcd6b0d04 100644
--- a/misc/xdelta3/files/patch-testing-regtest.cc.patch
+++ b/misc/xdelta3/files/patch-testing_regtest.cc
@@ -1,9 +1,9 @@
---- ../../xdelta3-3.0.7/testing/regtest.cc 2013-05-13 04:54:35.000000000 +0000
-+++ testing/regtest.cc 2013-05-20 02:32:05.243969745 +0000
-@@ -761,7 +761,7 @@
+--- testing/regtest.cc.orig 2016-02-15 23:07:07 UTC
++++ testing/regtest.cc
+@@ -1006,7 +1006,7 @@ void FourWayMergeTest(const FileSpec &sp
ExtFile d01, d12, d23;
Options options;
- options.encode_srcwin_maxsz =
+ options.encode_srcwin_maxsz =
- std::max(spec0.Size(), options.encode_srcwin_maxsz);
+ std::max((unsigned long long)spec0.Size(), (unsigned long long)options.encode_srcwin_maxsz);