aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2008-06-22 04:24:18 +0800
committerru <ru@FreeBSD.org>2008-06-22 04:24:18 +0800
commitca09e5cee2413ee6803673e9a95c4fdefefae2cc (patch)
tree1ad8cf802a04d853a8e7c3761040bb6bbfa5c254 /misc
parentc7c9e41f25dcd8206f9719a2b6d93e796d870aee (diff)
downloadfreebsd-ports-gnome-ca09e5cee2413ee6803673e9a95c4fdefefae2cc.tar.gz
freebsd-ports-gnome-ca09e5cee2413ee6803673e9a95c4fdefefae2cc.tar.zst
freebsd-ports-gnome-ca09e5cee2413ee6803673e9a95c4fdefefae2cc.zip
Detect the presence of execvpe() on recent -CURRENT.
Diffstat (limited to 'misc')
-rw-r--r--misc/deco/Makefile2
-rw-r--r--misc/deco/files/patch-configure11
-rw-r--r--misc/deco/files/patch-run.c20
3 files changed, 29 insertions, 4 deletions
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index 420515ae44b8..281f039ffdeb 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -7,7 +7,7 @@
PORTNAME= deco
PORTVERSION= 3.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/misc/deco/files/patch-configure b/misc/deco/files/patch-configure
new file mode 100644
index 000000000000..0f669df9b739
--- /dev/null
+++ b/misc/deco/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure 1997-07-18 18:48:13.000000000 +0400
++++ configure 2008-06-22 00:21:13.000000000 +0400
+@@ -1994,7 +1994,7 @@
+
+ fi
+
+-for ac_func in gethostname getgroups opendir memcpy strtol dirfd tcgetattr tcsetpgrp killpg
++for ac_func in gethostname getgroups opendir memcpy strtol dirfd tcgetattr tcsetpgrp killpg execvpe
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
+ echo "configure:2001: checking for $ac_func" >&5
diff --git a/misc/deco/files/patch-run.c b/misc/deco/files/patch-run.c
index 0f2fcd6a7360..ecebd04a9e35 100644
--- a/misc/deco/files/patch-run.c
+++ b/misc/deco/files/patch-run.c
@@ -1,6 +1,20 @@
---- run.c Wed Mar 7 19:37:47 2001
-+++ run.c Sun Dec 5 22:51:12 2004
-@@ -136,10 +136,22 @@
+--- run.c 2001-03-07 20:37:47.000000000 +0300
++++ run.c 2008-06-22 00:17:05.000000000 +0400
+@@ -77,6 +77,7 @@
+ return (*s1 ? ++s1 : 0);
+ }
+
++#if !HAVE_EXECVPE
+ static int execvpe (char *name, char **argv, char **envstr)
+ {
+ static char *pathstr;
+@@ -131,15 +132,28 @@
+ errno = EACCES;
+ return (-1);
+ }
++#endif
+
+ int runl (int silent, char *name, ...)
{
va_list ap;
int err;