aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-13 22:27:41 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-13 22:27:41 +0800
commitcb1ad7ce572f08280fc167ab3bafd656720ebf50 (patch)
treecc1abfbe025f5884f407f0bdeb7de37e9227c89a /misc
parent99ec04edc241b8e33a81f96a44515e60efb078ae (diff)
downloadfreebsd-ports-gnome-cb1ad7ce572f08280fc167ab3bafd656720ebf50.tar.gz
freebsd-ports-gnome-cb1ad7ce572f08280fc167ab3bafd656720ebf50.tar.zst
freebsd-ports-gnome-cb1ad7ce572f08280fc167ab3bafd656720ebf50.zip
Support staging
Diffstat (limited to 'misc')
-rw-r--r--misc/viz/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/misc/viz/Makefile b/misc/viz/Makefile
index 90da393a26bb..0f549e161c90 100644
--- a/misc/viz/Makefile
+++ b/misc/viz/Makefile
@@ -4,7 +4,7 @@
PORTNAME= viz
PORTVERSION= 1.1.1
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR= fenner
EXTRACT_SUFX= .tgz
@@ -13,12 +13,12 @@ COMMENT= Convert invisible (binary) characters to a visible form
MAKE_ARGS= CC="${CC}" DEFS="${CFLAGS}"
-MAN1= viz.1 inviz.1
-PLIST_FILES= bin/viz bin/inviz
+PLIST_FILES= bin/viz bin/inviz man/man1/viz.1.gz man/man1/inviz.1.gz
-NO_STAGE= yes
do-install:
- cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PLIST_FILES:T} ${PREFIX}/bin/
- cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1/
+.for f in viz inviz
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.endfor
.include <bsd.port.mk>