aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-01-31 18:46:10 +0800
committerGerald Pfeifer <gerald@FreeBSD.org>2021-01-31 18:46:10 +0800
commitce7d119555ebdb4769dc22077a5623bf45d02f18 (patch)
treefbb39bd72c027f2932b5da832cbfb1511149d3e2 /misc
parent1c3e1df0f51c0b4d96c485fbd4742439a45a475d (diff)
downloadfreebsd-ports-gnome-ce7d119555ebdb4769dc22077a5623bf45d02f18.tar.gz
freebsd-ports-gnome-ce7d119555ebdb4769dc22077a5623bf45d02f18.tar.zst
freebsd-ports-gnome-ce7d119555ebdb4769dc22077a5623bf45d02f18.zip
Convert misc/seabios to use the new "build" argument to USE_GCC,
replacing direct manipulation of RUN_DEPENDS by the much more declarative and simpler USE_GCC=yes:build. PR: 211154
Diffstat (limited to 'misc')
-rw-r--r--misc/seabios/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/misc/seabios/Makefile b/misc/seabios/Makefile
index 6367dfbd6d1f..d1e215218cd0 100644
--- a/misc/seabios/Makefile
+++ b/misc/seabios/Makefile
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS_REASON= specific to x86
USES= gmake python:build
MAKE_ARGS= HOSTCC="${CC}" LD="${LD}" PYTHON="${PYTHON_CMD}"
-USE_GCC= yes
+USE_GCC= yes:build
USE_BINUTILS= yes
PLIST_FILES= ${DATADIR}/bios.bin
@@ -27,4 +27,3 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/out/bios.bin ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
-RUN_DEPENDS:= ${RUN_DEPENDS:Ngcc*}