aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-04-17 08:19:02 +0800
committerreg <reg@FreeBSD.org>2000-04-17 08:19:02 +0800
commitd22cbcc0186bfcde72d3058c3d06d1032bb7157e (patch)
treeefb5227e2fc359da16edf2ca8a5ca4744a25bc3e /misc
parent8b766534122d71052c9f8e5a0752944edf0450f8 (diff)
downloadfreebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.tar.gz
freebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.tar.zst
freebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.zip
Standardize all user defined options to the booleans WITH_FOO and
WITHOUT_FOO. Begin the process of reserving these prefixes for user defined options. No comment by: ports
Diffstat (limited to 'misc')
-rw-r--r--misc/gone/Makefile8
-rw-r--r--misc/mc/Makefile2
2 files changed, 5 insertions, 5 deletions
diff --git a/misc/gone/Makefile b/misc/gone/Makefile
index 254c518c74c9..4eb6e6537497 100644
--- a/misc/gone/Makefile
+++ b/misc/gone/Makefile
@@ -20,10 +20,10 @@ GNU_CONFIGURE= yes
# override this with WITH_SETUID=yes in your environment.
# Be aware that setting gone to suid MAY be a security hole.
#
-WITH_SETUID?= no
-.if ${WITH_SETUID} == yes
-CONFIGURE_ENV= with_setuid=yes
+.if defined(WITH_SETUID)
+CONFIGURE_ENV= with_setuid=yes
.else
-CONFIGURE_ENV= with_setuid=no
+CONFIGURE_ENV= with_setuid=no
.endif
+
.include <bsd.port.mk>
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index d9e4a35b272b..659a59bf3953 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= reg@FreeBSD.org
LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12 \
intl.1:${PORTSDIR}/devel/gettext
-.if defined(USE_NCURSES_PORT)
+.if defined(WITH_NCURSES_PORT)
LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
.elif defined(WITH_SLANG)
LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang