aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2005-09-17 00:30:21 +0800
committerCy Schubert <cy@FreeBSD.org>2005-09-17 00:30:21 +0800
commitd5d85a487ff8137e2775d51bbd30f46e434720b3 (patch)
treeac79c52ac0e30eb737b43003fa39264beeb0c2df /misc
parentc274106b6f67bdc80bed42f26033309036ae6990 (diff)
downloadfreebsd-ports-gnome-d5d85a487ff8137e2775d51bbd30f46e434720b3.tar.gz
freebsd-ports-gnome-d5d85a487ff8137e2775d51bbd30f46e434720b3.tar.zst
freebsd-ports-gnome-d5d85a487ff8137e2775d51bbd30f46e434720b3.zip
Add support for 256 colour Xterm.
PR: 81285 Submitted by: Jeremy Chadwick <freebsd@jdc.parodius.com>
Diffstat (limited to 'misc')
-rw-r--r--misc/screen/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/misc/screen/Makefile b/misc/screen/Makefile
index e41d43849771..64db128c44a2 100644
--- a/misc/screen/Makefile
+++ b/misc/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
@@ -28,6 +28,14 @@ NO_PACKAGE= Tends to loop using 100% CPU when used from package - perhaps it har
CFLAGS+= -O0
.endif
+# Enables support for 256 colour xterm. Note that you may need to
+# set up a custom termcap entry or .screenrc which modifies termcap
+# to contain the following: Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm
+#
+.if defined(WITH_XTERM_256)
+CFLAGS+= -DCOLORS256
+.endif
+
.if defined(WITHOUT_NETHACK)
CFLAGS+= -DNONETHACK
.endif