aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-05-20 20:20:53 +0800
committerculot <culot@FreeBSD.org>2011-05-20 20:20:53 +0800
commitd692e81281a63df92972ad55824ae8296475bc88 (patch)
tree3672a50d22ddb66706281e13583a602b06052dc2 /misc
parent38d6f1065dffd400add5c75d458f2787188ea0fc (diff)
downloadfreebsd-ports-gnome-d692e81281a63df92972ad55824ae8296475bc88.tar.gz
freebsd-ports-gnome-d692e81281a63df92972ad55824ae8296475bc88.tar.zst
freebsd-ports-gnome-d692e81281a63df92972ad55824ae8296475bc88.zip
- Add a patch to fix usage of su(1) in the gupdatedb script provided
with findutils - Bump PORTREVISION PR: ports/157129 Submitted by: Klaus Aehlig <aehlig@linta.de> (maintainer)
Diffstat (limited to 'misc')
-rw-r--r--misc/findutils/Makefile1
-rw-r--r--misc/findutils/files/patch-locate__updatedb.sh38
2 files changed, 39 insertions, 0 deletions
diff --git a/misc/findutils/Makefile b/misc/findutils/Makefile
index 1d868b4aa24f..295051cf989e 100644
--- a/misc/findutils/Makefile
+++ b/misc/findutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= findutils
PORTVERSION= 4.5.10
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
MASTER_SITE_SUBDIR= findutils
diff --git a/misc/findutils/files/patch-locate__updatedb.sh b/misc/findutils/files/patch-locate__updatedb.sh
new file mode 100644
index 000000000000..4795680cbf4e
--- /dev/null
+++ b/misc/findutils/files/patch-locate__updatedb.sh
@@ -0,0 +1,38 @@
+--- locate/updatedb.sh.orig 2011-04-03 23:53:12.000000000 +0100
++++ locate/updatedb.sh 2011-05-17 18:20:29.000000000 +0100
+@@ -250,7 +250,7 @@
+ if test -n "$SEARCHPATHS"; then
+ if [ "$LOCALUSER" != "" ]; then
+ # : A1
+- su $LOCALUSER `select_shell $LOCALUSER` -c \
++ su -m $LOCALUSER -c \
+ "$find $SEARCHPATHS $FINDOPTIONS \
+ \\( $prunefs_exp \
+ -type d -regex '$PRUNEREGEX' \\) -prune -o $print_option"
+@@ -266,7 +266,7 @@
+ myuid=`getuid`
+ if [ "$myuid" = 0 ]; then
+ # : A3
+- su $NETUSER `select_shell $NETUSER` -c \
++ su -m $NETUSER -c \
+ "$find $NETPATHS $FINDOPTIONS \\( -type d -regex '$PRUNEREGEX' -prune \\) -o $print_option" ||
+ exit $?
+ else
+@@ -319,7 +319,7 @@
+ if test -n "$SEARCHPATHS"; then
+ if [ "$LOCALUSER" != "" ]; then
+ # : A5
+- su $LOCALUSER `select_shell $LOCALUSER` -c \
++ su -m $LOCALUSER -c \
+ "$find $SEARCHPATHS $FINDOPTIONS \
+ \( $prunefs_exp \
+ -type d -regex '$PRUNEREGEX' \) -prune -o $print_option" || exit $?
+@@ -335,7 +335,7 @@
+ myuid=`getuid`
+ if [ "$myuid" = 0 ]; then
+ # : A7
+- su $NETUSER `select_shell $NETUSER` -c \
++ su -m $NETUSER -c \
+ "$find $NETPATHS $FINDOPTIONS \\( -type d -regex '$PRUNEREGEX' -prune \\) -o $print_option" ||
+ exit $?
+ else