aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2008-08-04 13:32:59 +0800
committerdougb <dougb@FreeBSD.org>2008-08-04 13:32:59 +0800
commitdc13ba0b3768da609454c5380dde88c6e647b9f2 (patch)
tree36a43d8eea1401f3f18b2372b7a9e2c39b94e027 /misc
parenta0ef5e129541c9ba84cc3ef9c0082c0dfca0f051 (diff)
downloadfreebsd-ports-gnome-dc13ba0b3768da609454c5380dde88c6e647b9f2.tar.gz
freebsd-ports-gnome-dc13ba0b3768da609454c5380dde88c6e647b9f2.tar.zst
freebsd-ports-gnome-dc13ba0b3768da609454c5380dde88c6e647b9f2.zip
Upgrade to version 2.11 which mostly consists of changing from
libwww to curl. For the port: 1. Switch to the SF macro 2. Update COMMENT 3. Switch to using PLIST_FILES 4. Merge the functionality from files/patch-wmweather+.c to the Makefile 5. Make everything related to the conf example conditional on NOPORTEXAMPLES 6. Display the new pkg-message file after installation of the port 7. Take over maintainership with the approval of the current maintainer who reports ENOTIME. Thank you Willie for your work on this port. :)
Diffstat (limited to 'misc')
-rw-r--r--misc/wmweather+/Makefile53
-rw-r--r--misc/wmweather+/distinfo6
2 files changed, 37 insertions, 22 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index c9a5c83523c4..c2321e204ad1 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -4,17 +4,16 @@
#
# $FreeBSD$
-PORTNAME= wmweather+
-PORTVERSION= 2.9
-PORTREVISION= 5
-CATEGORIES= misc windowmaker geography
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= wmweather+
+PORTVERSION= 2.11
+CATEGORIES= misc windowmaker geography
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= wmweatherplus
-MAINTAINER= harald.wille@students.jku.at
-COMMENT= Think wmweather with forecasts, weather map, and a sky cond. display
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Displays current conditions and forecasts with icons and text
-LIB_DEPENDS= xmlparse:${PORTSDIR}/www/libwww \
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
wraster:${PORTSDIR}/x11-wm/windowmaker \
pcre:${PORTSDIR}/devel/pcre \
tiff:${PORTSDIR}/graphics/tiff \
@@ -31,22 +30,38 @@ CONFIGURE_ARGS+= --with-libwraster=${LOCALBASE}
MAN1= wmweather+.1
+PLIST_FILES= bin/wmweather+
+
+post-patch:
+ @${CP} ${WRKSRC}/wmweather+.c ${WRKSRC}/wmweather+.c.dist
+ @${SED} -e "s#^void usage(int i) __THROW.*#void usage(int i);#" \
+ ${WRKSRC}/wmweather+.c.dist > ${WRKSRC}/wmweather+.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmweather+ ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmweather+.1 ${PREFIX}/man/man1
-
-post-install:
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/HINTS ${EXAMPLESDIR}/HINTS
${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}/example.conf
+PLIST_FILES+= ${EXAMPLESDIR_REL}/HINTS
+PLIST_FILES+= ${EXAMPLESDIR_REL}/example.conf
+PLIST_DIRS+= ${EXAMPLESDIR_REL}
+PM= ${WRKDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+.endif
+
- @${ECHO} ""
- @${ECHO} "================================================="
- @${ECHO} "Sample configuration file has been copied to"
- @${ECHO} "${EXAMPLESDIR}/example.conf"
- @${ECHO} ""
- @${ECHO} "Please copy it to your homedir into .wmweather+"
- @${ECHO} "as conf and adjust it to your needs!"
- @${ECHO} "================================================="
- @${ECHO} ""
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO} "===================================================" > ${PM}
+ @${ECHO} "A sample configuration file has been copied to" >> ${PM}
+ @${ECHO} "${EXAMPLESDIR}/example.conf" >> ${PM}
+ @${ECHO} "" >> ${PM}
+ @${ECHO} "Please copy it to ~/.wmweather+/conf and adjust it" >> ${PM}
+ @${ECHO} "to your needs!" >> ${PM}
+ @${ECHO} "===================================================" >> ${PM}
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>
diff --git a/misc/wmweather+/distinfo b/misc/wmweather+/distinfo
index 46e146b400e8..b536fefbb4f8 100644
--- a/misc/wmweather+/distinfo
+++ b/misc/wmweather+/distinfo
@@ -1,3 +1,3 @@
-MD5 (wmweather+-2.9.tar.gz) = ede58d7ed589d5c41b9b68a2703a8f7d
-SHA256 (wmweather+-2.9.tar.gz) = f53d3242cc8ff00e880829ef32a6cc2da49b6e1d3b5e97ba2e64703b9b89e9a3
-SIZE (wmweather+-2.9.tar.gz) = 292955
+MD5 (wmweather+-2.11.tar.gz) = 6b199330fa40d11ab2a1652b961e0ea0
+SHA256 (wmweather+-2.11.tar.gz) = bab0d2d2cac65db51bb25f70b028ee7c55642119d2b38441aff65553a35566f9
+SIZE (wmweather+-2.11.tar.gz) = 193596