aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2017-06-07 23:43:29 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2017-06-07 23:43:29 +0800
commite1957c6dfb90beeb0229f17fafd2df0c71f8871f (patch)
tree889a7446cef96762c763b8a3b4ab31f8d5786559 /misc
parentd0c67d045a5a17ec41600f6c52c94c33d7355489 (diff)
downloadfreebsd-ports-gnome-e1957c6dfb90beeb0229f17fafd2df0c71f8871f.tar.gz
freebsd-ports-gnome-e1957c6dfb90beeb0229f17fafd2df0c71f8871f.tar.zst
freebsd-ports-gnome-e1957c6dfb90beeb0229f17fafd2df0c71f8871f.zip
[NEW] misc/py3-pexpect: Create Python 3.x version of port
The latest www/py-requests update [1] unbundled its dependencies, now requiring chardet, idna, urllib3 and certifi from ports. www/py3-requests port was not tested during QA, which would have highlighted the need for many new py3-* ports (and their dependencies). This change creates one of those ports. [1] https://svnweb.freebsd.org/changeset/ports/442565 PR: 219833
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-pexpect/Makefile4
-rw-r--r--misc/py3-pexpect/Makefile10
3 files changed, 13 insertions, 2 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dbf8e9b78ca3..b097b314bbb9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -393,6 +393,7 @@
SUBDIR += py-spdx-lookup
SUBDIR += py-tqdm
SUBDIR += py-yolk
+ SUBDIR += py3-pexpect
SUBDIR += py3-tqdm
SUBDIR += pylize
SUBDIR += qbrew
diff --git a/misc/py-pexpect/Makefile b/misc/py-pexpect/Makefile
index cda82728b1f1..6f3d8afcd7d3 100644
--- a/misc/py-pexpect/Makefile
+++ b/misc/py-pexpect/Makefile
@@ -12,9 +12,9 @@ COMMENT= Pure Python Expect-like module
LICENSE= ISCL
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0:sysutils/py-ptyprocess
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0:sysutils/py-ptyprocess
-USES= python
+USES?= python
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/misc/py3-pexpect/Makefile b/misc/py3-pexpect/Makefile
new file mode 100644
index 000000000000..6f4766942605
--- /dev/null
+++ b/misc/py3-pexpect/Makefile
@@ -0,0 +1,10 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-pexpect
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>=0:sysutils/py3-ptyprocess
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"