aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsanpei <sanpei@FreeBSD.org>2009-07-15 23:01:15 +0800
committersanpei <sanpei@FreeBSD.org>2009-07-15 23:01:15 +0800
commite6d98459352c799ec777b0de3a1a8e0fbea091b9 (patch)
tree4493b15cc8638551c10dd29e68f39982ed4e7c08 /misc
parentd4de3e44be21be236b87da31d5b318ff096fa67c (diff)
downloadfreebsd-ports-gnome-e6d98459352c799ec777b0de3a1a8e0fbea091b9.tar.gz
freebsd-ports-gnome-e6d98459352c799ec777b0de3a1a8e0fbea091b9.tar.zst
freebsd-ports-gnome-e6d98459352c799ec777b0de3a1a8e0fbea091b9.zip
THANKO USB AM/FM Radio controller
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/amfm/Makefile37
-rw-r--r--misc/amfm/distinfo3
-rw-r--r--misc/amfm/files/patch-Makefile11
-rw-r--r--misc/amfm/files/patch-amfm.c19
-rw-r--r--misc/amfm/pkg-descr14
-rw-r--r--misc/amfm/pkg-plist1
7 files changed, 86 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 9e8440ae01ea..644556616386 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -12,6 +12,7 @@
SUBDIR += amanda-server
SUBDIR += amanda25-client
SUBDIR += amanda25-server
+ SUBDIR += amfm
SUBDIR += apparix
SUBDIR += asbutton
SUBDIR += asr-manpages
diff --git a/misc/amfm/Makefile b/misc/amfm/Makefile
new file mode 100644
index 000000000000..3c2881e7e701
--- /dev/null
+++ b/misc/amfm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: amfm
+# Date created: 2009-06-21
+# Whom: sanpei@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= amfm
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://github.com/ikegam/amfm/raw/9679aa06eead7ed3571480e892f426828e17e361/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= sanpei
+DISTNAME= amfm
+EXTRACT_SUFX= .c
+
+MAINTAINER= sanpei@FreeBSD.org
+COMMENT= THANKO USB AM/FM Radio controller
+
+LIB_DEPENDS= hid.0:${PORTSDIR}/devel/libhid
+
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.pre.mk>
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+
+.if ${OSVERSION} <= 800097
+BROKEN= does not build
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/amfm ${PREFIX}/bin/amfm
+
+.include <bsd.port.post.mk>
diff --git a/misc/amfm/distinfo b/misc/amfm/distinfo
new file mode 100644
index 000000000000..b81cc38d20c1
--- /dev/null
+++ b/misc/amfm/distinfo
@@ -0,0 +1,3 @@
+MD5 (amfm.c) = 63d61864c30f6899254a72adccac8c03
+SHA256 (amfm.c) = 0dd12ba64466a7c82f7af546c856cc0e1fd65c1a70397dd7c61a2c2d266b762b
+SIZE (amfm.c) = 2590
diff --git a/misc/amfm/files/patch-Makefile b/misc/amfm/files/patch-Makefile
new file mode 100644
index 000000000000..a0ab3151daf8
--- /dev/null
+++ b/misc/amfm/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- ./Makefile.orig 2009-06-28 14:24:15.000000000 +0900
++++ ./Makefile 2009-06-28 14:26:05.000000000 +0900
+@@ -0,0 +1,8 @@
++CFLAGS=-I${PREFIX}/include -L${PREFIX}/lib -lhid
++TARGET=amfm
++SRC=amfm.c
++
++all: ${TARGET}
++
++${TARGET}: ${SRC}
++ cc -o amfm ${CFLAGS} amfm.c
diff --git a/misc/amfm/files/patch-amfm.c b/misc/amfm/files/patch-amfm.c
new file mode 100644
index 000000000000..75483ad5bd8f
--- /dev/null
+++ b/misc/amfm/files/patch-amfm.c
@@ -0,0 +1,19 @@
+--- ./amfm.c.orig 2009-06-28 13:47:21.000000000 +0900
++++ ./amfm.c 2009-06-28 14:24:15.000000000 +0900
+@@ -12,6 +12,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <hid.h>
+
+@@ -28,7 +29,7 @@
+ HIDInterface* hid;
+ HIDInterfaceMatcher matcher = { RADIO_VENDID, RADIO_DEVID, NULL, NULL, 0 };
+
+- unsigned char PACKET[SEND_PACKET_LENGTH] = { 0x28, 0xe2, 0x06, 0x03, 0x29, 0x52, 0x00, 0x10 };
++ unsigned char PACKET[SEND_PACKET_LENGTH] = { 0x28, 0xe2, 0x06, 0x03, 0x29, 0xd2, 0x00, 0x10 };
+ unsigned char ZERO[0];
+ unsigned short encodedFreq;
+ unsigned int freq;
diff --git a/misc/amfm/pkg-descr b/misc/amfm/pkg-descr
new file mode 100644
index 000000000000..d626841eb77a
--- /dev/null
+++ b/misc/amfm/pkg-descr
@@ -0,0 +1,14 @@
+THANKO USB AM/FM Radio controller
+
+commands usage:
+ -fm <freqeuncy> : set FM frequency, e.g. '-fm 77.4'
+ -stop : stop amfm radio
+
+Limitations:
+ you need root authority.
+ currently AM Radio mode is not supported.
+
+THANKO Co. USB AM/FM RADIO
+WWW: http://www.thanko.jp/usbamfmradio/
+
+WWW: http://d.hatena.ne.jp/pair/20080620/1213969553#c
diff --git a/misc/amfm/pkg-plist b/misc/amfm/pkg-plist
new file mode 100644
index 000000000000..d223c3267af2
--- /dev/null
+++ b/misc/amfm/pkg-plist
@@ -0,0 +1 @@
+bin/amfm