aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-09-03 13:00:32 +0800
committerdinoex <dinoex@FreeBSD.org>2013-09-03 13:00:32 +0800
commitf0ce14b31f1feae1fbe0f8354dfae3db067a6190 (patch)
treec5183529cbd52b0d0faab4943e4caa6b90207378 /misc
parentf5bc72cbcc42fa799216f72977929a46589b4568 (diff)
downloadfreebsd-ports-gnome-f0ce14b31f1feae1fbe0f8354dfae3db067a6190.tar.gz
freebsd-ports-gnome-f0ce14b31f1feae1fbe0f8354dfae3db067a6190.tar.zst
freebsd-ports-gnome-f0ce14b31f1feae1fbe0f8354dfae3db067a6190.zip
- fix segfault on 64bit with option XFT
Diffstat (limited to 'misc')
-rw-r--r--misc/magicpoint/Makefile2
-rw-r--r--misc/magicpoint/files/patch-draw.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 2f72854ccfbf..d401653f18f3 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
diff --git a/misc/magicpoint/files/patch-draw.c b/misc/magicpoint/files/patch-draw.c
new file mode 100644
index 000000000000..c2e711a07490
--- /dev/null
+++ b/misc/magicpoint/files/patch-draw.c
@@ -0,0 +1,17 @@
+--- draw.c.orig 2008-01-24 16:43:17.000000000 +0100
++++ draw.c 2013-09-03 06:48:44.000000000 +0200
+@@ -5471,12 +5471,12 @@
+ XFT_FAMILY, XftTypeString, font,
+ XFT_ENCODING, XftTypeString, registry,
+ XFT_STYLE, XftTypeString, style,
+- XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, 0);
++ XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, NULL);
+ } else {
+ xftfont = XftFontOpen(display, screen,
+ XFT_FAMILY, XftTypeString, font,
+ XFT_ENCODING, XftTypeString, registry,
+- XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, 0);
++ XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, NULL);
+ }
+ if (xftfont == 0) {
+ free(xfont);