aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2011-10-06 21:43:24 +0800
committerfjoe <fjoe@FreeBSD.org>2011-10-06 21:43:24 +0800
commitfb329c7c4fd784b8f1f51a04f737b5a0e740bcf0 (patch)
treed10c6ff478ec82090d11038947b541eeb352cd9c /misc
parent5720e46f715af9573f397dcc08b5d6cb6daef52b (diff)
downloadfreebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.tar.gz
freebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.tar.zst
freebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.zip
Update to 4.7.5.5
PR: 161083 (partially) Submitted by: Maxim Samsonov
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile7
-rw-r--r--misc/mc/distinfo4
-rw-r--r--misc/mc/files/patch-src-editor-edit.c38
-rw-r--r--misc/mc/files/patch-without-nls25
-rw-r--r--misc/mc/pkg-plist14
5 files changed, 17 insertions, 71 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 24245cf37ef7..35184f7a3050 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= mc
-PORTVERSION= 4.7.5
-PORTREVISION= 1
+PORTVERSION= 4.7.5.5
+PORTREVISION= 0
CATEGORIES= misc shells
MASTER_SITES= http://www.midnight-commander.org/downloads/ \
${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/file/managers/mc
-EXTRACT_SUFX= .tar.lzma
PATCH_SITES= ${MASTER_SITES}
@@ -29,7 +28,7 @@ USE_PERL5= yes
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${LOCALBASE}/bin/zip UNZIP=${LOCALBASE}/bin/unzip
-USE_AUTOTOOLS= autoconf automake
+USE_AUTOTOOLS= libtool
OPTIONS= SLANG "Build with SLang library" on \
ICONV "Build with iconv recoding" on \
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index c04b5ce3915b..e6f30ff758b9 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mc-4.7.5.tar.lzma) = 5e5893e9484e4854a29fa422834e79c9ef007c1672136331ef28bdddbfc1c457
-SIZE (mc-4.7.5.tar.lzma) = 1922463
+SHA256 (mc-4.7.5.5.tar.xz) = 1ec5e711e7de01d9317a444061ab0d3c91bb84d8898dbbc99c7c472d6afbe2ea
+SIZE (mc-4.7.5.5.tar.xz) = 1991540
diff --git a/misc/mc/files/patch-src-editor-edit.c b/misc/mc/files/patch-src-editor-edit.c
deleted file mode 100644
index c2e4eb7b748f..000000000000
--- a/misc/mc/files/patch-src-editor-edit.c
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: src/editor/edit.c
-===================================================================
---- src/editor/edit.c (revision bd3025e7a9ec490bc6adabc34cd0392e93ecd050)
-+++ src/editor/edit.c (revision 4f4876abb4acb812747d1050c4b3be01da87780a)
-@@ -2840,8 +2840,5 @@
- {
- int c, orig_c;
-- int utf_ch = 0;
--#ifdef HAVE_CHARSET
-- int cw = 1;
--#endif
-+
- if (cols != -10)
- {
-@@ -2851,8 +2848,13 @@
- return p - 1;
- }
-+
- orig_c = c = edit_get_byte (edit, p);
-+
- #ifdef HAVE_CHARSET
- if (edit->utf8)
- {
-+ int utf_ch;
-+ int cw = 1;
-+
- utf_ch = edit_get_utf (edit, p, &cw);
- if (utf8_display)
-@@ -2866,6 +2868,8 @@
- col -= cw - 1;
- }
-+
-+ c = convert_to_display_c (c);
- #endif
-- c = convert_to_display_c (c);
-+
- if (c == '\t')
- col += TAB_SIZE - col % TAB_SIZE;
diff --git a/misc/mc/files/patch-without-nls b/misc/mc/files/patch-without-nls
deleted file mode 100644
index 4e37f9b1ea2e..000000000000
--- a/misc/mc/files/patch-without-nls
+++ /dev/null
@@ -1,25 +0,0 @@
---- doc/hints/Makefile.am.orig 2011-03-22 00:02:49.000000000 +0600
-+++ doc/hints/Makefile.am 2011-03-22 00:03:11.000000000 +0600
-@@ -1,7 +1,11 @@
- HINTFILES = \
-- mc.hint mc.hint.cs mc.hint.es mc.hint.hu mc.hint.it \
-+ mc.hint
-+if USE_NLS
-+HINTFILES += \
-+ mc.hint.cs mc.hint.es mc.hint.hu mc.hint.it \
- mc.hint.nl mc.hint.pl mc.hint.ru mc.hint.sr mc.hint.uk \
- mc.hint.zh
-+endif
-
- hintdir = $(pkgdatadir)/hints
- hint_DATA = $(HINTFILES)
---- configure.ac.orig 2011-03-21 23:58:52.000000000 +0600
-+++ configure.ac 2011-03-22 00:01:04.000000000 +0600
-@@ -504,6 +504,7 @@
- AM_CONDITIONAL(USE_SCREEN_SLANG, [test x"$with_screen" = xslang])
- AM_CONDITIONAL(USE_EDIT, [test -n "$use_edit"])
- AM_CONDITIONAL(USE_DIFF, [test -n "$use_diff"])
-+AM_CONDITIONAL(USE_NLS, [test x"$USE_NLS" = xyes])
- AM_CONDITIONAL(CHARSET, [test -n "$have_charset"])
- AM_CONDITIONAL(CONS_SAVER, [test -n "$cons_saver"])
-
diff --git a/misc/mc/pkg-plist b/misc/mc/pkg-plist
index 4650f8d1194b..88475610467b 100644
--- a/misc/mc/pkg-plist
+++ b/misc/mc/pkg-plist
@@ -72,6 +72,7 @@ libexec/mc/mc.sh
%%NLS%%share/locale/da/LC_MESSAGES/mc.mo
%%NLS%%share/locale/de/LC_MESSAGES/mc.mo
%%NLS%%share/locale/el/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/mc.mo
%%NLS%%share/locale/es/LC_MESSAGES/mc.mo
%%NLS%%share/locale/eu/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fi/LC_MESSAGES/mc.mo
@@ -79,8 +80,10 @@ libexec/mc/mc.sh
%%NLS%%share/locale/fr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mc.mo
%%NLS%%share/locale/hu/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/ia/LC_MESSAGES/mc.mo
%%NLS%%share/locale/id/LC_MESSAGES/mc.mo
%%NLS%%share/locale/it/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ja/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ka/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ko/LC_MESSAGES/mc.mo
@@ -98,6 +101,7 @@ libexec/mc/mc.sh
%%NLS%%share/locale/sl/LC_MESSAGES/mc.mo
%%NLS%%share/locale/sr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ta/LC_MESSAGES/mc.mo
%%NLS%%share/locale/tr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/uk/LC_MESSAGES/mc.mo
@@ -125,11 +129,13 @@ libexec/mc/mc.sh
%%NLS%%%%DATADIR%%/hints/mc.hint.zh
%%CHARSETS%%%%DATADIR%%/mc.charsets
%%DATADIR%%/mc.lib
+%%DATADIR%%/skins/dark.ini
%%DATADIR%%/skins/darkfar.ini
%%DATADIR%%/skins/default.ini
%%DATADIR%%/skins/double-lines.ini
%%DATADIR%%/skins/featured.ini
%%DATADIR%%/skins/gotar.ini
+%%DATADIR%%/skins/mc46.ini
%%DATADIR%%/skins/nicedark.ini
%%EDITOR%%%%DATADIR%%/syntax/PKGBUILD.syntax
%%EDITOR%%%%DATADIR%%/syntax/Syntax
@@ -207,8 +213,12 @@ libexec/mc/mc.sh
@dirrm %%DATADIR%%/hints
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%
-%%NLS%%@dirrm share/locale/fi_FI/LC_MESSAGES
-%%NLS%%@dirrm share/locale/fi_FI
+%%NLS%%@dirrmtry share/locale/sv_SE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sv_SE
+%%NLS%%@dirrmtry share/locale/it_IT/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it_IT
+%%NLS%%@dirrmtry share/locale/fi_FI/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi_FI
@dirrm libexec/mc/fish
@dirrm libexec/mc/extfs.d
@dirrm libexec/mc
it.cgi/freebsd-ports-gnome/commit/x11-drivers?id=438830816865a8b85320e16e31f32e5b3d0bb4ca'>Update to 6.14.3eadler2012-01-132-3/+3 * Both of these ports have been BROKEN for nearly a year; it is time to get rid...eadler2012-01-089-66/+0 * - These two ports will soon be deleted so remove them from the meta port.eadler2012-01-081-2/+0 * - Connect xf86-video-intel29 to the buildpav2011-11-181-0/+1 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-0949-49/+0 * - Fix build on FreeBSD 10.0miwi2011-10-2949-5/+49 * Remove more tags from pkg-descr files fo the form:dougb2011-10-243-9/+0 * - Return my ports back to the pool. I was unable to make any fixes tostas2011-10-241-1/+1 * Update to 6.14.2.kwm2011-07-193-46/+3 * Add a patch to UMS supportkwm2011-03-272-0/+43 * - Update to 6.14.1miwi2011-03-254-59/+3 * - Get Rid MD5 supportmiwi2011-03-1933-34/+0 * Remove patch that is causing trouble for users of specific ATI cards.kwm2011-03-092-12/+1 * Replace a custom ARCH check in Mk/bsd.xorg.mk for xf86-video-sunffb withkwm2011-03-012-1/+1 * - Restore BROKEN does not buildmiwi2011-02-284-0/+8 * - Fix fetchmiwi2011-02-272-1/+1 * Update distinfo to unbreak build.kwm2011-02-261-3/+2 * - Add some missing patchesmiwi2011-02-263-0/+67 * - Connect xf86-video-ati613 to the buildmiwi2011-02-261-0/+1 * - Bump PORTREVISION after xorg updatemiwi2011-02-261-7/+2 * - Bump PORTREVISION after xorg updatemiwi2011-02-261-1/+0 * - Please welcome Xorg 7.5.1miwi2011-02-26130-580/+202 * Update from 11.0.1 to 11.0.3 as the former crashes under the modern Xorgmi2011-01-072-4/+3 * - Update to 6.13.2pgollucci2010-12-284-8/+8 * Sync to new bsd.autotools.mkade2010-12-042-2/+2 * Punt autoconf267->autoconf268ade2010-10-161-1/+1 * Round one migration of ports from automake{19,110} to automake111ade2010-10-061-2/+2 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-161-2/+2 * Update to 11.0.1.jsa2010-08-133-4/+6 * Update to 12.6.9.jsa2010-08-132-4/+5 * - Mark BROKEN on 6.X: does not compilepav2010-07-241-0/+4 * - Unbreak with Xorg 1.7Xmiwi2010-07-103-24/+412 * Update from 0.1 to 0.2.osa2010-07-022-8/+7 * Mark ignore, useless without uep(4).osa2010-06-171-1/+8 * Add X.Org xf86-input-egalax driver, version 0.1.osa2010-06-025-0/+34 * Update to 1.2.1 in order to unbreak the build with X.org 7.5.marius2010-05-312-5/+4 * - Mark BROKEN on 6.X: does not compilepav2010-05-261-1/+7 * - Mark BROKEN on 6.X/amd64: does not compilepav2010-05-241-1/+7 * - Mark BROKEN: does not compilepav2010-05-243-0/+6 * - Mark BROKEN: does not compilepav2010-05-131-0/+2 * Pull in patch from git to fix BIOS read on 650 and 760rnoland2010-05-102-0/+12 * - Update to 2.1.17miwi2010-05-102-5/+5 * - Fix build on 6.Xmiwi2010-05-0734-33/+236 * - Fix build on 6.Xmiwi2010-05-0712-11/+84 * - Update to 12.6.7 (which also fix build on new xorg)miwi2010-05-062-5/+11 * Pull patches from git to fix build on newer Xorg.rnoland2010-05-042-1/+71 * Update to 1.4.1 (fix build with newer Xorg)rnoland2010-05-042-5/+4 * Pull patch from git to allow building with newer Xorg.rnoland2010-05-042-1/+76 * Add another patch to fix unresolved symbols.rnoland2010-05-042-1/+81 * - Update to Xorg 7.5miwi2010-05-01120-263/+1202 * - Add port for xf86-video-rdc, X.Org driver forstas2010-04-155-0/+36 * - Remove all broken Drivermiwi2010-03-271-9/+7 * x11-drivers/xf86-input-calcomp Unmaintained upstream. Notify x11 Maintainers...miwi2010-03-2749-403/+0 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * - Chase libpci shlib bumpfluffy2010-03-121-2/+2 * Chase xorg-server update and bump driver PORTREVISIONS.rnoland2010-02-0769-57/+69 * Limited Update to Mesa3D 7.6.1 and libdrm 2.4.17.nork2010-02-071-0/+4 * 2010-01-08 x11-toolkits/gtkada-gps: has been broken for 3 monthsmiwi2010-01-285-37/+0 * Fix the bsd.port.(pre|post).mk inclusion that was incorrectly removederwin2010-01-161-1/+3 * - USB module does not build on 8.x, turn it off by default in this case.pgollucci2010-01-15