aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2014-03-11 01:13:44 +0800
committerculot <culot@FreeBSD.org>2014-03-11 01:13:44 +0800
commitfc3a1781693b09a4dd0739178671eb4878379415 (patch)
treed1ca0759705a845d499557c65e3e60663061f3fc /misc
parent25b827806b76112495e2d390912f6667b7b3ce39 (diff)
downloadfreebsd-ports-gnome-fc3a1781693b09a4dd0739178671eb4878379415.tar.gz
freebsd-ports-gnome-fc3a1781693b09a4dd0739178671eb4878379415.tar.zst
freebsd-ports-gnome-fc3a1781693b09a4dd0739178671eb4878379415.zip
- Add misc/ossp-uuid-perl, a stub port of misc/ossp-uuid with Perl
bindings enabled. This is required for the upcoming new devel/p5-Iodef-Pb-Simple port - Register CONFLICTS and PKGNAMESUFFIX in misc/ossp-uuid Approved by: vd@ (maintainer, via email)
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ossp-uuid-perl/Makefile10
-rw-r--r--misc/ossp-uuid/Makefile5
3 files changed, 15 insertions, 1 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a47929f41b74..e3affccdc063 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -287,6 +287,7 @@
SUBDIR += openr2
SUBDIR += orville-write
SUBDIR += ossp-uuid
+ SUBDIR += ossp-uuid-perl
SUBDIR += otter
SUBDIR += p5-Acme-ButFirst
SUBDIR += p5-Array-Compare
diff --git a/misc/ossp-uuid-perl/Makefile b/misc/ossp-uuid-perl/Makefile
new file mode 100644
index 000000000000..bdfe73d6d755
--- /dev/null
+++ b/misc/ossp-uuid-perl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Frederic Culot <culot@FreeBSD.org>
+# $FreeBSD$
+
+COMMENT= ossp-uuid with Perl bindings
+
+MASTERDIR= ${.CURDIR}/../ossp-uuid
+
+WITH_PERL= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 0d3d2623020a..04fd1990201c 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uuid
PORTVERSION= 1.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
@@ -20,6 +20,8 @@ CONFIGURE_ARGS= --disable-shared --enable-static --with-cxx \
--includedir=${PREFIX}/include/ossp
.if defined(WITH_PERL)
+PKGNAMESUFFIX= -perl
+CONFLICTS= ossp-uuid-[0-9]*
MAKE_JOBS_UNSAFE= yes
USES+= perl5
CONFIGURE_ENV+= PERL=${PERL5}
@@ -30,6 +32,7 @@ CONFIGURE_ARGS+=--with-perl
MAKE_ARGS+= WITH_PERL=yes
PLIST_SUB+= WITH_PERL=''
.else
+CONFLICTS= ossp-uuid-perl-[0-9]*
PLIST_SUB+= WITH_PERL='@comment '
.endif