aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-24 12:01:45 +0800
committeredwin <edwin@FreeBSD.org>2002-11-24 12:01:45 +0800
commitff159034fc29345c141f0f12d544d83442e9b180 (patch)
tree4497e83ae91f347ba30a9254f9b446f3e8b251cd /misc
parente8069c464f4cee71c3d9a4a0b09b1f0aba369616 (diff)
downloadfreebsd-ports-gnome-ff159034fc29345c141f0f12d544d83442e9b180.tar.gz
freebsd-ports-gnome-ff159034fc29345c141f0f12d544d83442e9b180.tar.zst
freebsd-ports-gnome-ff159034fc29345c141f0f12d544d83442e9b180.zip
New port: misc/gkrellmfmonitor2
This plugin monitors a file and displays its contens in gkrellm. File can have multiple rows of the form 'name : value : [flag]'. Number of rows as well as their contnens can change dynamicaly. If flag non-empty then for WARNING value - the orange led will light up and for ALERT value - red. PR: ports/45660 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/gkrellmfmonitor2/Makefile26
-rw-r--r--misc/gkrellmfmonitor2/distinfo1
-rw-r--r--misc/gkrellmfmonitor2/files/patch-aa18
-rw-r--r--misc/gkrellmfmonitor2/pkg-comment1
-rw-r--r--misc/gkrellmfmonitor2/pkg-descr7
-rw-r--r--misc/gkrellmfmonitor2/pkg-plist1
7 files changed, 55 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 947a78f94a4a..418c886d8d6f 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -87,6 +87,7 @@
SUBDIR += gkrellmaflag
SUBDIR += gkrellmbgchg
SUBDIR += gkrellmfmonitor
+ SUBDIR += gkrellmfmonitor2
SUBDIR += gkrellmlaunch
SUBDIR += gkrellscore
SUBDIR += gkrellshoot
diff --git a/misc/gkrellmfmonitor2/Makefile b/misc/gkrellmfmonitor2/Makefile
new file mode 100644
index 000000000000..a1e9f7cfa5de
--- /dev/null
+++ b/misc/gkrellmfmonitor2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gkrellmfmonitor2
+# Date Created: 24 Nov 2002
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.2 2002/11/24 02:30:34 jylefort Exp $
+#
+
+PORTNAME= gkrellmfmonitor
+PORTVERSION= 2.0.2
+CATEGORIES= misc
+MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
+DISTNAME= gkrellm-fmonitor-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+
+MAKE_ENV+= MKDIR="${MKDIR}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+.include <bsd.port.mk>
diff --git a/misc/gkrellmfmonitor2/distinfo b/misc/gkrellmfmonitor2/distinfo
new file mode 100644
index 000000000000..ce3d603a46f8
--- /dev/null
+++ b/misc/gkrellmfmonitor2/distinfo
@@ -0,0 +1 @@
+MD5 (gkrellm-fmonitor-2.0.2.tgz) = 1035290281b593f5e22576d8884c6ab5
diff --git a/misc/gkrellmfmonitor2/files/patch-aa b/misc/gkrellmfmonitor2/files/patch-aa
new file mode 100644
index 000000000000..8930eaf2edb2
--- /dev/null
+++ b/misc/gkrellmfmonitor2/files/patch-aa
@@ -0,0 +1,18 @@
+--- Makefile.orig Sun Nov 24 01:53:03 2002
++++ Makefile Sun Nov 24 02:13:16 2002
+@@ -8,12 +8,14 @@
+ OBJS = fmonitor.o
+ SOBJ = fmonitor.so
+
++all: ${SOBJ}
+
+ $(SOBJ): $(OBJS)
+ $(CC) -shared `pkg-config gtk+-2.0 --libs` $(OBJS) -o $(SOBJ)
+
+ install:
+- cp $(SOBJ) /usr/local/lib/gkrellm2/plugins
++ ${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
++ ${INSTALL_DATA} ${SOBJ} ${PREFIX}/libexec/gkrellm2/plugins
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/misc/gkrellmfmonitor2/pkg-comment b/misc/gkrellmfmonitor2/pkg-comment
new file mode 100644
index 000000000000..5f610ec1d697
--- /dev/null
+++ b/misc/gkrellmfmonitor2/pkg-comment
@@ -0,0 +1 @@
+GKrellM FMonitor plugin
diff --git a/misc/gkrellmfmonitor2/pkg-descr b/misc/gkrellmfmonitor2/pkg-descr
new file mode 100644
index 000000000000..1200eb618b91
--- /dev/null
+++ b/misc/gkrellmfmonitor2/pkg-descr
@@ -0,0 +1,7 @@
+This plugin monitors a file and displays its contens in gkrellm. File can
+have multiple rows of the form 'name : value : [flag]'. Number of rows as
+well as their contnens can change dynamicaly. If flag non-empty then for
+WARNING value - the orange led will light up and for ALERT value - red.
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/misc/gkrellmfmonitor2/pkg-plist b/misc/gkrellmfmonitor2/pkg-plist
new file mode 100644
index 000000000000..506b0d9d345d
--- /dev/null
+++ b/misc/gkrellmfmonitor2/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm2/plugins/fmonitor.so
1'>| | | | | | | | | - Refactor pkg-plist as PLIST_FILES - Narrow CONFLICTS down to versioned packages [1]: PR: ports/84032 Submitted by: Jean Milanez Melo <jmelo@freebsdbrasil.com.br> * Pass maintainership to last submittergarga2005-07-291-1/+1 | * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-231-0/+2 | | | | at that time and no PRs have been submitted to fix it. * BROKEN: Size mismatchkris2005-07-091-0/+2 | * Note that math/ploticus now installs as bin/ploticus rather than bin/pl.linimon2005-03-071-1/+1 | | | | | | Remove obsoleted conflicts. Prodded by: vs * Unbreak by chasing checksum (minor source code changes, and a new datakris2004-03-062-3/+3 | | | | file). Add SIZE. * BROKEN: Checksum mismatchkris2004-02-221-0/+2 | * Add conflictsarved2004-02-021-1/+1 | | | | | PR: 62103 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de> * Fix checksums.edwin2003-10-041-1/+1 | | | | | | | | | | | | | | Comparing the old distfile from ftp.freebsd.org and the new one from sourceforge revealled a lot of documentation and code updates, which none looked suspicious. From the PR: Fixed a bug in truss graphics code for all versions. Also, the pre-compiled binary package slffeabin.tgz for is now compiled using dynamic Mesa libraries rather than static. RP: ports/57337 Submitted by: Mark Linimon <linimon@lonesome.com> * - Tarball was rerolled by author, it contains onlykrion2003-09-051-1/+1 | | | | bug fixes. * Add a conflict for ploticus, slffea and swi-pl.arved2003-06-291-0/+1 | | | | All install a program bin/pl. * De-pkg-comment.knu2003-02-212-1/+1 | * Fix PORTCOMMENTs that were killing INDEX builds.adamw2002-11-072-2/+1 | | | | | 105 pointy hats to: me Approved by: pat * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 | | | | Approved by: pat