aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-07-20 20:04:12 +0800
committerdes <des@FreeBSD.org>2002-07-20 20:04:12 +0800
commitffb363ca76662ff66f06f2d44b728340c258b584 (patch)
tree1fc0bd19d61b716ca1998653b3bf0e04e6c02cab /misc
parent2132ee3879a61074b35f315fb54a201ad0d4dfd2 (diff)
downloadfreebsd-ports-gnome-ffb363ca76662ff66f06f2d44b728340c258b584.tar.gz
freebsd-ports-gnome-ffb363ca76662ff66f06f2d44b728340c258b584.tar.zst
freebsd-ports-gnome-ffb363ca76662ff66f06f2d44b728340c258b584.zip
Use USE_REINPLACE and REINPLACE_CMD rather than implicitly depend on Perl.
Also replace glib-config in configure with glib12-config so the port can actually build. Note that it's still kinda broken as it requires recode 3.5 exactly and we have 3.6 in our tree, but at least now it'll work if you have recode 3.5 installed.
Diffstat (limited to 'misc')
-rw-r--r--misc/pybliographer/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/misc/pybliographer/Makefile b/misc/pybliographer/Makefile
index a3f85641d6a5..73699e0952aa 100644
--- a/misc/pybliographer/Makefile
+++ b/misc/pybliographer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pybliographer
PORTVERSION= 1.0.8
+PORTREVISION= 1
CATEGORIES= misc python gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/pyblio
@@ -24,15 +25,17 @@ USE_PYTHON= yes
USE_GNOME= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
Python="${PYTHON_CMD}"
CONFIGURE_ARGS= --with-recode-prefix="${LOCALBASE}"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|glib-config|glib12-config|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'