aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/avbin
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-09 04:33:43 +0800
committerwg <wg@FreeBSD.org>2013-10-09 04:33:43 +0800
commit5c78df390cd5a3702bd37dfa00dd36745fd51788 (patch)
tree13aa7a89b44538478381b5cd70a9d088c985296b /multimedia/avbin
parentb932ee354fe9f4e87a2d38b528c7574ea1985a95 (diff)
downloadfreebsd-ports-gnome-5c78df390cd5a3702bd37dfa00dd36745fd51788.tar.gz
freebsd-ports-gnome-5c78df390cd5a3702bd37dfa00dd36745fd51788.tar.zst
freebsd-ports-gnome-5c78df390cd5a3702bd37dfa00dd36745fd51788.zip
multimedia/avbin: link using ffmpeg0
- Link using ffmpeg0 Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'multimedia/avbin')
-rw-r--r--multimedia/avbin/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/multimedia/avbin/Makefile b/multimedia/avbin/Makefile
index 7b7c44cef669..d43a6893c148 100644
--- a/multimedia/avbin/Makefile
+++ b/multimedia/avbin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= avbin
PORTVERSION= 7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
http://mirror.amdmi3.ru/distfiles/
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= FFmpeg wrapper
-LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0
LIBNAME= libavbin.so.${PORTVERSION}
PLIST_FILES= lib/${LIBNAME} include/avbin.h
@@ -30,9 +30,10 @@ CFLAGS+= -fPIC
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -shared -Wl,-soname,${LIBNAME} -o ${LIBNAME} \
- src/avbin.c -Iinclude -I${LOCALBASE}/include \
+ src/avbin.c -Iinclude -I${LOCALBASE}/include/ffmpeg0 -I${LOCALBASE}/include \
-DAVBIN_VERSION=${PORTVERSION} -DFFMPEG_REVISION=0 \
- -L${LOCALBASE}/lib -lavcodec -lavformat
+ -L${LOCALBASE}/lib/ffmpeg0 -L${LOCALBASE}/lib \
+ -lavcodec0 -lavformat0
do-install:
${INSTALL_DATA} ${WRKSRC}/${LIBNAME} ${PREFIX}/lib