aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/bino/Makefile
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2017-11-19 03:38:30 +0800
committerzeising <zeising@FreeBSD.org>2017-11-19 03:38:30 +0800
commit03a56c512d641c9c18e61002e1cd7e57b29b1f0d (patch)
tree73820240fcb0d2aba93c875962e5b707a18e6164 /multimedia/bino/Makefile
parent32f3335a207ff23c5f7c3e592129656ebd9812cd (diff)
downloadfreebsd-ports-gnome-03a56c512d641c9c18e61002e1cd7e57b29b1f0d.tar.gz
freebsd-ports-gnome-03a56c512d641c9c18e61002e1cd7e57b29b1f0d.tar.zst
freebsd-ports-gnome-03a56c512d641c9c18e61002e1cd7e57b29b1f0d.zip
Update to 1.6.5
Switch to use QT5 Add patch to fix build with recent update to graphics/glew PR: 223426 Submitted by: zeising Approved by: maintainer timeout
Diffstat (limited to 'multimedia/bino/Makefile')
-rw-r--r--multimedia/bino/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
index 6e49fe6af23a..43a8f0999f4f 100644
--- a/multimedia/bino/Makefile
+++ b/multimedia/bino/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= bino
-PORTVERSION= 1.4.2
-PORTREVISION= 12
+PORTVERSION= 1.6.5
CATEGORIES= multimedia
-MASTER_SITES= http://download.savannah.nongnu.org/releases/bino/ http://levsha.me/ports/distfiles/
+MASTER_SITES= https://download.savannah.nongnu.org/releases/bino/
MAINTAINER= i@levsha.me
COMMENT= 3D video player with multi-display support
@@ -17,14 +16,17 @@ LIB_DEPENDS= libass.so:multimedia/libass \
libavformat.so:multimedia/ffmpeg \
libopenal.so:audio/openal-soft
-USES= desktop-file-utils gmake pkgconfig tar:xz
-USE_GL= glew
+USES= autoreconf desktop-file-utils gmake iconv pkgconfig tar:xz
+USE_GL= gl glu glew
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_QT4= moc_build opengl rcc_build
+USE_QT5= buildtools_build core gui opengl widgets
+USE_CXXSTD= c++11
# no port fow equalizer now, lirc detecting not working
-CONFIGURE_ARGS= --without-equalizer --without-liblircclient --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --without-equalizer --without-lirc --docdir=${DOCSDIR}
+
+EXTRA_PATCHES= ${FILESDIR}/glew-fix-7098cd6a.patch
INFO= bino