aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/bino/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-03-30 05:39:25 +0800
committerpawel <pawel@FreeBSD.org>2012-03-30 05:39:25 +0800
commit27462fcd792cb1ab43b24d63bf88a84808318388 (patch)
tree9580ca0233ffcb18152b5a1432b4d1c6f12dfd54 /multimedia/bino/Makefile
parent50d18b77b18fcdfc08b26602ef030bd75722cd3f (diff)
downloadfreebsd-ports-gnome-27462fcd792cb1ab43b24d63bf88a84808318388.tar.gz
freebsd-ports-gnome-27462fcd792cb1ab43b24d63bf88a84808318388.tar.zst
freebsd-ports-gnome-27462fcd792cb1ab43b24d63bf88a84808318388.zip
Bino is a video player with the following main features:
Support for stereoscopic 3D video, with a wide variety of input and output formats. Support for multi-display video, e.g. for powerwalls, Virtual Reality installations and other multi-projector setups. WWW: http://bino3d.org/ PR: ports/166389 Submitted by: Mykola Dzham <i@levsha.me> Feature safe: yes
Diffstat (limited to 'multimedia/bino/Makefile')
-rw-r--r--multimedia/bino/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
new file mode 100644
index 000000000000..a3807ac0d8b5
--- /dev/null
+++ b/multimedia/bino/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bino
+# Date created: 2012-03-12
+# Whom: Mykola Dzham <i@levsha.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bino
+PORTVERSION= 1.2.1
+CATEGORIES= multimedia
+MASTER_SITES= http://download.savannah.nongnu.org/releases/bino/ http://levsha.me/ports/distfiles/
+
+MAINTAINER= i@levsha.me
+COMMENT= 3D video player with multi-display support
+
+LICENSE= GPLv3
+
+FETCH_ARGS= -Fpr
+USE_XZ= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_ICONS= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build opengl rcc_build
+
+# no port fow equalizer now, lirc detecting not working
+CONFIGURE_ARGS+= --without-equalizer --without-liblircclient --docdir=${DOCSDIR}
+
+LIB_DEPENDS+= ass.5:${PORTSDIR}/multimedia/libass \
+ avformat.1:${PORTSDIR}/multimedia/ffmpeg \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ openal.1:${PORTSDIR}/audio/openal-soft
+
+MAN1= bino.1
+INFO= bino
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+# fixes build on non UTF-8 enviroments
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo $<|LANG=C; LC_ALL=C; &|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
cessibility?h=gnome-3.28&id=2af37586dd84334969fd869dcc6cb3d47829eccd'>Repeated words are are hard to to find sometimes.eadler2012-01-081-1/+1 * - Update ruby-gnome2 to 1.0.3swills2011-12-061-3/+1 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-146-11/+11 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-092-2/+0 * Fix build on FreeBSD 10kwm2011-10-301-0/+1 * Fix build on FreeBSD 10kwm2011-10-291-0/+1 * - remove maintainer tags from pkg-descreadler2011-10-232-4/+0 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-1722-10192/+53 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2417-33/+33 * - Re-enable on pointyhat, this is needed for gnome2 package ...pav2011-09-071-4/+0 * Mark as broken on pointyhat: runaway process (build never terminates).erwin2011-09-061-0/+4 * - Update to 1.7dhn2011-09-013-13/+8 * - Sort SUBDIRssunpoet2011-08-011-2/+2 * Update the glib and gtk stack to the lastest stable releases.kwm2011-07-306-13/+20 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-081-1/+1 * Update KDE Software Compilation ports to 4.6.5makc2011-07-085-10/+10 * Distfile was rerolled. Changes are build infrastructure changes, and some docs.kwm2011-06-291-2/+2 * Fix build with clangkwm2011-06-211-0/+42 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-145-10/+10 * Add patch to fix build.jlaffaye2011-06-102-2/+11 * Update KDE Software Compilation ports to 4.6.3makc2011-05-1712-64/+20 * Remove stale CMake argumentmakc2011-05-102-2/+2 * Add dependency on libXtst (needed to build kmousetool)makc2011-05-105-0/+5 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-075-10/+10 * Garbage collect expired portsrene2011-04-055-139/+0 * - Fix linking in some circumstances.avilla2011-03-285-5/+10 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-2519-17/+42 * - Fix PLIST issues with RUBY_VER == 1.9swills2011-03-191-1/+1 * - Get Rid MD5 supportmiwi2011-03-1914-17/+0 * Unify maintainer address for emulation ports.ehaupt2011-03-073-3/+3 * Add a more reliable mirrors for fc4 and f10 linux emulation ports.ehaupt2011-03-032-0/+2 * Deprecate all non-default Fedora based linux_base respectively linux-fx-*netchild2011-02-281-0/+3 * Chase after net/openldap24-server update.delphij2011-02-252-0/+2 * - Move over to python2.5 or highermiwi2011-02-251-1/+2 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-087-12/+10 * - Mark BROKEN: does not linkpav2011-01-071-0/+2 * Clean up ruby pkg-plists:pgollucci2010-12-201-4/+0 * - Chase speech-dispatcher shlib bump.avilla2010-12-092-2/+4 * - Update to 0.7.1.avilla2010-12-098-421/+35 * Disable alsa explicitlymakc2010-12-072-3/+2 * Sync to new bsd.autotools.mkade2010-12-043-3/+3 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-035-10/+10 * KDE FreeBSD team is glad to present Qt 4.7.1 in ports.makc2010-12-031-1/+1 * Update to 1.12.1.marcus2010-11-283-5/+37 * Update to 2.22.1.marcus2010-11-272-4/+3 * - Update to 0.90.5swills2010-11-271-1/+1 * Redshift adjusts the color temperature of your screen accordingwxs2010-11-255-0/+120 * Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for thiskwm2010-11-2031-139/+492 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-0410-20/+25 * Deprecate md5 in favour of sha256 checksums. md5 checksums will no longererwin2010-10-292-2/+2 * Improve handing of LD_LIBRARY_PATH when doing non-standard LOCALBASE builds.kmoore2010-10-161-1/+1 * - Update to 0.90.2swills2010-10-121-1/+3 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-067-21/+21 * - Add missing python virtual categoriespgollucci2010-09-141-1/+1 * - Update ruby-gnome ports to 0.19.4swills2010-09-112-0/+2 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-0323-404/+170 * - Chase speech-dispatcher upgrade.avilla2010-08-314-6/+14 * - Upgrade to 0.7.avilla2010-08-3117-283/+128 * Presenting GNOME 2.30.2. for FreeBSD.kwm2010-07-264-12/+10 * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-305-15/+15 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-025-15/+15 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-3113-5/+13 * - Note kdelibs4-experimental removalfluffy2010-05-111-0/+1 * - The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSDfluffy2010-05-1123-475/+313 * - The FreeBSD KDE team is pleased to announce Qt-4.6.2 for FreeBSDfluffy2010-05-111-1/+0 * Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-1136-70/+385 * - update to 1.4.1dinoex2010-03-2817-11/+17 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * - Mark BROKEN on HEAD: fails to build with new utmpxmiwi2010-03-201-1/+7 * - Replace long options with short ones: they are documented, but notavilla2010-03-083-4/+5 * - Fix build on 7.X amd64 and 6.X everywhere.avilla2010-02-1910-31/+231 * Presenting KDE 4.3.5 for FreeBSD. The official release notes for thismiwi2010-02-0715-45/+15 * - Mark BROKEN on 6.X everywhere and on 7.X amd64pav2010-02-061-0/+8 * - update to jpeg-8dinoex2010-02-0516-6/+16 * - Update my e-mail address in the ports I maintain.avilla2010-01-271-1/+1 * The FreeBSD KDE team is pleased to announce Qt-4.6.1 for FreeBSD.makc2010-01-223-17/+21 * - speech-dispatcher: try fix building on FreeBSD < 8.0fluffy2010-01-188-1/+301 * - Add speech-dispatcherfluffy2010-01-0816-0/+426 * Update to 2.28.3ahze2010-01-042-4/+4 * Update to 2.28.2.kwm2009-12-193-4/+22 * Update to 2.28.2.marcus2009-12-182-4/+4 * The FreeBSD KDE is please to announce the release of KDE 4.3.4,miwi2009-12-025-15/+15 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-2924-129/+245 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.3miwi2009-11-2710-25/+15 * - Update to Qt-4.5miwi2009-11-272-6/+0 * - Mark MAKE_JOBS_UNSAFEpav2009-11-201-0/+1 * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-025-15/+15 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-221-1/+1 * Fix the plist when doxygen is installed.marcus2009-08-161-0/+11 * Mk/bsd.kde4.mk:makc2009-08-105-15/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-0515-30/+35 * - s/MAKE_JOBS_SAVE/MAKE_JOBS_SAFEmiwi2009-08-051-1/+1 * - Update Qt4 to 4.5.2miwi2009-08-052-3/+4 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-033-3/+3 * Update to 0.15.8.marcus2009-08-022-4/+4 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-3115-5/+15 * Update to 0.15.7.marcus2009-07-073-4/+7 * Update to 2.26.3.avl2009-07-032-4/+4 * Update to 2.26.3.avl2009-07-013-4/+7 * Fix build with custom LOCALBASEitetcu2009-06-171-0/+2 * - Assign all unmaintained ruby ports to ruby@,stas2009-06-161-1/+1 * The KDE FreeBSD team is pleased to announce KDE 4.2.4, the last bugfixmiwi2009-06-035-15/+15 * . add linux-f10 ports to the rank of CONFLICTS for linux-fc4 ports;bsam2009-06-031-2/+2 * . add CONFLICTS to linux-f8 infrastructure ports;bsam2009-06-031-0/+3 * Here are new Linux Fedora 10 infrastructure ports.bsam2009-06-024-20/+24 * Update to 2.26.2.marcus2009-05-196-8/+50 * Update KDE ports to 4.2.3makc2009-05-105-15/+15 * Update to 4.10.1.marcus2009-05-103-4/+23 * mark as MAKE_JOBS_UNSAFEmakc2009-04-255-5/+5 * Presenting GNOME 2.26.1 for FreeBSD.kwm2009-04-244-10/+10 * Update to 0.15.6.marcus2009-04-122-4/+4 * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-1023-53/+219 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-0210-20/+20 * Here are new Linux Fedora 8 infrastructure ports.bsam2009-04-017-44/+75 * Finish repocopies of new linux-f8 infrastructure ports:bsam2009-04-011-1/+3 * bump PORTREVISION after cmake updatemakc2009-03-255-0/+5 * Release these ports into wild. I don't have time for these ports anymore. I ammezz2009-03-191-1/+1 * Update to 0.15.5.marcus2009-03-153-4/+7 * Update KDE to 4.2.1.makc2009-03-095-15/+15 * Update to 0.0.9.mva2009-03-082-4/+4 * Update to 0.4.25.marcus2009-02-232-4/+4 * Update to 2.24.4.kwm2009-02-213-7/+7 * Updated my mail address to use @FreeBSD.org now.mva2009-02-202-2/+2 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-0915-690/+1580 * - Update to 0.0.8beech2009-02-082-4/+4 * Update to 0.4.23.marcus2009-02-042-4/+4 * - Use GNOME macro instead of ${MASTER_SITE_GNOME}, removearaujo2009-02-026-12/+6 * Fix build after X.org 7.4 merge.flz2009-01-251-0/+2 * In preparation for adding new linux (Fedora 8) infrastructure ports all linuxbsam2009-01-223-21/+3 * kde@freebsd team is pleased to announce KDE 4.1.4, the last bugfix release in...makc2009-01-1410-20/+20 * kde@freebsd team is pleased to announce the update for Qt4 ports.makc2009-01-141-3/+3 * Update to 2.24.3.marcus2009-01-132-4/+4 * Update to 2.24.3.marcus2009-01-132-4/+4 * Remove these ports as they have been absorbed into other ports in GNOME 2.24.marcus2009-01-107-185/+0 * Presenting GNOME 2.24 for FreeBSD.marcus2009-01-1026-223/+479 * Bump PORTREVISION's after OpenLDAP update.delphij2009-01-061-1/+1 * - Update to 0.0.7miwi2008-12-253-7/+14 * linux_base-(fc6|f7|f8) have glib2 by itself. Don't depend uponume2008-11-293-0/+15 * Update to 0.4.22.mezz2008-11-202-7/+6 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.1miwi2008-09-035-15/+15 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-291-3/+3 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-211-1/+0 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-182-4/+3 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-1021-7190/+2766 * - File was rerolled to add missing example filemiwi2008-08-063-4/+8 * - Update to 0.0.6miwi2008-08-063-15/+20 * - Update to qt 4.4.1miwi2008-08-052-15/+16 * Update to 0.4.21.marcus2008-08-052-4/+4 * - Remove USE_GCC where it can be satisfied with base compiler on followingpav2008-07-251-1/+0 * - Update to 0.16.0.20080706, it's more than 0.17 RC1.mezz2008-07-071-2/+1 * Update to 2.22.3.mezz2008-07-013-5/+6 * Update to 2.22.3.mezz2008-07-013-5/+7 * Update to 1.22.3.marcus2008-07-012-5/+5 * Update to 0.4.20.marcus2008-06-182-5/+4 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-062-2/+2 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-0621-7/+21 * Fix typos.olgeni2008-06-051-1/+1 * Update to 2.22.2.mezz2008-05-272-4/+4 * Update to 2.22.2.mezz2008-05-274-14/+14 * -De-bashism and remove bash dependency. [1]mezz2008-05-062-6/+33 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-2010-16/+14 * Update to 0.4.19ahze2008-04-182-4/+4 * Update to 4.7.3.marcus2008-04-082-4/+4 * Update to 4.7.2.marcus2008-04-083-4/+8 * Update to 2.22.1ahze2008-04-083-4/+10 * Update to 1.22.1ahze2008-04-075-8/+11 * Update to 2.22.1.marcus2008-04-073-4/+5 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-251-1/+0 * The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 formarcus2008-03-2422-51/+314 * - Update to 0.6.9jadawin2008-03-172-6/+9 * Update to Qt 4.3.4lofi2008-03-141-3/+3 * YASR ("Yet Another Screen Reader") is an attempt at a lightweight,alepulver2008-02-175-0/+89 * EFlite is a speech server for Emacspeak and other screen readers that allowsalepulver2008-02-176-0/+90 * Update to 0.4.18.kwm2008-01-152-4/+4 * Update to 2.20.3.mezz2008-01-082-4/+4 * Update to 0.4.17.mezz2007-12-192-4/+4 * Update to 2.20.2.marcus2007-12-122-5/+5 * Update to 1.20.2.marcus2007-12-122-5/+5 * Add a missing dependency, at-spi. Bump the PORTREVISION.mezz2007-10-301-1/+2 * Update to KDE 3.5.8lofi2007-10-306-18/+18 * Update to 2.20.1ahze2007-10-292-4/+4 * Presenting GNOME 2.20.1 and all related works for FreeBSD. The officialmarcus2007-10-2540-1532/+1622 * - Update to 0.0.5lwhsu2007-09-163-12/+18 * Update to Qt 4.3.1.lofi2007-09-023-10/+8 * The tarball has been rerolled, no function change. They only update themezz2007-08-151-3/+3 * - bsd.qt.mk:lofi2007-08-032-9/+4 * Update to 0.4.16.mezz2007-07-302-4/+4 * Update to Qt 4.3.0, introduce bsd.qt.mk.lofi2007-07-162-23/+9 * Update to 0.4.15.mezz2007-07-102-4/+4 * Update to KDE 3.5.7 / KOffice 1.6.3lofi2007-07-0418-24/+318 * Update to 0.4.14.marcus2007-06-192-4/+4 * - Add WWWpav2007-06-071-0/+2 * Update to 0.4.13 and remove X11BASE.mezz2007-06-072-6/+6 * Update to 4.4.2.mezz2007-05-293-5/+23 * Update to 1.2.5.mezz2007-05-293-6/+20 * Update to 0.14.4.mezz2007-05-293-7/+25 * Update to 0.4.12.mezz2007-05-292-4/+4 * - Welcome X.org 7.2 \o/.flz2007-05-2025-290/+17 * Rename all binaries in qt4 which conflict with binaries installed bylofi2007-04-201-2/+2 * Update to 2.18.1ahze2007-04-113-5/+5 * Update to 0.4.11.mezz2007-04-102-5/+4 * - Fix the '==' -> '=' in configure.mezz2007-04-102-1/+20 * Update to 1.18.1ahze2007-04-092-4/+4 * Update to 4.4.1.marcus2007-04-093-4/+5 * Fix packaging.marcus2007-03-262-5/+4 * Fix packaging.marcus2007-03-261-0/+2 * Whoops, too greedy with the cvs add. Remove files that do not belong.marcus2007-03-252-0/+0 * Fix orca so that it actually runs. While here, replace some hardcoded pathsmarcus2007-03-255-0/+43 * Update to 4.2.3lofi2007-03-252-6/+6 * - Update to 0.0.4miwi2007-03-232-4/+4 * Add a missing BUILD_DEPENDS on X_CLIENTS_PORT.marcus2007-03-221-0/+2 * Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOMEmarcus2007-03-1926-75/+223 * Update to KDE 3.5.6 / KOffice 1.6.2lofi2007-03-146-18/+18 * Update to 1.2.3.mezz2007-03-012-4/+4 * Update to 1.2.2.mezz2007-02-282-4/+5 * Update to 0.4.10ahze2007-02-26