aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/bmpx
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2007-08-19 19:42:40 +0800
committernovel <novel@FreeBSD.org>2007-08-19 19:42:40 +0800
commitb352b0c6a3e3643aa54c429b279317691a15a0e1 (patch)
tree3a7205860d215ed1ee38e7417506abab6eb3afc6 /multimedia/bmpx
parentfe77974c6140bc5464792152e53ea7a7cf0f98a2 (diff)
downloadfreebsd-ports-gnome-b352b0c6a3e3643aa54c429b279317691a15a0e1.tar.gz
freebsd-ports-gnome-b352b0c6a3e3643aa54c429b279317691a15a0e1.tar.zst
freebsd-ports-gnome-b352b0c6a3e3643aa54c429b279317691a15a0e1.zip
- Remove neon, mp4v2 and fam dependencies, since they are not needed
anymore [1] - Disable hal support by default and andd WITH_HAL knob which turns it on. However bmpx with hal support might be not stable [1] - Mark BROKEN on 5.x [2] - Disable docs installation, they're pretty useless at this moment, but require additional dependencies Suggested by: David Le Brun [1] Repored by: pointyhat via kris [2]
Diffstat (limited to 'multimedia/bmpx')
-rw-r--r--multimedia/bmpx/Makefile22
-rw-r--r--multimedia/bmpx/files/patch-docs-Makefile.am23
-rw-r--r--multimedia/bmpx/pkg-plist29
3 files changed, 38 insertions, 36 deletions
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index a7d0d4176ebb..a9d3d245f85c 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bmpx
PORTVERSION= 0.40.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://files.beep-media-player.org/releases/0.40/
@@ -17,24 +18,20 @@ LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib \
cairomm-1.0.1:${PORTSDIR}/graphics/cairomm \
musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia \
- neon.26:${PORTSDIR}/www/neon \
glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
rsvg-2:${PORTSDIR}/graphics/librsvg2 \
boost_date_time.4:${PORTSDIR}/devel/boost \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- hal.1:${PORTSDIR}/sysutils/hal \
sexymm.2:${PORTSDIR}/x11-toolkits/libsexymm \
ofa.0:${PORTSDIR}/audio/libofa \
soup-2.2.8:${PORTSDIR}/devel/libsoup
CONFLICTS= bmpx-devel-[0-9]*
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= automake:19 autoconf:261
USE_BISON= yes
USE_BZIP2= yes
-USE_FAM= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
USE_GNOME= gtk20 libglade2 desktopfileutils
INSTALLS_ICONS= yes
@@ -53,6 +50,12 @@ CONFIGURE_ARGS+= --x-includes=${X11BASE}/include \
MAN1= beep-media-player-2.1
+.if !defined(WITH_HAL)
+CONFIGURE_ARGS+= --disable-hal
+.else
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.endif
+
.if defined(WITHOUT_STARTUP_NOTIFICATION)
CONFIGURE_ARGS+= --disable-sn
.else
@@ -79,11 +82,16 @@ PLIST_SUB+= SID="@comment "
.if defined(WITH_FAAD) || defined(WITH_MPEG4IP)
CONFIGURE_ARGS+= --enable-mp4v2
-LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
USE_GSTREAMER+= faad
PLIST_SUB+= MPEG4IP=""
.else
PLIST_SUB+= MPEG4IP="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile on 5.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/bmpx/files/patch-docs-Makefile.am b/multimedia/bmpx/files/patch-docs-Makefile.am
new file mode 100644
index 000000000000..0b4824b11756
--- /dev/null
+++ b/multimedia/bmpx/files/patch-docs-Makefile.am
@@ -0,0 +1,23 @@
+--- docs/Makefile.am.orig 2007-08-11 22:41:52.000000000 +0400
++++ docs/Makefile.am 2007-08-18 00:24:09.000000000 +0400
+@@ -1,19 +1,8 @@
+ EXTRA_DIST = book.xml style.css
+-SUBDIRS = images chapters xsl
++SUBDIRS = chapters xsl
+
+-if GENERATE_DOC
+-
+-all-local: *.html
+-pkgdoc_DATA = *.html
+-pkgdocdir=$(prefix)/share/doc/@PACKAGE@/html
+-*.html:
+- @XSLTPROC@ --output . $(top_srcdir)/docs/xsl/bump.xsl $(top_srcdir)/docs/book.xml
+-clean-local:
+- rm -f *.html
+-else
+ all-local:
+ clean-local:
+-endif
+
+ CLEANFILES=*.html
+ DISTCLEANFILES=$(CLEANFILES)
diff --git a/multimedia/bmpx/pkg-plist b/multimedia/bmpx/pkg-plist
index 06b504fb8521..0d8c69005bce 100644
--- a/multimedia/bmpx/pkg-plist
+++ b/multimedia/bmpx/pkg-plist
@@ -269,30 +269,6 @@ share/applications/bmp-play-2.0.desktop
%%DATADIR%%/images/throbber.gif
share/dbus-1/services/org.beepmediaplayer.sentinel.service
share/dbus-1/services/org.mpris.bmp.service
-%%DOCSDIR%%/html/apa.html
-%%DOCSDIR%%/html/ch01.html
-%%DOCSDIR%%/html/ch02.html
-%%DOCSDIR%%/html/ch02s01.html
-%%DOCSDIR%%/html/ch03.html
-%%DOCSDIR%%/html/ch03s01.html
-%%DOCSDIR%%/html/ch03s02.html
-%%DOCSDIR%%/html/ch04.html
-%%DOCSDIR%%/html/ch05.html
-%%DOCSDIR%%/html/ch06.html
-%%DOCSDIR%%/html/ch07.html
-%%DOCSDIR%%/html/ch08.html
-%%DOCSDIR%%/html/ch09.html
-%%DOCSDIR%%/html/index.html
-%%DOCSDIR%%/images/active-source.png
-%%DOCSDIR%%/images/bmp-logo-small.png
-%%DOCSDIR%%/images/bmp.png
-%%DOCSDIR%%/images/favicon.ico
-%%DOCSDIR%%/images/gradient.png
-%%DOCSDIR%%/images/important.png
-%%DOCSDIR%%/images/main-window.png
-%%DOCSDIR%%/images/playing-source.png
-%%DOCSDIR%%/images/rect1869.png
-%%DOCSDIR%%/images/tip.png
share/icons/hicolor/48x48/apps/bmpx.png
%%NLS%%share/locale/af/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/cs/LC_MESSAGES/bmpx.mo
@@ -322,11 +298,6 @@ share/icons/hicolor/48x48/apps/bmpx.png
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-@dirrm %%DOCSDIR%%/images
-@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
-@dirrmtry share/dbus-1/services
-@dirrmtry share/dbus-1
@dirrm %%DATADIR%%/images/svg
@dirrm %%DATADIR%%/images/stock
@dirrm %%DATADIR%%/images/sources